Attachments in forwarded mails(message/rfc822 part) should not appear like attachments in "top" mail

NEW
Unassigned

Status

SeaMonkey
MailNews: Message Display
19 years ago
6 years ago

People

(Reporter: Henrik Gemal, Unassigned)

Tracking

(Blocks: 1 bug, {helpwanted})

Trunk
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Currently the attachments for forwarded mails are shown in the dropdown 
attachment box, as described in:
http://bugzilla.mozilla.org/show_bug.cgi?id=23634

But this is somewhat wrong. With the current implementation it's impossible to 
see by the dropdown attachment box who attached which attachments.
For the user it will look like the last sender attached all the attachment, 
which he might have done and which he might NOT have done.

The "right" solution would be a dropdown attachment box next to each forwarded 
mail, and not just show all attachments in the "top" mail.

Comment 1

19 years ago
Sorry, I can tell you I am not going to get to this one before shipping.

- rhp
Keywords: helpwanted
Target Milestone: --- → M30

Updated

19 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 2

19 years ago
That's alright...:)
The currently implementation is ok, but just not "right".
(Reporter)

Comment 3

18 years ago
Just changing subject.
Summary: Attachments in forwarded mails → Attachments in forwarded mails should be shown next to mail and not in "top" mail

Updated

18 years ago
QA Contact: lchiang → pmock

Comment 4

18 years ago
moving to future milestone.
Target Milestone: M30 → Future

Comment 5

18 years ago
Assign it to fenella@netscape.com
QA Contact: pmock → fenella

Comment 6

18 years ago
reassigning to ducarroz
Assignee: rhp → ducarroz
Status: ASSIGNED → NEW

Comment 7

18 years ago
To Esther...
QA Contact: fenella → esther
won't fix.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX

Updated

17 years ago
QA Contact: esther → trix

Comment 9

17 years ago
verified resolution
Status: RESOLVED → VERIFIED
I have changed my mind. We won't put an attachment box next to each inline
message but rather we could show an hierarchic list at the top. Also, I have a
fix in my tree which change the order we show the attachment in the list, I'll
show first the inline message and then it's attachment.
Status: VERIFIED → REOPENED
Resolution: WONTFIX → ---

Updated

16 years ago
Status: REOPENED → ASSIGNED
QA Contact: trix → stephend

Comment 11

14 years ago
xref bug 203570.

Since it is now possible to open attached messages into their own message 
window, this bug could be fixed by simply showing the attachments belonging to 
the top-level message, ignoring the nested ones.  However, bug 203570 would need 
to be fixed so that the message window for the attached mail shows only the 
attachments belonging to it.
Product: Browser → Seamonkey
Add "message/rfc822" to summary for ease of search.
Summary: Attachments in forwarded mails should be shown next to mail and not in "top" mail → Attachments in forwarded mails(message/rfc822 part) should be shown next to mail and not in "top" mail
Depends on: 269826
Blocks: 269826
No longer depends on: 269826
[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.9a1) Gecko/20051028 SeaMonkey/1.1a] (nightly) (W98SE)

Bug still there,
confirmed by bug 203570 comment 33 too.

Comment 14

13 years ago
I think it's much more convenient to show the nested attachments in the top level msg. That saves you having to open the message/rfc822 attachment in a new window in order to see the attachments.
(In reply to comment #14)
> I think it's much more convenient to show the nested attachments in the top

I could concur with that;
yet some way to distinguish the actual attachments from the nested ones could be interesting;
may be as "an hierarchic list" as suggested in comment 10 ?

Comment 16

13 years ago
Discovered while investigating bug 328324: the forwarded message's 
attachments don't appear in the containing message's attachment panel if 
Display Attachments Inline is turned off.
Assignee: ducarroz → mail
Status: ASSIGNED → NEW
OS: Windows 2000 → All
QA Contact: stephend
Hardware: PC → All

Updated

12 years ago
Duplicate of this bug: 328324
(In reply to comment #11)
> xref bug 203570.
> Since it is now possible to open attached messages into their own message 
> window, this bug could be fixed by simply showing the attachments belonging to 
> the top-level message, ignoring the nested ones.  However, bug 203570 would need 
> to be fixed so that the message window for the attached mail shows only the 
> attachments belonging to it.

Bug 203570 IS fixed (thank you so much!!!), at least for those cases where the top msg is stored locally/non-IMAP (see my comm. 62 in bug 203570). So, to quote comment #11, "this bug could be fixed by simply... ignoring nested ones [attachments]"? As Mike's comment #16 points out, this bug 35587 does NOT occur when "show attachments inline" is OFF. I conclude from this:

==> There are two different sets of code for displaying the attachment panel:
1) a correct one (when "attachments inline" is OFF), and
2) a buggy one (when "attachments inline is ON").

In other words (correct me if I'm wrong): the patch for this bug is already existant, namely in the code fragment (2) that *correctly* displays the attachment panel when "view attachments inline" is OFF.

So perhaps there is hope on the horizon for a quick & easy fix to this age-old and often-duped bug? Would be another nice little step ahead towards resolving the whole issue of message/rfc822 .eml attachments as documented in meta Bug 269826?
Priority: P3 → --
QA Contact: search
Target Milestone: Future → ---
Assignee: mail → nobody
QA Contact: search → message-display

Comment 19

7 years ago
Created attachment 561074 [details]
Sample message with message/rfc822 attachment having its own attachments

TB 6.0.2 on Windows
The bug isn't fixed yet.

And the inline display of attachments makes the rfc822 attachment to be displayed under the wrong name (namely, the name of the previous attachment)

Updated

6 years ago
Duplicate of this bug: 646363

Comment 21

6 years ago
Like comment 14 says, I think it's more convenient to show nested attachments. However, there's no easy way to show them as a tree in the current layout. I have an add-on[1] which does this, but I think it's a bad default, since it's really wasteful with space. I also don't really think it should go in-tree, since it's a lot of code for something that I think relatively few people will need.

I'm not averse to adding a pref for this for people (or businesses) who suffer from the ambiguity this causes. I know that adding prefs is the lazy way out of making a decision, but short of redesigning the attachment pane again, I don't see a good way of optimizing for both cases without a pref. I'd argue that it's reasonable to add prefs for cases where we can't/won't make one UI to rule them all. Granted, add-ons can fill that role, but I don't much like the idea of add-ons to fix bad UX, even if it's for a minority of users.

Thoughts?

[1] https://addons.mozilla.org/en-US/thunderbird/addon/attachment-tree/

Updated

6 years ago
Summary: Attachments in forwarded mails(message/rfc822 part) should be shown next to mail and not in "top" mail → Attachments in forwarded mails(message/rfc822 part) should not appear like attachments in "top" mail
You need to log in before you can comment on or make changes to this bug.