saving images using context menu saves the entire message

RESOLVED DUPLICATE of bug 270772

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 270772
14 years ago
14 years ago

People

(Reporter: Kostub, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316

If I have a gif image in my mail and I right click on it, I get a context menu.
If I select "Save Image As" from the menu, and try and save the file, the image
does not get saved correctly. If I open the saved file in a text editor, it is
the actual mail with the images being mime encoded.

Reproducible: Always
Steps to Reproduce:
1. Send yourself a mail with gif images attached.
2. Right click on the image and select "Save Image As"
3. Enter a file name and save the image.


Actual Results:  
4. Try opening the file with a program that displays gifs. It does not open it.
5. Open the file in a text editor. The text of the mail will be present.

Expected Results:  
It should have just saved the image as an actual gif file. I tested this with
Thunderbird 0.5 and it does the right thing.

Comment 1

14 years ago
I'm unable to reproduce this problem with
  Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040316

Comment 2

14 years ago
Confirm with Thunderbird 0.5+ (20040323) on WinXP. Only occurs if View - Message 
body as is "Original HTML" or "Simple HTML". Does not occur is setting is "Plain 
Text"

Comment 3

14 years ago
Just to be sure: are the images exhibiting this problem attachments to the 
message (appear in the Attachments panel) or are they embedded into the HTML 
message?  Is the message multipart/alternative or simply multipart/mixed?

This might, possibly, only be a Windows-XP problem, altho that seems unlikely.  
I'm not seeing the problem with 1.7b-0324 under Win2K.  Bug 238943, which 
appears to be a dupe, is filed as a WinXP bug -- and, I should note, explicitly 
states that the image is an attachment displayed inline.

Comment 4

14 years ago
Images embedded in HTML. 

Message was sent from MS Outlook. 

Mime headers:

Content-Type: multipart/related;
	boundary="----_=_NextPart_001_01C417CD.BEB38C03";
	type="multipart/alternative"

This is a multi-part message in MIME format.

------_=_NextPart_001_01C417CD.BEB38C03
Content-Type: multipart/alternative;
	boundary="----_=_NextPart_002_01C417CD.BEB38C03"


------_=_NextPart_002_01C417CD.BEB38C03
Content-Type: text/plain;
	charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

I could not reproduce this with message sent from Thunderbird, but occurs with
(some) messages sent from Outlook.

Comment 5

14 years ago
OK, can you generate a (small) sample message that exhibits the problem?  If so, 
save it as a .EML file and attach it to this bug.

Comment 6

14 years ago
Created attachment 148174 [details]
Message exhibiting the problem

Comment 7

14 years ago
Even if you select 'View Image' from the context menu (opens in Browser window),
and then try and save the image via the context menu from there, the entire
message is saved.

Comment 8

14 years ago
Well, I integrated the attached message from <odi> into my mail, and what I'm 
seeing is that right-clicking on the image and saving it saves only the image.  
The one thing that is a little odd is that the selected filename is the same as 
the name of the mail folder -- in my case, I use a folder called XAttach to hold 
messages with attachments that I'm testing for Bugzilla, and the image was saved 
as "XAttach" (no file extension).  Also, the preselection for "Save as Type" is 
"All Files".

If I edit the message in the mbox, and change the Content-Type header for the 
image portion to include a filename:
  Content-Type: image/gif; name="crude.gif"
then that filename is suggested by default, and the "Save as Type" is preset to 
"Image."

One viewer program I have parsed the saved file and recognized the GIF89 tag at 
the beginning, and so showed it as an image.  Switching to a hex view, it was 
obvious that there was nothing but the GIF stored in the file.
Product: Browser → Seamonkey

Comment 9

14 years ago
Bug 270772 reports a very similar symptom which is easily reproducible.
In that case, the message has been saved as a .EML file and then opened in a 
browser; under those circumstances, trying to save any image part of the message 
file results in saving the entire message, as described here.

Note that images in the message are not displayed correctly on opening in the 
browser -- see bug 174692.

Reporter (Kostub) -- does this match your situation?  Were you viewing the .EML 
file in the browser when you encountered this problem?  If so, please mark this 
bug as a duplicate of 270772.

Comment 10

14 years ago
No response from reporter, duping.

*** This bug has been marked as a duplicate of 270772 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.