Bad crash when opening nonexistant file

VERIFIED WORKSFORME

Status

SeaMonkey
UI Design
P2
critical
VERIFIED WORKSFORME
18 years ago
13 years ago

People

(Reporter: Richard Zach, Assigned: travis)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
When trying to open an non-existant file, instead of getting a "file not found"
error, you get a blank browser window, memory usage increases rapidly.  Finally,
when the swap space is full, my terminal hangs, and only an X-server shutdown
from another terminal will make it usable again.

To reproduce:
1. Open file:///nonexistant or File | Open File | nonexistant

Actual result:
Browser window goes blank, memory usage increases until termianl dies
Expected result:
"File not found" error message

Linux build 2000.01.13.08

Updated

18 years ago
Assignee: don → travis
Priority: P3 → P2
Target Milestone: M14

Comment 1

18 years ago
Travis, is this a URL loading problem?  If so, who should get this?  Rick?

(BTW, I think we can kick this out to M15 if we have to.)

Updated

18 years ago
QA Contact: paulmac → shrir

Comment 2

18 years ago
I see this also on linux also. Had to reboot.

Shrir, and you check this out on mac and windows?

Comment 3

18 years ago
Is this related to bug #21873 (blank file name in download dialog causes crash)?
(Reporter)

Comment 4

18 years ago
The symptoms of 21873 are very different.  There, you start the download and
crash imediately with a SEGFAULT.  Here, you don't crash, you jsut overload the
system until it shuts down.  If you hist CTRL-C in gdb and say where, this is
what you get:

0x402a27d0 in __poll (fds=0xbf5ffcbc, nfds=1, timeout=28854)
    at ../sysdeps/unix/sysv/linux/poll.c:45
../sysdeps/unix/sysv/linux/poll.c:45: No such file or directory.
(gdb) where
#0  0x402a27d0 in __poll (fds=0xbf5ffcbc, nfds=1, timeout=28854)
    at ../sysdeps/unix/sysv/linux/poll.c:45
#1  0x40150a74 in PR_Poll ()
#2  0x403fff22 in NSGetModule ()
#3  0x400f5f2f in nsThread::Main ()
#4  0x40151b0e in PR_Select ()
#5  0x40165ce9 in pthread_start_thread (arg=0xbf5ffe7c) at manager.c:204

Comment 5

18 years ago
I am getting with same resource hog, ugly crash on windows when entering

file:///fklajdsflksd

Comment 6

18 years ago
I tried this on Mac and Windows and had to restart my systems.

Updated

18 years ago
OS: Linux → All

Comment 7

18 years ago
same thing.  Window's NT when I try to get a local file listing using c:\.  Blue
screen.  Changing OS from Linux to All.

Comment 8

18 years ago
Adding "crash" keyword to all known open crasher bugs.
Keywords: crash
(Reporter)

Comment 9

18 years ago
I don't see this anymore on Linux build 2000.01.30.09.  Fixed on Mac and Windows
as well?

Although I don't get an alert, the console says:
Error loading URL file:///test 

Comment 10

18 years ago
yes, this works for me okay on windows/mac also, marking worksforme with 1/31 
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 11

18 years ago
verified
Status: RESOLVED → VERIFIED
(Reporter)

Comment 12

18 years ago
Should this be open until the "expected result" happens, which is a "file not
found" alert?  Or is that bug 20445?

Comment 13

18 years ago
I'll open a new bug and cc: you
(Reporter)

Comment 14

18 years ago
Don't: I just found it.  Bug 19073.
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.