No network error messages thru dialog

VERIFIED FIXED in M14

Status

()

Core
Networking
P3
major
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: Richard Zach, Assigned: Judson Valeski)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
There are, as yet, no warning messages displayed when a network error prevents a
page from loading, or a newsgroup from being opened, etc.  I'm thinking about
DNS lookup failures, refused connections, servers down.  I think this is pretty
important from the user's perspective since it is usually not obvious why
something isn't working in these cases.

To reproduce:
1. Enter nonexisting URI in location field
2. Press enter

Actual result: Throbber indicates page loading, progress bar shows "Document:
Done", but no new page is displayed

Expected result: A window with a warning message a la NS 4.x's "Netscape is
unable to locate the server xyz.  Please check the name and try again."

Comment 1

19 years ago
Mass move of all bugs without target milestones to M13.

Comment 2

19 years ago
Bulk move of all Networking-Core (to be deleted component) bugs to new
Networking component.

Updated

19 years ago
Status: NEW → ASSIGNED
Summary: No warnings on error messages → No network error messages thru dialog

Comment 3

19 years ago
updating the summary.

Comment 4

19 years ago
Subsumes 14696. Probably a dup of something else too, but I can't find it now.

Updated

19 years ago
Assignee: gagan → valeski
Status: ASSIGNED → NEW

Comment 5

19 years ago
-> jud

Updated

19 years ago
Target Milestone: M13 → M14

Comment 6

19 years ago
Socket transport needs to propagate up the right error codes, and the webshell
needs to notice them.
(Reporter)

Comment 7

19 years ago
Created attachment 4199 [details]
Drafts folder b/4 move
(Reporter)

Comment 8

19 years ago
Sorry, wrong bug.
(Assignee)

Comment 9

19 years ago
DNS failure dialog is in. So is un-registered protocol.

We need to throw dialogs when a server is resolvable, but not connectable
(either it's down or won't accept a connection on that port).
(Reporter)

Comment 10

19 years ago
I noticed that there's also no error message for FTP file not found problems:

go to ftp://ftp.mozilla.org/test
Actual result:
Console shows "Error loading URL ftp://ftp.mozilla.org/test" but otherwise
nothign happens
Expected result: File not found error message
(Assignee)

Comment 11

19 years ago
see 18007
Status: NEW → ASSIGNED
(Assignee)

Comment 12

19 years ago
I have a fix for the rest of this. Awaiting review.
(Assignee)

Comment 13

19 years ago
fix checked in 1/24/00 7:50 pm pac time. I just added error capturing and dialog 
throwing for connection_refused errors and socket timeout errors.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Reporter)

Comment 14

19 years ago
Would you be responsible also for local file errors (file not found, permission
denied)? Bug 26097.
(Assignee)

Comment 15

18 years ago
*** Bug 28065 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 16

18 years ago
*** Bug 25507 has been marked as a duplicate of this bug. ***

Comment 17

18 years ago
verified:
Linux 2000022108
NT 2000022108
Mac 2000022108
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.