Starting mozilla prints "No running window found" every time

RESOLVED FIXED

Status

()

RESOLVED FIXED
15 years ago
13 years ago

People

(Reporter: bzbarsky, Assigned: bryner)

Tracking

({fixed1.7, regression})

Trunk
x86
Linux
fixed1.7, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
BUILD:  2004-04-10 CVS build

STEPS TO REPRODUCE:  Type "./mozilla" in dist/bin

ACTUAL RESULTS:
1)  Prints "No running window found"
2)  Starts the browser

EXPECTED RESULTS: Just start the browser, without printing garbage to the
console (printing an error message when there is no error, expecially in a
release build, is bad).

This looks like a regression from bug 237283.  At a guess, the mozilla startup
scripts need to redirect the error message from their non-forced attempt at
xremote to /dev/null.
(Reporter)

Updated

15 years ago
Flags: blocking1.7?
(Assignee)

Comment 2

15 years ago
Created attachment 145843 [details] [diff] [review]
patch

Don't send an xremote command if no -remote argument was given.
Assignee: blizzard → bryner
Status: NEW → ASSIGNED
(Assignee)

Updated

15 years ago
Attachment #145843 - Flags: superreview?(blizzard)
Attachment #145843 - Flags: review?(blizzard)
(Reporter)

Updated

15 years ago
Blocks: 240238
(Reporter)

Comment 3

15 years ago
I'm also getting "Error: Failed to send command: No response included." a lot
(coming at startup, right after 2-3 seconds of doing nothing).  Also this bug,
or should I file a separate one?
(In reply to comment #3)
> I'm also getting "Error: Failed to send command: No response included." a lot

I have also seen it, but only when I didn't specify a -P option on startup
(Reporter)

Comment 5

15 years ago
I never specify -P, since there is only one profile involved.
Comment on attachment 145843 [details] [diff] [review]
patch

good catch.  should include this as part of 1.7, too.
Attachment #145843 - Flags: superreview?(blizzard)
Attachment #145843 - Flags: superreview+
Attachment #145843 - Flags: review?(blizzard)
Attachment #145843 - Flags: review+
Attachment #145843 - Flags: approval1.7?
(Assignee)

Comment 7

15 years ago
checked in on trunk (will check in on 1.7 branch once it is open)
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 8

15 years ago
*** Bug 240399 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

15 years ago
Keywords: fixed1.7
(Reporter)

Updated

15 years ago
Flags: blocking1.7?

Comment 9

14 years ago
*** Bug 200194 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.