"dowload error" appears during "save image as..." from browser context menu

VERIFIED DUPLICATE of bug 240367

Status

SeaMonkey
Download & File Handling
--
major
VERIFIED DUPLICATE of bug 240367
14 years ago
13 years ago

People

(Reporter: roseman, Assigned: Darin Fisher)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7b) Gecko/20040421
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7b) Gecko/20040421

visit a web page with images using Mozilla 1.7-RC1. right-click on an image.
from the context menu that pops up, select "save image as..." then save the
image to disk (anywhere). suddenly an error message box pops up saying "Download
Error" while listing the domain name of the web page you were visiting. It will
turn out that the image has successfully been saved to disk, but after a very
scary message. the download manager, if used, will then afterwards pop up
showing "failed" 0 bytes saved. but the saved file seems to be ok. 1.7-beta
NEVER did this, but 1.7-RC1 does (although 1.7-rc1 seems to call itself rv:1.7b
Gecko/20040421) 

Reproducible: Always
Steps to Reproduce:
1. visit web page with pictures. 
2. right click on an image, then select "save image as" 
3. after clicking on "save", watch "Download Error" message pop up in middle of
screen. 

Actual Results:  
turns out image file WAS saved properly, depsite "download error" message and
despite dowload manager saying "failed 0 bytes".

Expected Results:  
should have not given "download error" popup when file was actually saved properly.

Comment 1

14 years ago
Already fixed.

*** This bug has been marked as a duplicate of 240367 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

14 years ago
http://www.mozillazine.org/talkback.html?article=4650#69 
was what drew my attention to this initially. tested it immediately (i had
already switched to 1.7-RC1) and found exact same behaviour as original poster
(nicknamed "Tar"). forgot to give credit where credit due, sorry (*blush*). most
of my time at home surfing is spent looking at & saving images. a bug like this
would affect me CONSTANTLY! i am sure there are many surfers out there who do
same, though most probably do not save images all that often,
(Reporter)

Comment 4

14 years ago
(In reply to comment #1)
> Already fixed.
> 
> *** This bug has been marked as a duplicate of 240367 ***

i quesried bugzilla, searching for "download error" in "Step 1, search for your
bug"; 240367 does NOT appear in the long list of bugs shown! i did my part, i
searched to see if mine was a duplicate. there was none  :(  i could have saved
you time if the Step-1-search-for-your-bug had picked up 240367 from the search:
download error.
(In reply to comment #4)
> i quesried bugzilla, searching for "download error" in "Step 1, search for your
> bug";

bugs marked VERIFIED are probably not included in that search... I wonder whose
bright idea that was.

Updated

14 years ago
Component: Networking: File → Download Manager

Comment 6

14 years ago
Reporter, check out  bug 241945 and the links therein.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.