If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Thunderbird needs to register as default handler of mailto protocols

RESOLVED DUPLICATE of bug 252056

Status

Thunderbird
Preferences
RESOLVED DUPLICATE of bug 252056
14 years ago
9 years ago

People

(Reporter: Ben Goodger (use ben at mozilla dot org for email), Assigned: Brian Ryner (not reading))

Tracking

(Blocks: 1 bug)

unspecified
Thunderbird0.8
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Thunderbird needs to register itself as the default handler of the mailto
protocol on GNOME. Firefox will do this by implementing a GNOME version of
nsIShellService - nsGNOMEShellService. Thunderbird should do something similar.
Ideally the windows registration code tbird already uses would be massaged into
a nsWindowsShellService, ditto for nsMacShellService. 

This is a high visibility issue presently because people are having to manually
set default browser/mail handlers on linux - even though scripts make this a
little easier, it should be as automatic as it is on Windows. 

The preferred back end for this bryner tells me is gconf.
Blocks: 233462

Updated

14 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Thunderbird0.7

Comment 1

14 years ago
Tempted to DUP this to Bug #202497, except that one is WinXP, and this one is
*nix, and the fixes will be somewhat different.

Updated

14 years ago
Target Milestone: Thunderbird0.7 → Thunderbird0.8

Comment 2

13 years ago
Brian is working on this
Assignee: mscott → bryner
Status: ASSIGNED → NEW

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 252056 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.