Thunderbird should set itself as default mail/news client on GNOME

VERIFIED FIXED

Status

Thunderbird
General
VERIFIED FIXED
14 years ago
13 years ago

People

(Reporter: Brian Ryner (not reading), Assigned: Brian Ryner (not reading))

Tracking

({fixed-aviary1.0})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

14 years ago
Thunderbird should support setting itself as the default mail and/or news client
for GNOME, as it does on Windows.
(Assignee)

Comment 1

14 years ago
Created attachment 153628 [details] [diff] [review]
patch (new files are first, diffed separately)

This implements some code very similar to nsGNOMEShellService in Firefox,
except that it conforms to nsIMapiRegistry... which, despite the name, is
fairly generic.

One thing I decided not to support is _un_setting Thunderbird as the default
mail/news client.  There are plenty of other ways a user can do that, and I
don't think we are obligated to include it in our UI.  mscott tells me we do
need to on Windows because we install our own MAPI dll and need to restore the
original one when we no longer want to be the default.	There's no similar
situation on GNOME, so I changed the UI to be more like what Firefox has.

By default it prompts for being the default mail client; you have to go
specifically tell it to be the default news client since that's less common. 
If it turns out we want to have it offer to be the default news client by
default, I'll either need to roll it into an all-or-nothing setting or combine
them into one dialog (throwing up _two_ dialogs about it on startup would
suck).

This includes a port of the start script changes that Firefox got recently to
better handle communicating with a running instance.  The only difference is
that if you don't give a URL to load I call openInbox rather than openBrowser.

Also, to avoid adding yet another shared library, I merged this with the
migration module.
(Assignee)

Updated

14 years ago
Attachment #153628 - Flags: review?(mscott)

Comment 2

14 years ago
Comment on attachment 153628 [details] [diff] [review]
patch (new files are first, diffed separately)

I'm not sure what these macros are supposed to do:

NS_HIDDEN_

I'm assuming it's a unix build thing and trust your judgement.

I see you added a new mail\components\build directory and moved some stuff out
of mail\migration\src. The module registration for the migration stuff has
changed quite a bit on the branch and the trunk in the last week or so. Make
sure your removal of that stuff is up to date so we don't lose any module
registration info for migration. 

Thanks again for doing this Brian.

With these changes, can I now obsolete:

http://www.mozilla.org/projects/thunderbird/linuxurls.html

with the next release?

Updated

14 years ago
Attachment #153628 - Flags: review?(mscott) → review+

Comment 3

14 years ago
Whould be cool to see this checked in.
Any plans?
Flags: blocking-aviary1.0?
(Assignee)

Comment 4

14 years ago
checked in on trunk and aviary branch.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Keywords: fixed-aviary1.0
Resolution: --- → FIXED

Comment 5

14 years ago
messenger-mapi needs to be added to en-US-jar.mn for the US -> en-US jar move.

Comment 6

14 years ago
This doesn't seem to work in the trunk and aviary Linux builds from 20040729. 
(Is this the point that comment 4 is making?)  Neither sets the default app, and
both give the following JavaScript error when "Check Now" is pressed:

Error: uncaught exception: [Exception... "Component returned failure code:
0x8000ffff (NS_ERROR_UNEXPECTED) [nsIStringBundle.formatStringFromName]" 
nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame ::
XStringBundle :: getFormattedString :: line 33"  data: no]

I'm running RedHat Linux 9 with GNOME 2.2.

Comment 7

14 years ago
Re my comment 6, Aviary 20040730 seems okay.

Comment 8

14 years ago
*** Bug 242255 has been marked as a duplicate of this bug. ***

Comment 9

14 years ago
Has this caused regression bug 253475? The checkins to mozilla/mailnews are
affecting MailNews, right? It seems that the locale for messenger-mapi was moved
from en-win.jar to en-US.jar, but none of the packaging or installer files were
changed for windows to reflect that (like in Bug 253617).

Updated

14 years ago
Flags: blocking-aviary1.0?

Comment 10

14 years ago
This broke installer builds because they're still looking in en-win for the mapi
locale.
this has been working nicely; vrfy'ing fixed with recent aviary1.0 tbird builds
on linux fc2.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.