"open in tabs" fails to fully put focus in first tab's text entry box

VERIFIED DUPLICATE of bug 124750

Status

()

Firefox
General
--
minor
VERIFIED DUPLICATE of bug 124750
14 years ago
14 years ago

People

(Reporter: itsayellow@gmail.com, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

When using "open in tabs" to open a few web pages at a time from a bookmark
folder, the page opened in the first tab has text focus problems.

I use
https://login.yahoo.com/config/login?.done=http://mail.yahoo.com/
as my first bookmark, which opens in the first tab.  Sometimes when I "open in
tabs" the yahoo page comes up as always, the cursor is blinking in the
"username" textbox, but typing doesn't cause any letters to show up.  This
behavior ALWAYS happens if the first act after starting the browser is to "open
in tabs".

pressing tab once makes focus go to the url bar
pressing tab again makes focus go (elsewhere?)
pressing tab again focuses on the whole web page of the first tab
pressing tab again goes to the password text box (second text box)

then, pressing shift-tab goes back to the username text box. (that was
originally skipped in the tab sequence)

I see this behavior in Firefox 0.8, and also in the nightly firefox build 20040503

Reproducible: Always
Steps to Reproduce:
1. Start Firefox
2. click "open in tabs" on a bookmark folder that uses the following url as the
first bookmark:
https://login.yahoo.com/config/login?.done=http://mail.yahoo.com/
3. observe the cursor blinking in the entry box for 'username'
4. Try typing in a username

Actual Results:  
No text is typed, despite the cursor still blinking in the username text box

Expected Results:  
put letters from keystrokes into the username field

Orig. theme.
Happens both on WinXP and Win2000
Both with Firefox 0.8 and with Firefox 0.8+ 20040503

Comment 1

14 years ago
I think this is a dup of bug 241625, although that one doesn't involve a textbox
getting focus.
Blocks: 64451
(Reporter)

Comment 2

14 years ago
Actually, after looking, I'm pretty sure this is a dupe of bug 124750.

One of my URLs that I "open in tabs" is gmail.com.
Likely Gmail stealing focus from the yahoo textbox. When you type with the yahoo
page in view, and then switch to the google tab, do you see the text you were
typing at the yahoo page in that the google username box?

If so, this is in fact a dupe of bug 124750.
(Reporter)

Comment 4

14 years ago
Yes, in fact that does happen.  Marking as duplicate.

*** This bug has been marked as a duplicate of 124750 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.