previous/next buttons should be up/down instead of left/right

RESOLVED FIXED in Thunderbird 16.0

Status

Thunderbird
Theme
--
enhancement
RESOLVED FIXED
14 years ago
5 years ago

People

(Reporter: Max Waterman, Unassigned)

Tracking

Trunk
Thunderbird 16.0

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a) Gecko/20040506 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a) Gecko/20040506 Firefox/0.8.0+

The icons for the 'move to the previous unread message' and '...next...' buttons
contain arrows which point left and right.

This is unintuitive since the messages are lists one above the other.

IMO, they should point up and down, respectively.

Please consider changing the images. I would have done it myself, but I can't
find the image for a button without an arrow.

Thanks.

Max.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago
(In reply to comment #0)
> The icons for the 'move to the previous unread message' and '...next...' buttons
> contain arrows which point left and right.

You ment to report this bug for Thunderbird, right?
(Reporter)

Comment 2

14 years ago
doh! you're quite right. thanks.

could someone change it? it won't let me change the target milestone.

Updated

14 years ago
Assignee: bugs → mscott
Component: Toolbars → Mail Window Front End
Product: Firefox → Thunderbird
QA Contact: bugzilla

Comment 3

13 years ago
Yes, this makes sense.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: next/previous buttons need to be rotated 90 degrees → previous/next buttons should be up/down instead of left/right

Updated

13 years ago
Severity: trivial → enhancement
OS: MacOS X → All
Hardware: Macintosh → All
QA Contact: front-end

Updated

9 years ago
Assignee: mscott → nobody
opinions?
That makes sense to me, much more than the double arrows >>, <<

Updated

6 years ago
Blocks: 727598

Updated

6 years ago
Component: Mail Window Front End → Theme
QA Contact: front-end → theme
Version: unspecified → Trunk

Comment 6

5 years ago
Fixed by bug 727598, cabe seen in current trunk, TB16.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 16.0
(Reporter)

Comment 7

5 years ago
I guess that the text for the buttons now might not make sense, depending on how the user has the messages sorted? It doesn't matter for the icons, since 'down' is always down, irrespective of if it's the next or previous message, but the text could be confusing?

Comment 8

5 years ago
Not sure what you mean. It seems Previous (up) always goes up regardless of sort order.

Do you mean that if you have sorted by Date and descending (newest on top), that actually pressing Previous goes up, which means to newer message in time order?
(Reporter)

Comment 9

5 years ago
(In reply to :aceman from comment #8)
> Do you mean that if you have sorted by Date and descending (newest on top),
> that actually pressing Previous goes up, which means to newer message in
> time order?

Yes - the meaning of 'next' and 'previous' might imply a chronological order - but perhaps not, which is fine...

Comment 10

5 years ago
Maybe, if you sort by date/time. If you sort by other property, it is not so easy. But yes, in any ordering there is the mathematical notion of previous and next (or lower and higher). I agree the buttons may work wrong in that notion. But it is the question if users care about that notion :) It looks like not much as Outlook 2007 works the same way as TB.
(Reporter)

Comment 11

5 years ago
(In reply to :aceman from comment #10)
> Maybe, if you sort by date/time. If you sort by other property, it is not so
> easy. But yes, in any ordering there is the mathematical notion of previous
> and next (or lower and higher). I agree the buttons may work wrong in that
> notion. But it is the question if users care about that notion :) It looks
> like not much as Outlook 2007 works the same way as TB.

Indeed. I have nothing more to add. Thanks for fixing this :)
You need to log in before you can comment on or make changes to this bug.