If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

installer thinks that Mozilla/Firefox/etc. is Thunderbird and must close it for installation to continue

RESOLVED WORKSFORME

Status

Thunderbird
Installer
RESOLVED WORKSFORME
14 years ago
11 years ago

People

(Reporter: Tom Metro, Assigned: Scott MacGregor)

Tracking

unspecified
x86
Windows XP
Bug Flags:
blocking-aviary1.5 -
blocking-thunderbird2 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.7b) Gecko/20040310 Firefox/0.8.0+
Build Identifier: official 0.6 release

Just before performing the installation, the installer checks to see if
Thunderbird is running, and refuses to proceed if it is. Unfortunately it
doesn't appear to distinguish between Mozilla/Firefox/etc. and Thunderbird.

See similar Firefox installer bug 225500.

Reproducible: Didn't try
Steps to Reproduce:

Comment 1

13 years ago
Confirming for 0.7.1

Comment 2

13 years ago
I have the same problem when uninstalling any of the Mozilla applications and
while doing that runing another Mozilla application.

Comment 3

13 years ago
*** Bug 242477 has been marked as a duplicate of this bug. ***

Comment 4

13 years ago
*** Bug 251489 has been marked as a duplicate of this bug. ***

Comment 5

13 years ago
Confirming, which I though Comment #1 was doing....
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

13 years ago
WFM with Thunderbird v0.8
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Comment 7

13 years ago
I'm seeing this bug with Thunderbird 0.9.
Status: RESOLVED → REOPENED
OS: Windows NT → Windows XP
Resolution: WORKSFORME → ---

Comment 8

13 years ago
Sometimes I am installing both Firefox and Thunderbird at the same time. One
will always close out the other installer.

Comment 9

13 years ago
The download and the CD for thunderbird 1.0.2 gets firefox.
win me
please correct.

Updated

12 years ago
Flags: blocking-aviary1.1?

Updated

12 years ago
Flags: blocking-aviary1.1? → blocking-aviary1.1-

Updated

12 years ago
Flags: blocking-aviary2.0?

Updated

12 years ago
Flags: blocking-firefox2? → blocking-thunderbird2?
(Assignee)

Updated

12 years ago
Flags: blocking-thunderbird2? → blocking-thunderbird2-

Comment 10

12 years ago
Is program stoppage considered "data loss"? There should be a better keyword to cover it. "Crash"? "Hang"?

Comment 11

12 years ago
Has anyone tried this in the most recent branch nightly builds? I still think this should block a release.
WFM installs using trunk and 2.0 with seamonkey running - no prompt
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.