Closed Bug 244328 Opened 18 years ago Closed 14 years ago

[l10n] Date formats should obey system internationalization settings

Categories

(Camino Graveyard :: OS Integration, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Camino2.0

People

(Reporter: sugar.waffle, Assigned: stuart.morgan+bugzilla)

References

(Blocks 1 open bug)

Details

(Keywords: intl)

Attachments

(4 files)

The format of the date displayed by "Get Info" of bookmark and the saved list of
cookies is not in agreement with the date format set up by OS.

This is bewildered by understanding the date.

Mac OS X 10.3.3
Default OS Locale:Japanese

2004052200 (v0.7+)(trunk build)
Attached image Page Info of mozilla1.4
At Page Info of Mozilla1.4, the date is displayed by the date format as
expected.
Updating summary for clarity.
Summary: The display format of the date does not suit a setup of OS. → Date formats should obey system internationalization settings.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → Camino1.0
Summary: Date formats should obey system internationalization settings. → [l10n] Date formats should obey system internationalization settings.
Blocks: 299757
Fix in bug 299757 seems to fix the bookmark info dispaly and the cookie info
display.
(In reply to comment #6)
> Fix in bug 299757 seems to fix the bookmark info dispaly and the cookie info
> display.

What else needs to be fixed to fix this bug, then?
On Camino's history page (View -> Show History) the System Preferences ->
International settings are also ignored.
I run the system in English, but with customized formats settings (i.e. 24-hour
clock) and I get the standard English format (am/pm, etc.).
(In reply to comment #7)
> (In reply to comment #6)
> > Fix in bug 299757 seems to fix the bookmark info dispaly and the cookie info
> > display.
> 
> What else needs to be fixed to fix this bug, then?

Some places the user-set date format is not used: 
*The Go menu has weekday and month names from system settings, but not the
format. This produces a wrong-looking format (right now I have a history folder
called "tisdag, september 01". If this was in the system-set format it would be
"tisdag, 1 september" etc.)
*The columns "First Visit" and "Last Visit" at about:history also use some
hard-coded date format, not the system set format.

The bookmarks info panel uses a system format and it displays correctly
The issues in comment 6 are probably a result of the way bug 299757 was fixed
(the formats are up to the localizers and set in localizable.strings, because
the system settings always return a year and we don't need a year in the Go
menu).  Is there a way to work around that issue?
(In reply to comment #6)
> Fix in bug 299757 seems to fix the bookmark info dispaly and the cookie info
> display.

In 1.0a1 only the History Menu part seems fixed. I can't see any string to
localize the cookies date format.
(In reply to comment #11)
> (In reply to comment #6)
> > Fix in bug 299757 seems to fix the bookmark info dispaly and the cookie info
> > display.
> 
> In 1.0a1 only the History Menu part seems fixed. I can't see any string to
> localize the cookies date format.

It should be the same.
It should be, but perhaps we aren't using it for cookies?
This is basically because Cocoa sucks and doesn't give dates in the format set
in the Intl system pref pane, before Tiger.
(In reply to comment #14)
> This is basically because Cocoa sucks and doesn't give dates in the format set
> in the Intl system pref pane, before Tiger.

Is this a 10.2/3-only bug then?
Component: General → Translations
*** Bug 322256 has been marked as a duplicate of this bug. ***
Not Translations, since even in US English I might still want UK date formats (and do).
Component: Translations → General
-> 1.1
Target Milestone: Camino1.0 → Camino1.1
I filed bug 335986 for the History view in the Bookmark Manager (comment 9) and bug 335985 for the Cookies (comment 11).

Pushing this to 2.0 because it sounds like we can get better options to use real OS settings once we drop support for 10.3.
Assignee: mikepinkerton → nobody
Component: General → OS Integration
Depends on: 301740
Keywords: intl
OS: Mac OS X 10.2 → Mac OS X 10.3
QA Contact: os.integration
Summary: [l10n] Date formats should obey system internationalization settings. → [l10n] Date formats should obey system internationalization settings
Target Milestone: Camino1.1 → Camino2.0
It would be helpful if someone could re-audit the UI in light of 335985 and 335986 being fixed, file new bugs for any remaining issues, and then we can close this.
I'll be the "someone"
Assignee: nobody → stuart.morgan
I don't see any remaining issues, so I'm going to call this FIXED by the various bugs referenced above. If anyone finds anything else, please file new bugs.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.