Last Comment Bug 244884 - Back button does not restore scroll position for vBulletin 3+ forums.
: Back button does not restore scroll position for vBulletin 3+ forums.
Status: RESOLVED DUPLICATE of bug 215405
: qawanted
Product: Core
Classification: Components
Component: Document Navigation (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://www.vbulletin.com/forum/forumd...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-27 12:48 PDT by Kevin Ar18
Modified: 2008-07-31 02:44 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Kevin Ar18 2004-05-27 12:48:21 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040527 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040527 Firefox/0.8.0+

Cause: unknown.

Reproducible: Always
Steps to Reproduce:
1. Go to a website using a vBulletin forum.
Here are two URLs you can use:
http://www.vbulletin.com/forum/forumdisplay.php?s=d1b86abdeee737bba2a06991bcdfa0b1&f=1
or
http://forums.relicnews.com/forumdisplay.php?f=64
2. Scroll part way down the page.
3. Go to one of the links.
4. Click on the "back" button.

Actual Results:  
The page scroll position is at the top of the page.

Expected Results:  
The page should scroll to the last position you were at on that page.

I saved one of the pages to my computer (from both forums).  However, after
saving the files to my computer the issue no longer appeared.
Comment 1 R.K.Aa. 2004-05-27 13:48:40 PDT
doesn't work in bugzilla either.
Related/dup: bug 215405 bug 210992 bug 217120 bug 238195 
Comment 2 Boris Zbarsky [:bz] (Out June 25-July 6) 2004-05-27 14:01:07 PDT
Someone needs to figure out what this site is doing that breaks session history...
Comment 3 Kevin Ar18 2004-05-27 15:10:06 PDT
(In reply to comment #2)
> Someone needs to figure out what this site is doing that breaks session history...
Viewing the page info for both vBulletin forums reveals the following:
Source: Memory Cache
Viewing the page info for other sites on the internet reveals the following:
Source: Disk Cache

Based on this info, I found another page that had Source: Memory Cache here:
http://www.tvguide.com/listings/

This page demonstrated the same problem.
It's possible that this is a duplicate of Bug 215405 (thanks for the links
R.K.Aa) since the URL listed there also displays Source: Memory Cache.
Comment 4 Boris Zbarsky [:bz] (Out June 25-July 6) 2004-05-27 22:06:40 PDT
Yeah, vbulletin does indeed send cache-control: no-store.

*** This bug has been marked as a duplicate of 215405 ***

Note You need to log in before you can comment on or make changes to this bug.