If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

New mail status not reset correctly when moving mail by filter

RESOLVED DUPLICATE of bug 222068

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 222068
14 years ago
14 years ago

People

(Reporter: Daniel Küstner, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040514
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040514

Having an account receiving mails automatically (through IMAP idle I believe, as
I didn't enable automatic message collection). When a message is received and
moved by a filter to Local Folders, the account for which the message arrived is
set in bold blue face and the Thunderbird icon is changed to show the number of
new messages. This keeps after reading the message. It is set back only when
opening the INBOX of the receiving account.

Reproducible: Always
Steps to Reproduce:
1. Set up an IMAP account.
2. Set up a filter which is moving messages to local folders
3. Receive mail for the account (in order to open an IMAP connection)
4. Set the mark in the folder pane outside the account, e.g. to local folders
5. Send a mail to the account which is triggering the filter
6. Go to the local folder where the mail is in and read the mail
7. Go to the INBOX of the created account
Actual Results:  
After step 5: System mail sound, TBs icon is changing, local folder gets bold
black, the name of the IMAP-account gets bold blue

After step 6: local folder normal, IMAP account still blue, TBs icon still
showing unread mail

after step 7: IMAP account changing to normal, TBs icon changing back to default

Expected Results:  
after step 5: Not the IMAP account should be shown in bold blue, but the Local
Folders headline

after step 6: Everything should be reverted to normal

Comment 1

14 years ago
IMO dupe of Bug 222068.
(Reporter)

Comment 2

14 years ago
I can't reproduce Bug 222068 on 1.7RC2 but the behaviour described there is the
same as this bug. Marking duplicate.

*** This bug has been marked as a duplicate of 222068 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.