Middle-mouse paste should be pref-able

VERIFIED FIXED in M15

Status

()

Core
XUL
P3
normal
VERIFIED FIXED
18 years ago
7 years ago

People

(Reporter: Chris McAfee, Assigned: Akkana Peck)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT-] Easy, safe fix available)

(Reporter)

Description

18 years ago
Middle-mouse paste should be pref-able,
mouse wheel pastes on NT w/ mouse-wheel,
some Windows users might not want that.

Comment 1

18 years ago
Clarification: the mouse wheel doesn't paste automatically, but it's trivially
easy to go from mouse wheeling up to pasting into who knows where... And when I
paste into something other than a text area the browser attempts to load
whatever is in my clipboard as if it's a URL.
(Reporter)

Comment 2

18 years ago
m15
Target Milestone: M15
(Assignee)

Comment 3

18 years ago
*** Bug 25295 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

18 years ago
Blocks: 25295
(Assignee)

Comment 4

18 years ago
*** Bug 25295 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

18 years ago
No longer blocks: 25295
(Assignee)

Comment 5

18 years ago
I'll take this -- I don't think Chris will have time for it.
(Assignee)

Comment 6

18 years ago
It would help if I clicked the reassign button. :-)
Assignee: mcafee → akkana
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 7

18 years ago
I have a fix for this.  It's very easy -- just a couple of lines in navigator.js
to check the pref, plus two lines in each of the platform default prefs files to
set default values for the prefs.

I called the prefs "middlemouse.paste" and "middlemouse.opennewwindow" and made
them true by default on linux and mac (I'm told mouse scrolling doesn't work on
mac and isn't expected to any time soon), false on windows.

Nominating for beta because many Windows scroll-mouse users seem surprised by
the middle mouse behavior (there are lots of dups of this bug if you trace down
the dup tree), but Unix users are clamoring for it (see bug 7787, which has also
been nominated for beta) and because the fix is available and safe.  I'm hoping
that both this and bug 7787 get marked PDT+ because that's the combination I'm
testing, but I can split them up if need be.
Keywords: beta1
Whiteboard: Easy, safe fix available

Comment 8

18 years ago
PDT- feature
Whiteboard: Easy, safe fix available → [PDT-] Easy, safe fix available

Comment 9

18 years ago
*** Bug 29623 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 10

18 years ago
The fix is in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 11

18 years ago
qa -> jrgm
QA Contact: paulmac → jrgm

Comment 12

18 years ago
filed an rfe for a gui for these prefs, bug 55704.

Comment 13

18 years ago
verified fixed. (Don't you love bugs that you never knew you had anymore).
Status: RESOLVED → VERIFIED

Updated

7 years ago
Depends on: 675551
You need to log in before you can comment on or make changes to this bug.