[RFE] DHTML DIV Javascript popups evade popup blocker

RESOLVED DUPLICATE of bug 242237

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 242237
14 years ago
12 years ago

People

(Reporter: krellan, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

I am seeing more and more sites go to popup/overlay advertisements that are
rendered entirely within the browser window.  No external popup window is created.  

However, these ads are just as annoying, if not MORE so: because the ad is
rendered inside the browser window, there are no UI controls to move or close
the ad, so it is free to obscure the content!

PLEASE allow this behaviour of Javascript to be turned off and/or regulated by
the existing popup mechanism.  When Javascript (or a style sheet) attempts to
place a DIV element that overlaps existing content, it should be treated as a
popup ad, and blocked!


Reproducible: Always
Steps to Reproduce:
1. Go to http://www.thesteelwarrior.org/forum/
2. Notice the "Please take some time to register" popup at center.  This is
IMMUNE to Mozilla/Firefox's popup controls!


Actual Results:  
See above.

Expected Results:  
It should have treated the DIV as a popup, and allow it to be regulated/blocked
by the user.


Here's the vile script that does it:

http://www.thesteelwarrior.org/forum/clientscript/vbulletin_vbpopup.js

The actual popup ad is a DIV element with a corresponding stylesheet.  It
defaults to hidden, but the script raises the ad and then hides it again after a
timer expires.

Comment 1

14 years ago
*** Bug 247782 has been marked as a duplicate of this bug. ***

Comment 2

14 years ago
You know animated DHTML has nothing to do with popup windows, the popup blocker,
or anything of the sort, right? People seem to get them confused; I don't know
why. This is an extremely sticky problem to fix, separating legitimate content
in overwrought, artistic websites from advertising.

The heuristic to use may indeed be something as simple as refusing to allow one
div to position itself over another, or make itself visible in that position, on
a timer. Maybe that'd be a decent first cut at the problem. But there's already
a bug for this.

*** This bug has been marked as a duplicate of 242237 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 3

12 years ago
*** Bug 342808 has been marked as a duplicate of this bug. ***

Comment 4

12 years ago
*** Bug 345719 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.