"Ask for each cookie" option broken

RESOLVED WORKSFORME

Status

()

Firefox
General
P2
major
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: Erryn Pollock, Assigned: mconnor)

Tracking

({fixed-aviary1.0})

unspecified
Firefox1.0beta
x86
Windows XP
fixed-aviary1.0
Points:
---
Bug Flags:
blocking-aviary1.0PR +
blocking-aviary1.0 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

If the option to "ask for each cookie" is set, when a cookie confirmation dialog
should appear, this error appears instead:

XML Parsing Error: undefined entity
Location: chrome://cookie/content/cookieAcceptDialog.xul
Line Number 47, Column 1:

<dialog id="cookieAcceptDialog"
^

Reproducible: Always
Steps to Reproduce:
1. Set cookie option to "ask for each cookie"
2. Go to a site that wants to set a cookie
3. Get the error message

Actual Results:  
Got the aforementioned error.

Expected Results:  
Displayed a confirmation dialog.

Did have 0.8 installed before this install, but uninstalled (followed by manual
cleanup) before installing 0.9.
(Assignee)

Comment 1

14 years ago
This is not a good thing... 
Assignee: firefox → mconnor
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

14 years ago
I should really fork this bit of UI so I don't have to dig into seamonkey code
for stock icons.
Flags: blocking1.0+
(Reporter)

Comment 3

14 years ago
Curiously, I went through the same process with another computer (with the same
setup) and this hasn't been a problem. It seems to work fine on the second machine.

Comment 4

14 years ago
WFM with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040615
Firefox/0.9 (Steffen).

Are you missing Menu Help->Help Contents as well?
(Reporter)

Comment 5

14 years ago
Yes, I was. And I just found the resolution.

On the first installation, when the installation was finished, I chose not to
run Firefox and instead ran it manually later.

On the second, I chose to run it at the finish, and the "import settings" dialog
popped up (which never appeared in the first one). I imported my 0.8 settings
and everything seemed happy and perfectly functional.

I uninstalled the first try and reinstalled, following the same procedure, and
now it is also happy.

Comment 6

14 years ago
I too have come across this problem.

I downloaded Firefox 0.9 and upgrade from 0.8 which i setup to ask me to allow
or deny each cookie. Now in 0.9 i get the exact same XUL parsing error as listed
by Erryn, when it tries to bring up the question box. Happens right here on the
bugzilla site infact

I have no problems with the Help->Help Contents though.

User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040614 Firefox/0.8

hrm thats interesting user agent from the help about menu says 0.8 but the help
about says 0.9
Thanks
Priority: -- → P2
Target Milestone: --- → Firefox1.0beta
Flags: blocking-aviary1.0RC1+

Comment 7

14 years ago
WFM
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
(Assignee)

Comment 8

14 years ago
*** Bug 251732 has been marked as a duplicate of this bug. ***
Mike, please figure out within the next 7 days if this is still a problem... if
this is related to the zip build, then let's not bother unless this also effects
Mac disk images/linux tar.gzs. 

Comment 10

14 years ago
tracy can you check this out to determine if it is only a problem with .zip and
.gz builds and does not exist in installer builds?
I can not reproduce this with recent builds:
Windows 2004-07-22-10-0.9 installer build - works
Windows 2004-07-22-10-0.9 .zip build - works
Linux 2004-07-22-11-0.9 installer build - works
Linux 2004-07-22-11-0.9 tarball build - works
Mac 2004-07-22-10-0.9 .dmg build - works

I did not, however, upgrade from 0.8.  I installed in a clean directory and
created a new profile with the newly installed build.
(Assignee)

Comment 12

14 years ago
resolving WORKSFORME.  There might have been some bad packaging-fu that's
resolved now.  Someone please reopen if this recurs.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Comment 13

14 years ago
I have been getting this problem on all branch builds since 22nd July, whether
using a new or existing profile.

Builds dated 21st July or earlier work fine.

A quick way to reproduce (rather than having to visit a site) is to type the
following into the location field;
chrome://cookie/content/cookieAcceptDialog.xul

Can someone re-open please.

Comment 14

14 years ago
Just got it after installing 7-23 branch installer build with old profile (worked fine with 7-22).

Comment 15

14 years ago
Created attachment 154174 [details]
7-23 branch installer "Accept Cookie" error message.

Comment 16

14 years ago
I have been trying various changes having looked at the checkins from 21st July
onwards and have so far discovered the following. Please bear in mind, I know
nothing about xul or the inner workings of FireFox, so this may be completely
irrelevant.

If I change line 41 of cookieAcceptDialog.xul to;
<!DOCTYPE dialog SYSTEM "chrome://browser/cookie/locale/cookieAcceptDialog.dtd">
(note, I added "browser", but I get the same results with "global").

Then the error message moves to the next line and becomes

XML Parsing Error: undefined entity
Location: chrome://cookie/content/cookieAcceptDialog.xul
Line Number 48, Column 18:    acceptLabel="&button.allow.label;"
-------------------------------------------^
Note; I added extra "-"'s so that the "^" is actually pointing at the "&" in the
line above as in the original message.

If I change the path on line 41 to garbage, then the original error remains.

This makes me think that cookieAcceptDialog.xul is having difficulty finding
cookieAcceptDialog.dtd, but when it does there are still errors.

Incidentally, if I remove all the ampersands as well from cookieAcceptDialog.xul
then the error no longer occurs and I get a (broken) accept cookie dialogue box.
(Assignee)

Comment 17

14 years ago
this regressed again, but its fixed now, should be in the next round of
nightlies (not the ones currently up)

Comment 18

14 years ago
I have just downloaded a BEAST build and can confirm that this is now working.

Thanks.

Comment 19

14 years ago
*** Bug 252891 has been marked as a duplicate of this bug. ***

Comment 20

14 years ago
*** Bug 252882 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Keywords: fixed-aviary1.0
You need to log in before you can comment on or make changes to this bug.