Closed Bug 24690 Opened 23 years ago Closed 10 years ago

Personal Toolbar: Two clicks needed to bring up new folder

Categories

(Core :: XUL, defect, P3)

defect

Tracking

()

RESOLVED WORKSFORME
Future

People

(Reporter: slamm, Unassigned)

References

Details

(Whiteboard: [2012 Fall Equinox])

Click on a folder on the personal toolbar.
Click on another toplevel folder on the personal toolbar.

Instead of bringing up the new folder, it only dismisses the one that was
currently open.
cc'ing pink, who can even take this if he wants.  
Status: NEW → ASSIGNED
Target Milestone: M14
Summary: Personal Toolbar: Two clicks needed to bring up new folder → [Menus] Personal Toolbar: Two clicks needed to bring up new folder
Target Milestone: M14 → M15
*** Bug 22914 has been marked as a duplicate of this bug. ***
This seems to have been fixed.
It now works in build 2000022308.
Status: ASSIGNED → RESOLVED
Closed: 23 years ago
Resolution: --- → WORKSFORME
sorry fot the spam, changing QA contact.
QA Contact: paulmac → jrgm
Now it's not working again!
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Status: REOPENED → ASSIGNED
Target Milestone: M15 → M18
mass-moving all bugs to m21 that are not dofood+, or nsbeta2+
Target Milestone: M18 → M21
oh darn... ->future
Target Milestone: M21 → Future
*** Bug 28086 has been marked as a duplicate of this bug. ***
Peter, the bug that was just duped on this (bug 28086) was assigned to Pink and nsbeta3+'d. I concur with that status.
Normally, I'd just copy over the status but at this stage in the game I just wanted to call it to your attention to resolve the
discrepancy.
Severity: minor → normal
Keywords: nsbeta3
the other bug probably shouldn't have been beta3+'d in the first place. just 
overzealous whining on my part got it that way ;)
Thanks for not copying nsbeta3+ status!  While that one managed to get on our
list briefly in July, in mid-August, with 3.5 weeks to go, this one will not.
nsbeta3-
Whiteboard: [nsbeta3-]
*** Bug 57601 has been marked as a duplicate of this bug. ***
*** Bug 70668 has been marked as a duplicate of this bug. ***
FWIW, I think the folders on the personal toolbar should behave the same as
ordinary menus, i.e. when one folder has been opened, folders are opened on
hover, not click)
Bug still apparent in 2001052606.  Need to double-click to close one and open other.
*** Bug 80755 has been marked as a duplicate of this bug. ***
*** Bug 91053 has been marked as a duplicate of this bug. ***
See also bug 48574, [RFE]: folder open state should persist between folders on 
personal toolbar.

I think fixing bug 48574 is the best way to fix this bug.
*** Bug 48574 has been marked as a duplicate of this bug. ***
Hello, what is with this bug? Any progress? It looks like Mozilla 1.0 will be
shipped with this still present if nothing will be done very quickly. Of course,
this is not a really important bug (one could even argue that it might be an
enhancement) and there are lots more important ones for 1.0.

Just curious what the plans are...
This is a defect, we should fix it for the next release.  ->menus.
Status: ASSIGNED → NEW
Component: XP Toolkit/Widgets → XP Toolkit/Widgets: Menus
QA Contact: jrgm → shrir
Summary: [Menus] Personal Toolbar: Two clicks needed to bring up new folder → Personal Toolbar: Two clicks needed to bring up new folder
Whiteboard: [nsbeta3-]
The personal toolbar should react *exactly* the same as the menubar (file, edit...)

In other words, after clicking on a folder on the personal toolbar, I should
only need to hover over another toplevel folder in order for it to open. (I
should *not* have to click twice(!) to open another folder.) 

More specifically, I should be "locked" into selecting a bookmark from one of
the folders on the personal toolbar, unless I click on a toolbar folder again
(to close it) or unless I click somewhere outside the toolbar and it's folders.
[This is a description of how the menubar reacts to mouse interaction.]
One other comment: this bug only applies to top level folders on the personal
toolbar. Folders within toplevel folders open automatically on hover (at least
in Windows 2000).
I made a work around for this highly visible PT bug which will be added to
MultiZilla v1.1.21 but I love to see this fixed in mozilla. 

note: we expect user feedback, on all platforms, starting from August 26.
HJ, does this work with MultiZilla now? Could you make a patch for Mozilla too?
It would be really nice to have a patch in the Phoenix tree, too.
I agree with comment 22, it should work like normal menus.
*** Bug 203926 has been marked as a duplicate of this bug. ***
This bug is present in Mozilla 1.4rc1 on Win2k.  IMO, this is a blocker 
for 1.4 final.
Sorry, as has been pointed out off-bug-list, I wasn't clear enough here.

This bug has *reappeared* in Mozilla 1.4rc1.  I believe even that Mozilla
1.4beta was fine (I didn't really test that one that much, but I certainly
would have noticed this) but it's there in 1.4rc1, and I've reinstalled 
a couple of times now.
Pete, sorry to disappoint you, but this bug was never fixed in Mozilla (at least
not in the recent months I remember - as you can also see from the last few
comments).
I also just tested it with Mozilla 1.0 and Mozilla 1.3.

Do/did you have Multizilla installed? (see comment #23) That would explain why
it seems to have worked for you.
This is a (old) minor UI consistentcy bug.  This does not block 1.4.  If you
want this fixed, start by taking the bug and posting a patch, get it into trunk,
and then you can ask for 1.4 approval.  However, at this point, it's probably
too late unless the fix is trivial and obviously risk-free.
Flags: blocking1.4-
*** Bug 221750 has been marked as a duplicate of this bug. ***
This bug is reproduced with 2004031008-trunk/WinXP.

But, when sub folder is expanded, other top level folder icon works fine.
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: shrir → xptoolkit.widgets
Assignee: hyatt → nobody
WFM here, when I click on one folder in Bookmarks Toolbar and move cursor to other it also expands without additional clicking
User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 SeaMonkey/2.15a1
Build identifier: 20120918003007
Status: NEW → RESOLVED
Closed: 23 years ago10 years ago
Resolution: --- → WORKSFORME
Whiteboard: [2012 Fall Equinox]
You need to log in before you can comment on or make changes to this bug.