Status bar does not display "Done" when you use Javascript to preload images, even though the page has finished loading

RESOLVED DUPLICATE of bug 209330

Status

()

Core
DOM: Core & HTML
RESOLVED DUPLICATE of bug 209330
14 years ago
4 years ago

People

(Reporter: Toh Zhiqiang, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

After Firefox finishes loading the page at
http://home.pacific.net.sg/~lifeguard/firefox_bug.htm, the status bar does not
display "Done", but other message like "Transfering data from..." or "Waiting
for ...".

This is due to the following Javascript that preloads the image:
function preloadImg() {
	var img = new Image();
	img.src = "arrow.png";
}

In addition, as long as "Done" is not displayed, you cannnot use
window.status="Some text" to change the status bar message.

Pressing F5, or clicking the refresh button does not help. However, if you
reload the page by clicking in the location bar and press Enter, the status bar
will display "Done".

If you press F5 or clicking the refresh button AGAIN, the status bar does NOT
display "Done".

Reproducible: Always
Steps to Reproduce:
1. Clear the browser's cache
2. Load the page at: http://pachome2.pacific.net.sg/~lifeguard/firefox_bug.htm
3. Take note of the status bar message after the page finishes loading
4. Press F5 or click the refresh button
5. Take note of the status bar message after the page finishes loading

Actual Results:  
Status bar message for Step 3 and Step 5 is "Transfering data from..." or
"Waiting for ..."

Expected Results:  
Status bar message should be "Done"

Comment 1

14 years ago
I've got a similar problem here:

When I go to a site like <http://geckow.net/misc/site_links.html> it loads
correctly, and the statusbar displays 'Done'. But when I hit 'refresh' (F5) it
loads the page again, but now the statusbar displays 'Waiting for geckow.net..'
although the page is displayed correctly.

Steps to reproduce:
1) Go to <http://geckow.net/misc/site_links.html>
2) Notice the statusbar, and now hit refresh
3) The statusbar now displays 'Waiting for geckow.net', even if the entire page
is rendered completely after a while.

(this page also preloads images)

I have this problem quite a long time, even in the 'stable' releases.


Comment 2

14 years ago
Can someone change the status of this bug? I don't have sufficient rights for
that, and the problem still persist in the latest build.

Comment 3

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a3) Gecko/20040721
Assignee: firefox → general
Component: General → DOM: HTML
Product: Firefox → Browser
QA Contact: firefox.general → ian
Whiteboard: DUPEME
Version: unspecified → Trunk
Darin, this page loads an image from inside onload.... So the browser status
handler may never get a STATE_IS_DOCUMENT notification here when the image
finishes loading (though it should get  a STATE_IS_NETWORK, I would think).

Comment 5

13 years ago
Related to bug 250542, bug 246052 and bug 248749?
*** Bug 282352 has been marked as a duplicate of this bug. ***

Comment 7

13 years ago
*** Bug 288398 has been marked as a duplicate of this bug. ***

Comment 8

13 years ago
(In reply to comment #7)
> *** Bug 288398 has been marked as a duplicate of this bug. ***

Please see bug https://bugzilla.mozilla.org/show_bug.cgi?id=288398
for a minimal example to reproduce the situation.

*** This bug has been marked as a duplicate of 209330 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: DOM: HTML → DOM: Core & HTML
QA Contact: ian → general

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.