Cannot create shortcut for pages with no title or invalid characters in title

RESOLVED WONTFIX

Status

()

Firefox
Shell Integration
P4
normal
RESOLVED WONTFIX
14 years ago
10 years ago

People

(Reporter: Brodie, Unassigned)

Tracking

1.0 Branch
x86
Windows XP
Points:
---
Bug Flags:
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

14 years ago
This is the FireFox version of the following Mozilla bugs:

bug 103468 = Mozilla creates .url files with zero byte at end, confusing IE
(Internet shortcut)
bug 78509 = Can't make an Internet shortcut with :, /, \ in title (by dragging
link to desktop)
bug 104933 = Mozilla-generated .url filename without name when page has no title 

These have all been fixed on the Mozilla 1.8 trunk. It would be worthwhile
putting it into Firefox 1.0. The patch for all of these problems is patch 5 at
bug 103468 
http://bugzilla.mozilla.org/attachment.cgi?id=149548&action=view

Note that this patch uses the localized string "noPageTitle" from
chrome://navigator/locale/pageInfo.properties 
It is possible that this is different in Firefox?

Comment 1

14 years ago
The Mac version of AVIARY_1_0_20040515_BRANCH is also reproduced.
(Reporter)

Comment 2

14 years ago
This is a Windows only bug (in a Windows specific source file). The patch as 
applied to 1.8 trunk will fix Windows only, so I think you need to open a new 
bug for the same issue against Mac. Is there already a bug for the same problem 
on Seamonkey?

Comment 3

14 years ago
Bug 159773 is dup of this and l10n problem.
Shift-JIS contains 0x5c(\).
For Japanese this bug is bigger problem than for others.
(Reporter)

Comment 4

14 years ago
Nominating for blocking 1.0
Patch available.
Flags: blocking1.0?

Updated

14 years ago
Flags: blocking1.0? → blocking1.0+
Priority: -- → P4

Comment 5

14 years ago
p4 priority - not a blocker. if a patch materializes, please nominate for aviary
approval. 
Flags: blocking-aviary1.0+ → blocking-aviary1.0-
(Reporter)

Comment 6

14 years ago
For crying out loud read the bug, even just a little. There is a patch 
already. It's been in the trunk for ages. From comment #0:
--
The patch for all of these problems is patch 5 at bug 103468 
http://bugzilla.mozilla.org/attachment.cgi?id=149548&action=view
--
(Reporter)

Comment 7

14 years ago
Created attachment 161099 [details] [diff] [review]
patch 5 from bug 103468 

I don't have access to source at the moment, nor am I doing development at
moment, so I can't verify this patch still works. It's probably bitrot, as is
normal with Moz development.

Comment 8

14 years ago
s/patch/fully reviewed patch/
(Reporter)

Comment 9

14 years ago
Created attachment 166229 [details] [diff] [review]
fully reviewed patch updated for firefox 1.0 branch

This is the patch from bug 103468 simply applied and re-created for the the
Firefox 1.0 source branch. It fixes the mismatch between the patch for the 1.8
trunk and the Firefox branch and now applies cleanly to the branch. Let's get
this into the next Firefox point release to fix this problem. For examples of
what this fixes see the testcases in attachment 149729 [details], 'testcases' on bug
103468.
Attachment #161099 - Attachment is obsolete: true
(Reporter)

Comment 10

14 years ago
Comment on attachment 166229 [details] [diff] [review]
fully reviewed patch updated for firefox 1.0 branch

This patch is unchanged from that which has R/SR at bug 103468.
Attachment #166229 - Flags: approval-aviary?
The plan at this point is to push aggressively towards 1.1, with 1.0.x being
security-only releases, so I doubt we'll take this on branch.

Updated

14 years ago
Attachment #166229 - Flags: approval-aviary? → approval-aviary-
*** Bug 281982 has been marked as a duplicate of this bug. ***
Assignee: bugs → nobody
Firefox 1.0 is no longer supported so resolving -> wontfix

Note: this was fixed on trunk quite some time ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
Version: unspecified → 1.0 Branch
You need to log in before you can comment on or make changes to this bug.