Slow performance of autoscroll

RESOLVED FIXED

Status

()

Firefox
General
--
minor
RESOLVED FIXED
14 years ago
11 years ago

People

(Reporter: Thomas Rutter, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
x86
Windows XP
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox2 -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

Autoscroll (clicking the middle mouse button and moving the mouse) performance
is much slower and jerkier than other forms of scrolling on the same page,
including using the scroll bar, or rolling the mouse wheel.

This has been discussed before and if I recall correctly I believe that it may
have been blamed on the partially transparent icon that is visible during
autoscroll.  I believe the performance was improved a bit a couple of versions
ago.  However, the performance is still significantly poorer than using the
scroll bar, so there is still something wrong.

Reproducible: Always
Steps to Reproduce:
1. Autoscroll on a web page, particularly a long one like the example URL


Actual Results:  
Significantly slower and jerkier than using the scroll bar, or using the mouse
wheel.

Expected Results:  
Smooth and fast scrolling.

If this problem really is due to the semi-transparent autoscroll icon, then this
could be indicative of poor performance in general of rendering semi-transparent
images and moving them.  In that case the problem would be due to rendering
speed, but a workaround would be not to use a semi-transparent icon for the
autoscroll icon.

Unfortunately, the dreaded MSIE autoscrolls much more smoothly on the same pages.

Comment 1

14 years ago
Works fine for me in Firefox 0.8.
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> Works fine for me in Firefox 0.8.

The issue is not whether it works or not; the issue is that it works, but the
performance is very slow, which causes it to be very jerky.  Compare it with the
smoothness of using the scroll bar.

Comment 3

14 years ago
(In reply to comment #2)
> (In reply to comment #1)
> > Works fine for me in Firefox 0.8.
> 
> The issue is not whether it works or not; the issue is that it works, but the
> performance is very slow, which causes it to be very jerky.  Compare it with the
> smoothness of using the scroll bar.

By "works fine" I mean it works as expected, not slow as you report.

Comment 4

14 years ago
Moving to FF b/c to my knowledge Mozilla doees not have Autoscroll feature w/o
an extention.
Assignee: general → firefox
Component: Browser-General → General
Product: Browser → Firefox
QA Contact: general → firefox.general
(Reporter)

Comment 5

14 years ago
Here's some updated 'steps to reproduce' for this bug:

1. Go to http://www.zeldman.com/daily/0604d.shtml
2. Slowly move the page up and down using the scroll bar at the right hand side
of the page with your mouse.  Notice how smooth the movement is.
3. Click the page with your middle mouse button so that the translucent
autoscroll icon appears (if it doesn't or if it's not translucent, then your
mouse driver is overriding it - turn that off).
4. Slowly move your mouse up and down and see how smooth the movement is.
5. Compare the two movements.

Actual result:
Scrolling with autoscroll is significantly jerkier (many times over) than using
the scroll bar.

Noticeable but less annoying on a newer computer (Athlon XP 2600+).  Extremely
annoying on older computer (Athlon Thunderbird 900).

Expected result:
Scrolling with autoscroll is just as smooth as using scroll bar.

---

Note:
Moving the autoscroll icon out of the DOM will render this bug irrelevant, and
likely solve the problem.  Therefore I would recommend that this bug depends on
bug #242621.
Component: General → Layout: View Rendering
Depends on: 242621
Product: Firefox → Browser
Version: Trunk → Other Branch
(Reporter)

Updated

14 years ago
Component: Layout: View Rendering → General
Product: Browser → Firefox
Version: Other Branch → 1.0 Branch

Comment 6

14 years ago
This is partially due to using a semitransparent icon, but probably mostly
caused by having the autoscroll icon in the DOM.  Only noticible on slower machines.
Blocks: 212273
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: 1.0 Branch → unspecified
(Reporter)

Comment 7

14 years ago
It's particularly annoying on slower machines, but it's quite noticeable on all
machines.  It's noticeable on the following computer for me:

Athlon XP 2600+
ATI Radeon 9600 128Mb
Windows XP
512 Mb RAM

Comment 8

13 years ago
*** Bug 263894 has been marked as a duplicate of this bug. ***

Comment 9

13 years ago
I noticed that right away after installing.

On my PC the CPU usage reaches 95 %.
Especially when using "AutoScroll" for scrolling left, right and diagonally (coz
of sidebar or ICQ, for example), it's very jerky.
Scrolling up and down is absolutely no problem, so I dont think the reason is
the semi-transparent icon.

I use the following PC:
Athlon XP 2400
Radeon 8500 64m
WinXP Pro (already reproduceable on 9x)
512m RAM

In IE the movement of the page is smooth, even if you scroll diagonally.

Comment 10

13 years ago
*** Bug 283700 has been marked as a duplicate of this bug. ***

Comment 11

13 years ago
In Firefox 1.0.6, autoscroll performance doesn't change. autoscroll is much
slower. In deer park alpha 2, it's the same problem.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20050929
Firefox/1.4 ID:2005092911

It's still slow on sites that use PNG graphics and/or some fix/absolute
positioned elements.
It's actually due to the autoscroll marker (which is PNG, I suppose). One can
disable it with the All-in-One Gestures extension (0.17.2, Advanced Prefs #2).
Furthermore, setting the Autoscroll Refresh Rate to Faster makes scrolling
entirely smooth.

Maybe these options should be set by default or at least be part of some
"Advanced -> Performance" options window.
Otherwise someone should fix the marker.
(Reporter)

Comment 13

12 years ago
(In reply to comment #12)
> It's actually due to the autoscroll marker (which is PNG, I suppose). One can
> disable it with the All-in-One Gestures extension (0.17.2, Advanced Prefs #2).
> Furthermore, setting the Autoscroll Refresh Rate to Faster makes scrolling
> entirely smooth.

Just to address your comment:

Removing the autoscroll marker has no noticeable difference for me.  I guess
that some graphics subsystems can cope with the autoscroll marker better than
others.  Mine has no problem.

Setting the Autoscroll Refresh Rate to faster in All-in-One Gestures does
significantly help the problem for me in simple pages, but does not help on more
complex pages such as those with fixed elements, frames, applets etc.  In these
cases, using the scroll bar is always significantly smoother than autoscroll.

The benchmark for this is the scrollbar - autoscroll should, in my opinion, be
as smooth in motion as using the scrollbar - there is no reason it should be
different.  This obviously depends on the other bugs mentioned in meta bug #212273.

Comment 14

12 years ago
As a user of both windows and Linux, I'd like to make sure everyone realizes that this bug is windows specific.  I have both Win XP and Ubuntu on the computer I'm using, and the difference is very noticeable, both in terms of CPU usage and performance.

Comment 15

12 years ago
(In reply to comment #14)
> As a user of both windows and Linux, I'd like to make sure everyone realizes
> that this bug is windows specific.  I have both Win XP and Ubuntu on the
> computer I'm using, and the difference is very noticeable, both in terms of CPU
> usage and performance.
> 

I'm not sure if 1.5 had anything to do with this, but I'm using the RC right now in Windows, and it seems to perform as expected.  I'm not going to get 1.07 just to compare right now, but maybe this will still be useful.  If needed, I can compare it on request.

Comment 16

12 years ago
Firefox 1.5 RC 1 : autoscroll is still slow with almost pages. There are a little amelioration than 1.0.x. With All In One Gestures extansions which can put more faster the fresh rate, the problem can be resloved. 

Note concerning All In One Gestures : the semi transparent icon can be deleted with this extansion but i didn't see ant differences after that.

Comment 17

12 years ago
I randomly had my task manager open. Autoscroll a page up and down, CPU is almost full. Scroll wheel or scroll bar only goes to half CPU.

Comment 18

12 years ago
I've noticed using the lastest branch builds that AutoScroll (Smoothscrolling disabled) is VERY jerky (seen on machines with both nVidia and ATI cards) on pretty much every page, even more so then 1.x.  This seems to have worsened in the latest builds.  Can we get this fixed once and for all?

BUILD: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20060502 BonEcho/2.0a1 ID:2006050201

~B
Flags: blocking-firefox2?
Autoscroll works fine for me with recent branch builds.
Assignee: firefox → nobody
not a blocker, would be glad to take a patch
Flags: blocking-firefox2? → blocking-firefox2-
This should be significantly better with my checkin for bug 242621.  With the layout debugger, it is apparent that significantly less of the screen is repainted during scrolls now.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.