can't subscribe to calendars on http://www.icalshare.com or http://www.icals.de any more

RESOLVED FIXED

Status

Calendar
General
--
major
RESOLVED FIXED
14 years ago
12 years ago

People

(Reporter: Michael Kunz, Assigned: Mostafa Hosseini)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040616
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040616

I just installed the newest build calendar_windows_20040617.xpi and now i can't
subscribe to calendars on http://www.icalshare.com or http://www.icals.de any more.
This worked with the privious build (from April?).

Reproducible: Always
Steps to Reproduce:
1. go to http://www.icalshare.com or http://www.icals.de
2. click on "subscribe" or "abonnieren"


Actual Results:  
nothing

Expected Results:  
"add new calendar" dialog should appear
(Reporter)

Comment 1

14 years ago
some more information:

When I try to subscribe to those calendar manually using "Subscribe to Remote
Calendar..." in the Tools menu, I get an alert window "Getting the calendar file
failed. Status code: 302: Found".

You can test it with http://ical.mac.com/macklausi/GermanSpecials.ics or
http://ical.mac.com/beweis/EM_2004.ics for example.
Created attachment 151178 [details] [diff] [review]
patch v1

the channel can change. so use the one from the loader, not the initial one.
Attachment #151178 - Flags: first-review?(mostafah)
(Assignee)

Updated

14 years ago
Attachment #151178 - Flags: first-review?(mostafah) → first-review+
*** Bug 247489 has been marked as a duplicate of this bug. ***

Comment 4

14 years ago
Mvl, shouldn't the strings in your patch be put into a properties file so that
they can be localized?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Checked in.
Didn't use the properties yet, because i want calender to work again.
Filed bug 247636 on fixing it properly.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

14 years ago
Thanks, this works for manually added remote calendars.

But clicking on calendars on those websites still doesn't open the "add new
calendar" dialog again.

Reopen?
For the calendars on http://www.icalshare.com that don't give a 404, it works
just fine for me.
(Reporter)

Comment 8

14 years ago
For testing I take the first calendar on the front page "2004 C.F.L Schedule All
Teams" and click on "Subscribe" (using 1.7 final), but absolutely nothing happens.
That one gives me a 404, page not found

what happens if you visit
http://icalx.com/rycardo/public/CFL2004Schedule-AllTeams.ics ?
When nothing happens, it either means some dialog is hidden, but waiting for
your input, or your network is acting strange.
(Reporter)

Comment 10

14 years ago
OK, that was a bad example. I get a 404 for the download link, too.

The problem are the "Subscribe" links. They link to webcal://... adresses. With
older calendar versions I got the "add new calendar" dialog by clicking on them.
Now nothing happens.

When I click on "Download calendar" links I can download the .ics-File, but I
don't get the "add new calendar" dialog, too.
(Reporter)

Comment 11

14 years ago
OK, I just tested it with an old caledar version.
I go to http://www.icalshare.com and down to "ELW Leerungstermine 2004".
There is a link "Subscribe" on the left pointing to
webcal://below.groof.com/ical/Leerungstermine32Wiesbaden.ics.

Old version (from April): "add new calendar" dialog appears
new version (from yesterday + your patch): nothing happens
That works for me.
Try to close all calendar windows and dialog before clicking the link. It didn't
work for me when i had the 'edit calendar' dialog open.
(Reporter)

Comment 13

14 years ago
I made a clean install now. I unzipped Mozilla 1.7final. Made a fresh profile
and only installed the Calendar XPI.
I tried it with opened and closed Calendar. No other windows were open.
Nevertheless nothing happens, when I click on the "Subscribe" link. Can anybody
else test this?

Comment 14

14 years ago
(In reply to comment #13)
> I made a clean install now. I unzipped Mozilla 1.7final. Made a fresh profile
> and only installed the Calendar XPI.
> I tried it with opened and closed Calendar. No other windows were open.
> Nevertheless nothing happens, when I click on the "Subscribe" link. Can anybody
> else test this?

My friend and I have been struggling with this for two days and I can confirm
that it is broken.  Fresh, brand new everything as you described above results
in, nothing.  I've tried various combinations of other screens open/closed but
nothing works.  404 not found is certainly not the issue here, we admin the
server that host's the ics files.
(Assignee)

Comment 15

14 years ago
Maybe it is bug 249796?
(Reporter)

Comment 16

14 years ago
This one is not about publishing, but about subscribing via a link on a webpage.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Michael, are you sure you wanted to reopen this bug?
(Reporter)

Comment 18

14 years ago
The original problem was subscribing via a link in the web. This doesn't work
here, at a friend and Rob Larkin.
The privided patch fixes a part of the problem, but not subscribing via a weblink.
I could subscribe to a calendar at http://www.icalshare.com

If there are still problems, please give _exact_ steps to reproduce (including
urls etc). Also, check the version of the calendar xpi you are using.
(Reporter)

Comment 20

14 years ago
Ok, again in detail:

Mozilla 1.7.1
Calendar: 2004062218-cal

Go to http://www.icalshare.com
Just take the first calendar provided "Asia Cup Cricket July 2004".
Click on "subscribe" on the left.
The link points to "webcal://ical.mac.com/rogerattlee/Asia32Cup32Cricket.ics"

Absolutely nothing happens here.
In older versions of the Calendar the "add new calendar" dialog appears.
Those steps work for me, except that i am using a cvs build of mozilla+calendar,
buildid 20040710. So either something fixed this after the calendar build was
made, or after 1.7 was branched, or it is platform specific, or something else
is doing weird things.
Let's try to rule out the first two options first, by waiting for a new calendar
xpi.
(Reporter)

Comment 22

14 years ago
Perhaps this problem only occurs, when the Calendar is installed as xpi. Can I
download the build you are using anywhere?

Comment 23

14 years ago
Maybe related:  bug 247626

Do you see errors in the javascript console?
I'm seeing on w2k:

Error: [Exception... "Component returned failure code: 0x80004002
(NS_NOINTERFACE) [nsISupports.QueryInterface]"  nsresult: "0x80004002
(NS_NOINTERFACE)"  location: "JS frame ::
file:///C:/Program%20Files/mozilla.org/Mozilla/components/calendarService.js ::
anonymous :: line 116"  data: no]
Source File:
file:///C:/Program%20Files/mozilla.org/Mozilla/components/calendarService.js
Line: 116

Error: [Exception... "Component returned failure code: 0x80004002
(NS_NOINTERFACE) [nsIStreamListener.onStartRequest]"  nsresult: "0x80004002
(NS_NOINTERFACE)"  location: "JS frame ::
file:///C:/Program%20Files/Mozilla%20Firefox/components/calendarService.js ::
anonymous :: line 246"  data: no]
Source File:
file:///C:/Program%20Files/Mozilla%20Firefox/components/calendarService.js
Line: 246

According to bonsai, no changes to calendarService.js since 20040622, and the
changes to libxpical don't appear relevant.
(Reporter)

Comment 24

14 years ago
This seems to be the same bug. I get the same errors. We should mark one of
these bugs as dupe of the other.
(Reporter)

Comment 25

14 years ago
Did these Javascript errors help you find the problem, Michiel?
No, but i can't work on it anyway, as i have no way to reproduce the bug. Hence
no way of finding a fix.
(Reporter)

Comment 27

14 years ago
you can just unzip the zip-version of the 1.7 release and install the Calendar
XPI to repoduce this bug.
But then i still can't work on it, because it works in my own builds.
(Reporter)

Comment 29

14 years ago
I think the problem is the integration of the Calendar during the install
process of the XPI.
Dep on Bug 252944?
Depends on: 252944
(Reporter)

Comment 31

14 years ago
The patch proposed in Bug 252944 seems to help for this bug, too.
(Reporter)

Comment 32

14 years ago
Fixed with bug 252944.
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: gurganbl → general
You need to log in before you can comment on or make changes to this bug.