Note: There are a few cases of duplicates in user autocompletion which are being worked on.

TypeError exception launching firefox 0.9 with Venkman

RESOLVED FIXED

Status

Other Applications
Venkman JS Debugger
RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: jsp, Assigned: James Ross)

Tracking

({fixed-aviary1.0})

Trunk
x86
Windows XP
fixed-aviary1.0
Dependency tree / graph
Bug Flags:
blocking-aviary1.0PR -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 5 obsolete attachments)

(Reporter)

Description

13 years ago
A message box with the following error pops up when I try to launch "firefox
-venkman" after installing Venkman 0.9.79: "An exception occurred while
initializing, please file a bug. TypeError: parentNode has no properties @
<chrome://venkman/content/menu-manager.js> 229".

Comment 1

13 years ago
I received the same error.  Running Venkman 0.9.79 on Firefox 0.9.1 on Windows XP.
(Assignee)

Updated

13 years ago
Assignee: rginda → silver
(Assignee)

Updated

13 years ago
Blocks: 184646
(Assignee)

Updated

13 years ago
Blocks: 247609
(Assignee)

Updated

13 years ago
Blocks: 234238
(Assignee)

Comment 2

13 years ago
Created attachment 152698 [details] [diff] [review]
Move comm overlays to overlayinfo and roll own edit menu

This makes the Aviary-branch's Venkman work in Firefox 0.9 (as vesion 0.9.83),
and includes the files for building a Venkman XPI.
(Reporter)

Comment 3

13 years ago
I'd like to help test this.  Is there someplace to get an XPI, or is there a way
to build Venkman without building an entire browser?
(Assignee)

Comment 4

13 years ago
(In reply to comment #3)
> I'd like to help test this.  Is there someplace to get an XPI, or is there a way
> to build Venkman without building an entire browser?

http://twpol.dyndns.org/temp/venkman-0.9.83.xpi is the XPI I've got from the
patch, which installed into Firefox 0.9+ and Mozilla 1.7 rc 3 and worked fine. :)

Depending on versions of things, you may need to download and install locally
(XPInstall blocking in 1.7 and latest Firefox nighlies).
(Reporter)

Comment 5

13 years ago
Thanks!  I had no problem installing in Mozilla 1.7 or Firefox 0.9.  It worked
immediately under Mozilla.  (As the extension manager points out, you have to
restart Firefox.)

Once I restarted Firefox, selecting the appropriate menu item started Venkman,
but no panes were initially displayed.  I used the View menu to Show the panes I
use most commonly, including the source pane.  I was initially unable to click
to set breakpoints in the source pane, but after I mucked about a bit, my clicks
started having the desired effect.  Everything behaved reasonably thereafter,
even after I removed and reinstalled Venkman.

In short, it looks like Venkman is not quite fully initialized when first run. 
It restored my window layout when I ran it after removing and reinstalling, so
it clearly had retained some information that allowed it to come up fully
functional.

(Later that same day...)  When I reset all the extension.venkman entries listed
in about:config, uninstall the extension, restart Firefox, reinstall Venkman,
restart Firefox again, and launch Venkman, it comes up pretty as you please. 
Maybe I had some detritus left over from a previous attempt at installing that
interfered with its proper function the first time.

I guess the bottom line is, if you have trouble getting Venkman working with
Firefox, try the song and dance above, especially if you previously tried
installing it.
(Assignee)

Comment 6

13 years ago
(In reply to comment #5)
> (Later that same day...)  When I reset all the extension.venkman entries listed
> in about:config, uninstall the extension, restart Firefox, reinstall Venkman,
> restart Firefox again, and launch Venkman, it comes up pretty as you please. 
> Maybe I had some detritus left over from a previous attempt at installing that
> interfered with its proper function the first time.

Yeah, I should have mentioned that. I don't know why, exactly, but if you try to
run a broken version it manages to save the layout as "" (which is then fails to
parse on any subsequent starts, even with a working version). Clearing the
layout pref seemed to fix it for me.

I guess a quick "if it's blank, use the default" check may be all we need there.
(Reporter)

Comment 7

13 years ago
And here I was all excited about stumbling across hazards in previously
unexplored territory.

Sanity-checking the layout preference value seems like a good idea.  Other than
that, do you think this patch is ready for review?  (Can you tell that I'd like
to see this get checked in?)
(Assignee)

Comment 8

13 years ago
(In reply to comment #7)
> Sanity-checking the layout preference value seems like a good idea.  Other than
> that, do you think this patch is ready for review?  (Can you tell that I'd like
> to see this get checked in?)

Probably. The thing does /work/, after all (and most of the code is actually
from ChatZilla where it's been used for a few weeks), though I was completely
making up the "contributors" list for the install.rdf file. Some idea who should
be listed would be good. :)

I'm guessing this may be a candidate for blocking-aviary1.0RC1, since I've heard
unofficially that Venkman is a blocking issue for Firefox 1.0.
Flags: blocking-aviary1.0RC1?

Comment 9

13 years ago
First - woo hoo James!  Lots of good stuff in there.
I would like to see a change or two before review though. 
Some double checking finds places where clerical things need tidying - e.g. the
package name is given as chatzilla and the issue of contributors etc.
I'm also wondering about other bits and pieces that venkman calls for that don't
exist or were moved in FF that I didn't see addressed, e.g. findUtils.js. (I
presume they should be fixed or they aren't needed and can be removed.)

That said, I'm willing to put some time into it over the next two-three days if
that isn't too much delay for folks.
(Reporter)

Comment 10

13 years ago
If there are known issues with the patch, it makes sense to me to deal with them
before asking for review.  We can fix now or fix later, but I imagine reviewers
would appreciate a best-effort patch.  So, I'd suggest Derek go ahead and tidy
up whatever he can.

And I second Derek's cheer for James' work!

Comment 11

13 years ago
Great effort!

I did notice that detaching panes (floating view) seems not to work. When
floated, it opens another window but its blank. It also doesn't remove the view
pane from the primary window.
(Assignee)

Comment 12

13 years ago
(In reply to comment #11)
> I did notice that detaching panes (floating view) seems not to work. When
> floated, it opens another window but its blank. It also doesn't remove the view
> pane from the primary window.

Yeah, as Derek Seabury mentioned in comment 9, I missed a few communicator
references - it turns out one of them is an overlay on the floating window, and
Gecko can't handle missing overlays, so it just fails to work entirely.

Comment 13

13 years ago
Created attachment 153102 [details]
xpi for folks to test

Comment 14

13 years ago
Comment on attachment 153102 [details]
xpi for folks to test

Given I don't have a proper set up here is a hand-rolled XPI with my updates to
the patch James created if people want to give it a spin.
(Assignee)

Comment 15

13 years ago
(In reply to comment #14)
> Given I don't have a proper set up here is a hand-rolled XPI with my updates to
> the patch James created if people want to give it a spin.

Can you do a cvs diff for this? I'm guessing progrably not, since if you can
build Moz you can make a Venkman XPI with my patch (which adds the build
script), so could you detail the actual changes somewhere/somehow?
(Reporter)

Comment 16

13 years ago
Wow.  Be careful how you install these XPIs.  I'm not quite sure where I went
wrong, but I have just spent a long time recovering from installing Derek's.  I
think I should probably have uninstalled James' first, but I didn't, and managed
to get Firefox in such a state that its UI was almost completely unresponsive. 
Tooltips would display, and I could close the browser, but other than that, no
keyboard or mouse activity had any effect.  I couldn't bring down menus or click
buttons.  I ended up deleting the Application Data\Mozilla\Firefox directory
(I'm running on Windows), at which point Firefox came up functional (but without
my bookmarks, extensions, and so on, of course).

Any guidance on how to install safely would be a public service.

Now that I've got Firefox running again with Derek's version of Venkman, the
floating pane issue seems to be corrected.  The layout issue discussed in
comments 5 and 6 remains, however.

Comment 17

13 years ago
Created attachment 153173 [details]
Test XPI with changes

I put together a new XPI that addresses the blank layout problem (but not
corrupt ones) and fixes the toolbar button.  Sounds like you may want to
uninstall any older version before useing...  If anyone can send me a pointer
on creating/submitting a patch I'd be happy to do that instead of an XPI.

Regarding the toolbar button, I used the 'step-into' button for large and per
James the javascript file w/breakpoint icon for small. Anyone feel like
creating a more appropriate one?
Attachment #153102 - Attachment is obsolete: true
(Assignee)

Comment 18

13 years ago
(In reply to comment #17)
> Created an attachment (id=153173)
> Test XPI with changes

Hmm. It's lost the common menus on Mozilla Suite... (and thus the code actually
thinks it's running on Firefox even when it's on the Suite!)

There was a reason why I did the sm and ff dirs. This was it. :)  (the FF one
probably isn't needed in this case, but it's there for symetry)

Comment 19

13 years ago
Created attachment 153372 [details] [diff] [review]
Above w/ fix for floated windows, blank layout pref, toolbars

I believe this patch addresses all issues noted above excepting installation
problems in comment #16.

Comment 20

13 years ago
Created attachment 153373 [details]
TestXPI that

XPI corresponding to patch 155372.
Firefox users may want to uninstall prior versions before using.
Attachment #153173 - Attachment is obsolete: true
(Reporter)

Comment 21

13 years ago
The latest test XPI doesn't install properly for me, even though I'm doing the
uninstall/restart/install/restart dance.  When I restart the second time,
Firefox never creates a window, but it seems to be doing something, since its
memory usage goes up and down a few K at intervals.  If I let it run for a while
before killing it, it will sometimes display itself the next time I start it. 
In this case, the extensions list says the debugger will install the next time I
restart Firefox, but it doesn't happen.

Is there any way I can gather useful diagnostic information without rebuilding
anything?

Comment 22

13 years ago
the xpi "venkman-0.9.83.xpi" also doesnt install on my firefox (new profile,
osx) seems as it blocks on the register part .. after the failed register the
application is unresponsive as described by comment #16 .. though the extension
window could be opened and after uninstall of venkmanext ff worked again normally.

Comment 23

13 years ago
the (marked as obsolete) "venkman-0.9.83-test.xpi" aka "test xpi with changes"
though seems to work with my firefox 0.9.1 :)
(In reply to comment #23)

Ditto with my WinXP Firefox .9.2 install.  The latest TestXPI went into the
extensions list with the typical "... will be installed when you restart"
message, but restarting FireFox did not finish the installation.  The menu
option was not installed and using x-jsd:debugger or firefox.exe -venkman popped
up a blank window titled JavaScript Debugger with no controls or menus.

I uninstalled the above and installed the TestXPI attached to this bug on
2004-07-14 and it seems to work great.  The one "error" I've found with this
installation so far is if I expand the "XStringBundle" entry in the "Loaded
Scripts" window, I get the following error:

!! Error loading URL <XStringBundle>: [Exception... "Component returned failure
code: 0x804b000a [nsIIOService.newChannel]" nsresult: "0x804b000a (<unknown>)"
location: "JS frame :: chrome://venkman/content/venkman-url-loader.js ::
_getChannelForURL :: line 50" data: no].

Comment 25

13 years ago
Comment on attachment 153373 [details]
TestXPI that

Seems the XPI is deadly for at least a subset of firefox installs...  can't
recommend it.
Attachment #153373 - Attachment is obsolete: true
Flags: blocking-aviary1.0RC1? → blocking-aviary1.0RC1-

Comment 26

13 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
When installing this XPI:
attachment 153173 [details]
clicking tools->JavaScript Debugger or starting firefox -venkman:
  An exception occurred while initializing, please file a bug.
  BadMojo 4: JS Debugger Service is not installed. @
  <chrome://venkman/content/venkman-debugger.js> line 122 (initDebugger)


attachment 153373 [details]
after a restart it still says "This item will be installed after you restart
Firefox"
on the Console it prints out:
*** nsExtensionManager::_finishOperations - failure, catching exception so
finalize window can close

using this latest firefox build:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a3) Gecko/20040722 Firefox/0.9.1+
i can't install the extension at all
(Reporter)

Comment 27

13 years ago
The first sounds like bug 239519, which has only been seen on Linux so far. 
Perhaps the fact that you get a different error with the later XPI means the
BadMojo problem has been addressed.

Derek and James: any ideas what the rest of us can do to help track down the
cause of the problem with the latest XPI?
(Assignee)

Comment 28

13 years ago
BadMojo 4 is pretty bad - it occurs when the debugger service (JSD) doesn't
exist; i.e. "@mozilla.org/js/jsd/debugger-service;1" is not listed in
Components.classes. I don't know how to check that, except to check that
jsd3250.dll, or it's platform Linux equiv., is in the components directory.

Hopefully I will be able to try a couple of the attached versions here later,
and also try to update my Aviary-branch CVS tree with all the useful/nessessary
changes so it can make an XPI that works.

Comment 29

13 years ago
Created attachment 154113 [details]
XPI package for Firefox 

Sorry for folks that have felt in the lurch without this.  Most of the major
technical issues are resolved the issue is creating a single package that would
work for both Mozilla and Firefox.  This XPI will not have full function if
used in Mozilla, but seems to work for FF where the last XPIs did not (I tested
with a clean 0.9.1 install on Win 2k).

Given many of the underlying problems are being addressed in the development
branches this may not be an issue for upcoming releases of firefox anyhow.
(Reporter)

Comment 30

13 years ago
Installs and fires up OK with Firefox 0.9.2 on Windows XP.  Thanks!

Comment 31

13 years ago
using Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626
Firefox/0.9.1 i still get the BadMojo-error

where should i find a jsd3250.dll (or jsd3250.so)? in /opt/firefox/components
there is none, and in
~/.mozilla/firefox/default.95p/extensions/{f13b157f-b174-47e7-a34d-4815ddfdfeb8}/components
i have only a venkman-service.js

Comment 32

13 years ago
(In reply to comment #31)
> using Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040626
> Firefox/0.9.1 i still get the BadMojo-error
> 
> where should i find a jsd3250.dll (or jsd3250.so)? in /opt/firefox/components
> there is none, and in

This file is windows specific. (That said there are a bunch of seemingly *js*.so
files in the mozilla tar that don't seem to be in FF...)  Which lib*js* files
are in your components directory?  

Can you use the javascript console?  If not I do think that this should move to
another bug since it is more serious and OS specific. 
(Assignee)

Comment 33

13 years ago
(In reply to comment #31)
> where should i find a jsd3250.dll (or jsd3250.so)? in /opt/firefox/components
> there is none, and in

It's probably called jsd3250.so on Linux, but I can't gurentee that. If it's not
in the components directory, it's possible the build didn't include JSD at all.
(Assignee)

Comment 34

13 years ago
To check if it wasn't included, open the URL "about:buildconfig" and look for
"--disable-jsd". If that's there, it's a build without JSD, otherwise it should
work.

Comment 35

13 years ago
I was using the Installer-Version - and the libjsd.so was not included!
using the 0.9.1-tared-version the debugger now works! (at least with a new fresh
profile)

is the libjsd.so only needed for the JavaScript-Debugger? If so, shouldn't this
file be in the xpi?
(Assignee)

Comment 36

13 years ago
(In reply to comment #35)
> is the libjsd.so only needed for the JavaScript-Debugger? If so, shouldn't this
> file be in the xpi?

If only it were that easy. Since it's a compiled component, you'll get a
different one for every platform/compiler combination, at minimum. This calls
for a Install bug....
(Assignee)

Updated

13 years ago
Depends on: 253663

Comment 37

13 years ago
thats right, of course...

shouldn't it be possible then to have this file (and the venkman itself too)
behind the options "Developer Tools" in the installer? at least the description
says "Tools for web developers including an error console, the Document
Inspector anda JavaScript Debugger"

but i'm pretty shure there is allready a bug for this :D

Comment 38

13 years ago
I have just installed the venkman.xpi located at
http://twpol.dyndns.org/temp/venkman-0.9.83.xpi ( July 9th 2004, 16:19) into
Firefox 0.9.2 and was happy to see that it is working fine.

Since Firefox is a popular browser, it would be really cool if the code changes
necessary to produce this XPI were somehow merged into the official Venkman sources.

Cheers,

Antoine

Comment 39

13 years ago
Hi there, 

just to clarify: The xpi on the noted URL also works on my install. (The size is
 207kb, 211 988 bytes). The previously posted (as v.xxx.83) did not work however.

Obviously, firefox 0.9.x + venkman is a great combo.

/mawi

(In reply to comment #38)
> I have just installed the venkman.xpi located at
> http://twpol.dyndns.org/temp/venkman-0.9.83.xpi ( July 9th 2004, 16:19) into
> Firefox 0.9.2 and was happy to see that it is working fine.
(Assignee)

Comment 40

13 years ago
Created attachment 161219 [details] [diff] [review]
Aviary Venkman 0.9.64 - includes basically everything to date
Attachment #152698 - Attachment is obsolete: true
Attachment #153372 - Attachment is obsolete: true
Comment on attachment 161219 [details] [diff] [review]
Aviary Venkman 0.9.64 - includes basically everything to date

r=shaver,a=drivers for aviary-branch landing.  Please make the utmost haste.
Attachment #161219 - Flags: review+
Attachment #161219 - Flags: approval-aviary+
(Assignee)

Comment 42

13 years ago
Landed on Aviary branch.
(Assignee)

Comment 43

13 years ago
Whoops, new files seemed to land on trunk instead of branch. Fixing...
(Assignee)

Comment 44

13 years ago
Right. Really landed this time.

Updated

13 years ago
Keywords: fixed-aviary1.0
Product: Core → Other Applications
(Assignee)

Comment 45

13 years ago
Created attachment 175775 [details] [diff] [review]
Sync FF branch work to trunk

This patch combinds a few things, but the result is a working Venkman in all of
the following (and hopefully most things in between):
  Mozilla 1.0
  Mozilla 1.7.1
  Mozilla 1.8b2 (trunk)
  Firefox 1.0
  Firefox 1.0+ (trunk)

There's a couple of issues, like in Moz 1.0 the icons don't show up in the
trees (need the alternate pseudo stuff), and in FF 1.0 the Open Windows list
seemed to perpetually stay empty, which needs poking, but we're getting there.

I've pushed a copy of the XPI built from this to:
  http://twpol.dyndns.org/temp/venkman-0.9.85.xpi

Comment 46

13 years ago
I've copied the XPI to hacksrus and added an entry on the venkman dev page. 
Thanks for saving Venkman's bacon!

Comment 47

13 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050227
Firefox/1.0+

I am able to install and use Venkman. Thank you.
(Assignee)

Comment 48

12 years ago
Comment on attachment 175775 [details] [diff] [review]
Sync FF branch work to trunk

The empty window list seems to be a fluke, this version does seem to work fine.
Attachment #175775 - Flags: review?(rginda)

Comment 49

12 years ago
I successfully applied the patch in attachment 175775 [details] [diff] [review] to both MOZILLA_1_8_BRANCH
and trunk and after bumping the firefox upper version to 1.4 successfully used
the resulting venkman xpi on both branch and trunk.

I did run into a hung process initially when exiting Firefox after using
venkman, but have been unable to reproduce it again.

Comment 50

12 years ago
I too successfully installed the patch in attachment 175775 [details] [diff] [review]. I patched the trunk
and bumped the max version to 1.6+. No hung process for me, everything has
worked fine.

Comment 51

12 years ago
Comment on attachment 175775 [details] [diff] [review]
Sync FF branch work to trunk

What's the status on this patch... Should I review it as is, or has it
bitrotted?

Comment 52

12 years ago
Comment on attachment 175775 [details] [diff] [review]
Sync FF branch work to trunk

oops, I missed jgaunt's comment.  r=rginda.
Attachment #175775 - Flags: review?(rginda) → review+
Checked in, with maxVersion bumped to 1.6 at Silver's request.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 54

12 years ago
Comment on attachment 175775 [details] [diff] [review]
Sync FF branch work to trunk

>     <RDF:li resource="chrome://communicator/content/tasksOverlay.xul"/>
>+    <RDF:li resource="chrome://browser/content/browser.xul"/>
>+    <RDF:li resource="chrome://messenger/content/messenger.xul"/>
This caused bug 317202.

Comment 55

12 years ago
When you plan to upload a Firefox 1.5 compatible version, directly on extension site?
You need to log in before you can comment on or make changes to this bug.