Update Sunbird classic theme

RESOLVED FIXED

Status

Calendar
Sunbird Only
RESOLVED FIXED
14 years ago
11 years ago

People

(Reporter: Chris Cook, Assigned: Mostafa Hosseini)

Tracking

Details

(URL)

Attachments

(15 attachments, 7 obsolete attachments)

2.70 KB, patch
Details | Diff | Splinter Review
80.84 KB, application/zip
Details
64.67 KB, application/zip
Details
46.80 KB, patch
Michiel van Leeuwen (email: mvl+moz@)
: first-review+
Details | Diff | Splinter Review
1.58 KB, application/zip
Details
2.08 KB, patch
Mostafa Hosseini
: first-review+
Details | Diff | Splinter Review
61.04 KB, application/zip
Details
782 bytes, patch
Details | Diff | Splinter Review
73.88 KB, image/png
Details
63.21 KB, image/png
Details
67.63 KB, image/png
Mostafa Hosseini
: first-review+
Details
8.57 KB, patch
Mostafa Hosseini
: first-review+
Details | Diff | Splinter Review
33.92 KB, image/png
Mostafa Hosseini
: first-review+
Details
21.54 KB, image/png
Mostafa Hosseini
: first-review+
Details
10.60 KB, patch
Mostafa Hosseini
: first-review+
Details | Diff | Splinter Review
(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

Calendar needs a new look. I am opening this bug, as requested, to track the
revision of the classic theme to support toolkit and to have updated graphics.
At least this is my understanding of the necessary work.

Todo:
1. Create new graphics for all application icons and toolkit dialogs (options,
themes, extensions, etc.)
2. Update theme style if necessary

Questions:
1. Will this skin be migrated into classic.jar (like other toolkit apps) or
remain in calendar.jar?
2. Will the modern theme continue to be supported?

I am uninformed about a possible contest for the theme revision so I'll let
others add that info if pertinent.

I have started work updating the theme with new icons created by Mark Carson.
I'll report further when there is something interesting to show.

Reproducible: Always
Steps to Reproduce:
(Reporter)

Comment 1

14 years ago
CC'ing bugzilla@babylonsounds.com as requested.

Comment 2

14 years ago
My understanding will be that Sunbird itself needs a new theme, Suite themes
will still be supported, though we need a new theme for our Standalone application.

IMO, also a `*stripe` theme would be useful for the firefox/TB installs.

(Marking NEW)
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

14 years ago
Is the intention is to somehow support both toolkit and xpfe?

The other stand-alone apps have used the classic skin for their default theme
(and have stopped supporting modern). How would a new theme _and_ classic and
modern be supported by calendar?

Comment 4

14 years ago
because we are an extension *and* stand-alone.
(Reporter)

Comment 5

14 years ago
I was intending to post patches (to classic) for the new skin. For a new theme,
should I just post the complete files (css, png, etc.) to this bug? How will
paths be handled? Should I just post a jar?

Comment 6

14 years ago
For the new theme I would suggest a zip file for the theme itself and seperately
PATCH files for the changes made to makefiles, etc.  (and jar.mn, etc.)

but this is me, and mostafah may prefer a different method.

Comment 7

14 years ago
Updating summary to better reflect reality. The call is currently for a new
default theme for Sunbird. And that's what we should focus on.

It should be no big problem to checkin a new theme into the sunbird cvs
directory and hook this up with some makefile-fu.

Updating or changing the calendar extension theme(s) is a whole different matter
and should be discussed in the calendar newsgroup/mailinglist.

Disclaimer: 
That is my personal opinion. In the end the decision lies with Mostafah.
Summary: Update classic theme → Update Sunbird classic theme

Updated

14 years ago
(Assignee)

Comment 8

14 years ago
We will keep the current themes for suite extension support. Anything new for
sunbird will end up in calendar/sunbird/base/skin ( which is currently empty ).
If the look and feel of the new graphics happen to be more consistent with the
theme of firefox and thunderbird, we will supply the same theme for them as well.
A zip file of the new skin directory would be sufficient.
(Reporter)

Comment 9

14 years ago
In the current build (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2)
Gecko/20040602 Mozilla Sunbird/0.1.1+) the skin lives in both calendar.jar and
classic.jar but the "contest" requests only a calendar.jar to be submitted so I
assume all of the skin will be migrated into calendar.jar. Will this happen
gradually or are you waiting for the theme to be created first? It is difficult
to test theme changes when the xul is referencing css files which exist in the
classic.jar file. Currently I am forced to update classic.jar to make and test
changes.
Chris, the classic.jar comes from Firefox. With our recent changes in the build
system we don't package that file anymore (or only parts of it) as far as I
know. If you need any files from there, then please identify those so that we
know what we may eventually need to hook up or fork for our purposes.

If you can't supply your proposal in the calendar.jar, but in another file, then
that is fine. We won't kill you for it :-)
(Reporter)

Comment 11

14 years ago
I should have been more clear. Some xul is pointing to stylesheets in the
browser component instead of calendar. In particular
calendar/resources/content/pref/pref.xul is importing
chrome://browser/skin/pref/pref.css while it should, as far as I know, be
importing chrome://calendar/skin/prefs.css. Or should that be
chrome://calendar/skin/pref/pref.css? There is a file for the latter but not the
former.

What I meant before is that I would have to update
chrome://browser/skin/pref/pref.css which is packaged in classic.jar in order to
style the options dialog but pref.xul should obviously (to me) be updated to
import the appropriate stylesheet.

There are other references to files in the browser component as well but mostly
dtds and not css so I won't mention them here.
(Reporter)

Comment 12

14 years ago
What modifications are sought for the initial theme change? The contest posting
isn't clear.

All current themes currently skin the toolbar but leave the calendar area with a
common style (AFAIK). Should the new theme design update the calendar area style
and graphics as well?

When the new theme is initially deployed, will it make use of both small and
large icons similiar to Firefox and Thunderbird?

Will the options dialog require the "Themes" and "Extensions" icons or will
these be relocated to the Tools menu similar to Firefox?

Will additional toolbar buttons be added (cut, copy, paste, import, export,
etc.) similar to Firefox?

Knowing these things will help me prioritize the changes.
(Reporter)

Comment 13

14 years ago
Created attachment 152231 [details] [diff] [review]
Patch pref.xul to use skin in the calendar package

RE comment 11. This updates the pref dialog xul to use css located in the
calendar package. It also renames the option button ids which I hope is
appropriate.

Since this is a non-skin file I'm attaching it separately as a patch.
(Assignee)

Comment 14

14 years ago
This check-in applies the submitted patch and adds the base framework for using
the new theme for sunbird:

http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=mozilla%2Fcalendar&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2004-07-03+9%3A00&maxdate=2004-07-03+10%3A00&cvsroot=%2Fcvsroot

Thanks for the patch.
(Reporter)

Comment 15

14 years ago
Created attachment 152632 [details]
Winstripe theme - first revision

This zip contains my winstripe theme. Toolbar icons and options dialog have
been replaced and appropriate CSS has been updated. The theme includes a
/skin/mozapps/pref directory which contains the options dialog css to be
consistant with Firefox and Thunderbird skin implementations.

Some filenames (toolbar icons) are different than the originals in anticipation
of more being added once toolbar customization lands (i.e., small icons),
though it can be changed if this is a showstopper.
(Reporter)

Comment 16

14 years ago
In case it matters, I'll be offline from July 10-18.
(Assignee)

Comment 17

14 years ago
I've checked in the files from attachment 152632 [details] which are from the new theme
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=mozilla%2Fcalendar%2Fsunbird%2Fthemes&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=08%2F06%2F2004+10%3A30&maxdate=08%2F06%2F2004+10%3A40&cvsroot=%2Fcvsroot

Please provide the rest of the graphics and/or changes to the css files so I can
update the tree
(Reporter)

Comment 18

14 years ago
re #17, do you mean graphics updated since the attachment submission or are 
there missing files?

In that attachment the CSS still uses the current throbber though I've changed 
the throbber to the one used by FF/TB in my later revisions. Should we use it?
(Reporter)

Comment 19

14 years ago
The new images checked in have text encoding so they don't check-out properly. 
Were they not checked in correctly or do I need to change something in my cvs 
config?
(Assignee)

Comment 20

14 years ago
(In reply to comment #18)
> re #17, do you mean graphics updated since the attachment submission or are 
> there missing files?

The blue arrows?
I've actually emailed Marc to see if he can give them to us in the same format
as the old ones:
http://lxr.mozilla.org/mozilla/source/calendar/resources/skin/classic/prevnextarrow.png
http://lxr.mozilla.org/mozilla/source/calendar/resources/skin/classic/pageupdown.png

> In that attachment the CSS still uses the current throbber though I've changed 
> the throbber to the one used by FF/TB in my later revisions. Should we use it?
No big deal. We don't have an activity to show by an animated throbber so for
now we'll use the sunbird icon.
(Assignee)

Comment 21

14 years ago
(In reply to comment #19)
> The new images checked in have text encoding so they don't check-out properly. 
> Were they not checked in correctly or do I need to change something in my cvs 
> config?

Fixed.
(Reporter)

Comment 22

14 years ago
Created attachment 155875 [details]
Updated images and supporting CSS

This zip contains updated theme images and the required css changes only. I am
still working on theme changes unrelated to images which I will post as they
become ready.

I simply put the calendar.css in the zip. Let me know if you need a patch
instead.

I also added /mozapps/pref/pref.css to this zip because it wasn't previously
added and /content/calendar/pref/pref.xul references it. I don't know if
supporting the new mozapps toolbox component is planned for Sunbird so I chose
to support it until I am told otherwise.
(Assignee)

Comment 23

14 years ago
New images and changes have been checked into cvs.
Note that in calendar.css, I kept "cursor:pointer;" for the week/month
navigation buttons (e.g. #multiweek-next-button ) since I wasn't sure why they
were take out.
Also regarding mozapps/pref/pref.css, this is the pref.css defined in
toolkit/mozapps:
http://lxr.mozilla.org/mozilla/source/toolkit/themes/winstripe/mozapps/pref/pref.css
we get it by default.
(Assignee)

Comment 24

14 years ago
New logo has been checked in
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=mozilla%2Fcalendar&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=08%2F16%2F2004+12%3A00&maxdate=08%2F16%2F2004+12%3A10&cvsroot=%2Fcvsroot
Created attachment 156672 [details] [diff] [review]
Hook up the new buttons

This patch enables the new buttons (new task, cut, copy, paste, import, export,
subscribe, publish, print, choose date, go to today) in the customize toolbar
dialog. It also eanbles the new-task button on the default toolbar. This patch
covers all languages (localizers have to translate the new strings, of course).


Remaining issues:
- we need a "customize toolbar" menuitem in the view-menu
- we should get rid of the "go to today button" under the mini-calendar

I will open new bugs for these issues.

Updated

13 years ago
Attachment #156672 - Flags: first-review?(mostafah)
I filed bug 256405 and bug 256407 for the remaining issues and attached patches
there.
(Assignee)

Updated

13 years ago
Attachment #156672 - Flags: first-review?(mostafah) → first-review?(mvl)
Attachment #156672 - Flags: first-review?(mvl) → first-review+
Checked in the new buttons patch. Can this bug be closed now?
(Reporter)

Comment 28

13 years ago
My opinion is that the theme is about more than the toolbar button images. I am
working on updating the appearance of the calendar view area which still falls
under the heading of this bug. However, if this work is not desired I would like
to know now.
It's not that i think changes like that are not welcome! I just didn't think
about it :)
But i do think that splitting off a different bug for that work would be better,
to keep stuff readable. Otherwise, someone looking for info on why the view
changed, has to wade through lots of buttons stuff before finding it.
(Reporter)

Comment 30

13 years ago
I was under the impression that the scope of "theme contest" and this bug was
about the whole theme and not just the toolbar. If that scope is too large I
have no problems with working in new bug.
Nobody said everything that falls under the contest has to be done in this bug. :)
I removed the !important clauses from the button rules in calendar.css in a
seperate checkin. They are not needed.
(Reporter)

Comment 33

13 years ago
Created attachment 157766 [details] [diff] [review]
Patch to change throbber to Firefox style

This patch requires the throbber images to be attached next.
(Reporter)

Comment 34

13 years ago
Created attachment 157767 [details]
Throbber images

These images need to be dropped in /themes/winstripe/sunbird.

Forgot to mention, I'm not sure why the #navigator-throbber[busy="true"]
selector section was removed so I put it back in, but IMO if we're going to
remove that then we may as well remove the throbber altogether.
(Reporter)

Comment 35

13 years ago
Created attachment 157768 [details] [diff] [review]
Patch to change throbber to Firefox style

Updated patch to fix sloppy whitespace. Sorry for the spam.
Attachment #157766 - Attachment is obsolete: true
(Reporter)

Comment 36

13 years ago
Created attachment 157778 [details] [diff] [review]
Patch to change throbber to Firefox style( checked in )

Added changes for jar.mn file. Hope I got that part right.
Attachment #157768 - Attachment is obsolete: true
(Reporter)

Comment 37

13 years ago
Created attachment 157779 [details]
New "about" dialog files to make it consistant with other apps

These files make the about dialog look the same as those in Firefox and
Thunderbird. I had to hack the current logo image to look decent (added the
Brand text and fixed the weird semi-transparent border) but Mark will have to
create a final version.

Is there a way to create diffs for new files if you don't have add permission?
(Reporter)

Comment 38

13 years ago
Created attachment 157780 [details]
New "about" dialog files to make it consistant with other apps

Oops. Last upload didn't work.
Attachment #157779 - Attachment is obsolete: true
(Reporter)

Comment 39

13 years ago
Created attachment 157781 [details] [diff] [review]
Patch to update jar.mn for aboutDialog new files
(Reporter)

Comment 40

13 years ago
Created attachment 157782 [details]
Screenshot of about dialog with patch (and hacked image) applied

Comment 41

13 years ago
Created attachment 157784 [details]
Sunbird About graphic without text
(Reporter)

Comment 42

13 years ago
(In reply to Comment #41)
Can you create a version WITH the brand text and slogan, which is 300x236px just
so we can have that option. The files I've added rely on this being part of the
image.

Also, if you look closely there is a dark line at the bottom and on the left
side. Please make sure that it isn't there in updated versions as it is quite
visible on the white background.
(Reporter)

Comment 43

13 years ago
Sorry. I didn't realize that you already posted a graphic with text in bug
157657. However, the brand text in that image doesn't really match the style
used in the other apps.
(Reporter)

Comment 44

13 years ago
Doh! Sorry, that should have been bug 257711.

Comment 45

13 years ago
Created attachment 157819 [details]
Sunbird About Page Graphic with Text

300x236 image with text (green "Sinbird", black "it's about time")

Comment 46

13 years ago
Created attachment 157820 [details]
Sunbird About Page - no text

300x236 image without text
Attachment #157784 - Attachment is obsolete: true
(Reporter)

Comment 47

13 years ago
(In reply to comment #45)
That green is a bit bright isn't it? Try putting my screenshot next to Firefox's
about dialog and I think you'll find that the darker green matches better with
the darker red text of the other.

Comment 48

13 years ago
Created attachment 157825 [details]
Sunbird About page with (darker) green text
Attachment #157819 - Attachment is obsolete: true

Comment 49

13 years ago
Created attachment 157826 [details]
Sunbird About Page graphic with text

Oops - grabbed the wrong image a moment ago.
(Reporter)

Comment 50

13 years ago
Much better. If I were a graphic artist I would probably have some comment about
the slogan not being the same length as the brand, but I'm not ;-)

Comment 51

13 years ago
Created attachment 157840 [details]
Sunbird About Graphic - justified text

Everyone's a critic. Just kidding Chris. The previous one was close, but I
think one is right on. BTW - I'm not a graphic designer either :-) Just a coder
who hacks out some grapics for fun.
Attachment #157825 - Attachment is obsolete: true
Attachment #157826 - Attachment is obsolete: true
(Reporter)

Comment 52

13 years ago
Comment on attachment 157778 [details] [diff] [review]
Patch to change throbber to Firefox style( checked in )

This patch hooks up the new throbber image. Please review and check in if
appropriate.
Attachment #157778 - Flags: first-review?(mostafah)
(Reporter)

Comment 53

13 years ago
Created attachment 162553 [details] [diff] [review]
Patch to update toolbar graphics to support image changes( checked in )

This patch supports changes made to the toolbar graphic by Mark Carson.
Specifically, the view (day, week, multi-week, month) buttons have been given a
new icon for their "checked" state.

This patch relies on the following image files being replaced/updated:
toolbar-large.png
toolbar-small.png
(Reporter)

Comment 54

13 years ago
Created attachment 162902 [details]
New toolbar-large with "pressed" view button graphics( checked in )
(Reporter)

Comment 55

13 years ago
Created attachment 162903 [details]
New toolbar-small with "pressed" view button graphics( checked in )
(Reporter)

Comment 56

13 years ago
Comment on attachment 162553 [details] [diff] [review]
Patch to update toolbar graphics to support image changes( checked in )

The required toolbar images have been attached. Provided the new "pressed"
graphic is suitable this is ready to go.
Attachment #162553 - Flags: first-review?(mostafah)
*** Bug 264919 has been marked as a duplicate of this bug. ***
Created attachment 164009 [details] [diff] [review]
rev0 - trunk - changes about dialog to mimic Firefox's

This patch makes "About Sunbird" look similar to Firefox, and gets rid of a
nasty scrollbar problem on Mac OS X once the useragent wrapped to 3 lines.

mozilla/calendar/sunbird/base/content/about.png is attachment 157840 [details] above.

The patch also moves the Sunbird-specific about dialog components inside
Sunbird's directory, rather than have them added to the calendar.jar of the
xpi.
Attachment #164009 - Flags: first-review?(mostafah)
(Assignee)

Updated

13 years ago
Attachment #157778 - Attachment description: Patch to change throbber to Firefox style → Patch to change throbber to Firefox style( checked in )
Attachment #157778 - Flags: first-review?(mostafah) → first-review+
(Assignee)

Updated

13 years ago
Attachment #162553 - Attachment description: Patch to update toolbar graphics to support image changes → Patch to update toolbar graphics to support image changes( checked in )
Attachment #162553 - Flags: first-review?(mostafah) → first-review+
(Assignee)

Updated

13 years ago
Attachment #162902 - Attachment description: New toolbar-large with "pressed" view button graphics → New toolbar-large with "pressed" view button graphics( checked in )
Attachment #162902 - Flags: first-review+
(Assignee)

Updated

13 years ago
Attachment #162903 - Attachment description: New toolbar-small with "pressed" view button graphics → New toolbar-small with "pressed" view button graphics( checked in )
Attachment #162903 - Flags: first-review+
(Assignee)

Comment 59

13 years ago
Comment on attachment 164009 [details] [diff] [review]
rev0 - trunk - changes about dialog to mimic Firefox's

Patch checked in with minor tweaks:
sunbird.png is about-sunbird.png
kept height setting for aboutDialog.xul
Attachment #164009 - Flags: first-review?(mostafah) → first-review+
(Assignee)

Comment 60

13 years ago
Comment on attachment 157840 [details]
Sunbird About Graphic - justified text

Checked in as sunbird/base/content/about-sunbird.png
Attachment #157840 - Flags: first-review+
(Assignee)

Comment 61

13 years ago
This bug is fixed now. Please open new bugs for more improvements.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
The bugspam monkeys have been set free and are feeding on Calendar :: Sunbird Only. Be afraid for your sanity!
QA Contact: gurganbl → sunbird
You need to log in before you can comment on or make changes to this bug.