Closed Bug 248419 Opened 16 years ago Closed 16 years ago

[Linux] Yellow background in location bar for secure site indication does not show

Categories

(Firefox :: Address Bar, defect)

1.0 Branch
x86
Linux
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox1.0

People

(Reporter: ali, Assigned: steffen.wilberg)

References

Details

(Keywords: fixed-aviary1.0)

Attachments

(1 file)

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040623 Firefox/0.9.0+

On Linux, the yellow background in the location bar for secure site indication
does not show. Although the SSL lock shows, the background remains white.

It works fine on Windows.
Flags: blocking1.0?
it blocks a blocker, don't muddy the water :)
Flags: blocking1.0?
For an explanation what's happening, see bug 244025 comment 37 and bug 244025
comment 41.
-> bryner
Assignee: bugs → bryner
Flags: blocking-aviary1.0+
this is pretty much due to the crappy moz-appearance impl on GTK, per bz and my
own testing.

evil CSS hackery is probably our best short-term bet... if someone wants to dig
into it enough
Bug 241070 looks to be the fix needed here, and it even has an unreviewed patch.
*** Bug 259664 has been marked as a duplicate of this bug. ***
have a fix, need to test on other platforms to make sure it doesn't hork those
platforms.

-moz-appearance sucks
Assignee: bryner → mconnor
ok, short version is that to get this to work fine, just add -moz-appearance:
none; to the style rule that hardcodes the colors.

Steffen, if you can patch/drive this, that'd be great.
Assignee: mconnor → steffen.wilberg
Attachment #161139 - Attachment description: -moz-appearance: none none → -moz-appearance: none
Comment on attachment 161139 [details] [diff] [review]
-moz-appearance: none

One-liner, as suggested by Mike. Fixes the problem in Linux, and doesn't harm
Windows.
Attachment #161139 - Flags: review?(bugs)
Status: NEW → ASSIGNED
Whiteboard: [have patch]
Target Milestone: --- → Firefox1.0
Version: unspecified → 1.0 Branch
Comment on attachment 161139 [details] [diff] [review]
-moz-appearance: none

r+a=ben@mozilla.org if the field still has the standard blue luna border around
the edge.
Attachment #161139 - Flags: review?(bugs)
Attachment #161139 - Flags: review+
Attachment #161139 - Flags: approval-aviary+
Checked in br & trunk.
Status: ASSIGNED → RESOLVED
Closed: 16 years ago
Keywords: polishfixed-aviary1.0
Resolution: --- → FIXED
Whiteboard: [have patch]
> r+a=ben@mozilla.org if the field still has the standard blue luna border around
> the edge.
It still has.
Marking VERIFIED YELLOW, er, FIXED, with Linux Gecko/20041010 Firefox/0.10.1.
See bug 263750 for 1px black border regression (which I think looks neat) caused
by this.
Status: RESOLVED → VERIFIED
*** Bug 282963 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.