Filter message As Junk: message not handled as Junk, left in Inbox

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
15 years ago
11 years ago

People

(Reporter: wilhelm.svenselius, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla Thunderbird version 0.7 (20040616)

Usually, Mozilla Thunderbird will suppress the "New mail" notification window
when all new messages are flagged as Spam by the adaptive filter. However, this
does not work under certain circumstances. The company where I work uses a spam
filtering software on its own server, which tags messages with "*****SPAM*****"
in the subject row for easy filtering. I have set Thunderbird to automatically
flag such messages as Junk and move them to the junk mail folder. Since these
messages are marked as Junk when received, it is my opinion that Thunderbird
should _not_ announce them as new messages.

Reproducible: Always
Steps to Reproduce:
Receive e-mail which is marked as Junk and moved/deleted by message filter other
than Thunderbird's adaptive e-mail filter.

Actual Results:  
A New E-mail notification was displayed.

Expected Results:  
No notification should be displayed so long as all incoming messages are Junk.

The message filter I use is configured as follows:

For incoming messages that:
Match any of the following
Subject contains *****SPAM*****

Perform these actions:
Move to folder: Junk on Local Folders
Set Junk Status to: Junk

Comment 1

15 years ago
See bug 206050, this should be fixed in Thunderbird now.

Comment 2

15 years ago
I think this is a duplicate of Bug 189289 requesting "No new mail notification
(biff) when junk mail (spam) arrives."

Bug 206050 requests no new mail notification if that new mail is marked read by
a filter. Bug 206050 Comment #2 refers to Bug 189289.

Comment 3

15 years ago
I don't think this is a dupe of 189289, because I don't think the messages 
Reporter is complaining about have been ID'd as junk, they've only been moved to 
the Junk folder.  Wilhelm Svenselius, is that correct?

Bug 224573 is about suppressing notification for mail filtered to a particular 
folder; bug 11040 is about suppressing notification as a filter action.  
However, in your case, you can simply add the action "Mark Message Read" to your 
filter, in addition to "Move to" Junk, and that should suppress notification for 
these messages.  If this solution is satisfactory, please mark this bug as 
  Resolved|Invalid
otherwise, mark it as a duplicate of one of the bugs mentioned above.
(Reporter)

Comment 4

15 years ago
Mike: The messages are not only moved to the junk folder; the filter explicitly
marks them as junk regardless of whether the adaptive filter thinks they are
junk or not. One of the filter actions is "Set Junk Status to: Junk".

I have added the action "Mark Message Read" to the filter, assuming it works I
am most grateful for your assistance, as this bug has been a major cause of
annoyance for me. However, I do not feel it is a satisfactory solution, rather a
work-around since junk mail should never trigger a notification, even if it's
"unread".

This bug is similar to 11040 but not quite the same; 11040 is an enhancement, ie
the addition of a means to control when a new mail notification should be
displayed using filters. If 11040 were resolved, it would provide another
workaround for this bug, which would be to simply add the "Do not notify me"
action to the filter. However, this bug is about changing the DEFAULT BEHAVIOUR
or Thunderbird so that messages that have been marked as junk never trigger a
notification.

Comment 5

15 years ago
Wilhelm: Another workaround for your specific example would be to train the
adaptive filter - it should learn very quickly that messages with
"*****SPAM*****" in the subject are just that :-)

I agree that if a message filter sets the "junk status" to Junk" then the new
mail notification should be suppressed (subject to whatever the user preferences
might be for notification of new spam if/when those prefs are implemented).

This bug clearly falls under the scope of Bug 189289, but the fix to that bug
only dealt with the case of the adaptive spam filter marking messages as "Junk".
I don't know whether the case of a message filter marking messages as "Junk" is
best addressed in Bug 189289 (by reopening) or best addressed here, in this bug.

Comment 6

14 years ago
*** Bug 250417 has been marked as a duplicate of this bug. ***

Comment 7

14 years ago
The problem here, I would say, is not just the notification.  It seems to me 
that if a filter marks a message as Junk (and does not do anything else), then 
when the JMC processing takes over after filters run, that message should be 
treated like anything automatically ID'd as junk -- and so, if the junk is 
normally automatically moved, the filtered message should be automatically 
moved.  This should suppress notification for the bug, as well.

If JMC normally leaves mail in the Inbox, notification should still be 
suppressed -- it doesn't, but that's bug 233929.

The problem mentioned by reporter is also similar to bug 233930 -- if a junk 
message is filtered to another folder before JMC can run on it, it still 
generates a notification, but (in the automatically-ID'd case) that's because 
the junk processing hasn't run on that message at all, yet, and won't until the 
destination folder is opened.
Assignee: mscott → sspitzer
Status: UNCONFIRMED → NEW
Component: General → Filters
Ever confirmed: true
Product: Thunderbird → MailNews
Summary: New mail notification when only spam messages received → Filter message As Junk: message not handled as Junk, left in Inbox
Version: unspecified → Trunk

Comment 8

14 years ago
*** Bug 267674 has been marked as a duplicate of this bug. ***
Product: MailNews → Core
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody
dupe of Bug 389098?
I don't think so (not sure), as that's about it not moving. I think there won't be any notification anymore - is this bug still happening?
QA Contact: filters
Don't know if still happening, and everyone here seems to be gone.  But Mike in comment 7 modified the summary to be about "not moving", I'm guessing on the premise that the underlying cause of the notification issue is the message simply wasn't being moved.  Hence, my comment 10.
(Reporter)

Comment 13

11 years ago
I think this has been fixed for a while now (I am the original submitter). Any reason this bug is still open? I could try to see if it is still reproducible if anyone is interested.
->WFM then
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

11 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.