Closed Bug 249251 Opened 15 years ago Closed 15 years ago

Prevent theme/extension version incompatibility for subminor Firefox/Thunderbird releases


(Toolkit :: Application Update, defect, P2, minor)






(Reporter: gkn, Assigned: bugs)



(Keywords: fixed-aviary1.0)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7) Gecko/20040626 Firefox/0.9.1

When Firefox 0.9.1 came out, it had to have an app version of 0.9, so that
0.9-compatible extensions could be installed into it (bug 249015 comment 8).

There should be a system to allow extensions to be installed into subminor
updates of the extensions' targeted releases. The onus should be on the
application developers not to break functionality between subminor releases.

Suggested ways to fix this:
bug 249015 comment 10
bug 249015 comment 14

Personally, I prefer the latter as it's "smarter".

Reproducible: Always
Steps to Reproduce:
1. Release Firefox 0.9.1
2. Realise 0.9 extensions refuse to install

Actual Results:  
A bit of software-update–related awkwardness

Expected Results:  
Updates all run smoothly – no bogus notifications for 0.9.1 users, no
notifications missing for 0.9 users
We should probably consider doing something before 1.0, as Bug 249015 generated
dupes at a rate of one every few hours.
Ever confirmed: true
Flags: blocking-aviary1.0?
Blocks: 245953
The fix for this is to create a pref that contains the extension compatibility
version, and only rev it when there are major changes. 

Currently we have app.version, but I think we need a separate one for extensions. 
Flags: blocking-aviary1.0RC1+
Flags: blocking-aviary1.0?
Flags: blocking-aviary1.0+
Priority: -- → P2
I'm confused.  It sounds like you want to do away with minVersion and maxVersion
and go back to using a chrome version like skins had to have in contents.rdf.

I think that for compatibility, we should do what the summary says and "ignore"
the subminor.  However, the browser should detect a subversion is available,
such as Firefox 0.9.2 which would be marked as critical.
OK, I've added a pref - app.extensions.version that tracks compatible extensions
separately. This should make it so that 0.9 extensions work (for better or
worse) in 0.9+

Authors should not worry about the value of this pref - we track this separately
rather than ignoring minor versions in case (who knows) a .1 update causes
extensions to break and we *have* to break compatibility. 

br&trunk fixed.
Closed: 15 years ago
Resolution: --- → FIXED
*** Bug 251411 has been marked as a duplicate of this bug. ***
*** Bug 251540 has been marked as a duplicate of this bug. ***
*** Bug 248653 has been marked as a duplicate of this bug. ***
Keywords: fixed-aviary1.0
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.