If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

update.rdf has 0.9.1 but app doesn't (0.9.1 says new version is available when it isn't)

RESOLVED FIXED

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED FIXED
13 years ago
2 years ago

People

(Reporter: Michael Lefevre, Assigned: wolf)

Tracking

Details

(Whiteboard: see comment 46 on how to stop being notified, URL)

(Reporter)

Description

13 years ago
This may not be something that we actually want to fix but...

0.9.1 has an app version of 0.9, for the benefit of themes and extensions. UMO's
update.rdf is now advertising version 0.9.1, which doesn't exist, so 0.9.1 users
are being told there's a new version available when there isn't.

The question is whether it's better to fail to give notifications to 0.9 users,
or to give bogus notifications to 0.9.1 users.

Comment 1

13 years ago
It's a bit annoying to have that popup each time you start your browser IMHO :)
*** Bug 249017 has been marked as a duplicate of this bug. ***

Comment 3

13 years ago
(In reply to comment #1)
> It's a bit annoying to have that popup each time you start your browser IMHO :)

I have to agree with this.  It's not a show stopper, but it's distracting, and
that will gradually eat up user goodwill, IMO.

Comment 4

13 years ago
Maybe we should leave update.rdf like this for a week or so, to inform 0.9
users, and then change it back to 0.9, to stop bugging 0.9.1 users.

Comment 5

13 years ago
The problem is not update.rdf but "app.version" (see about:config) of Firefox 0.9.1.

Setting this to 0.9.1 (as it should be imho) fixes the troubles (you may have to
reset "update.app.updatesAvailable" to "false").

WFM at least.
*** Bug 249023 has been marked as a duplicate of this bug. ***

Comment 7

13 years ago
0.9.1 users are more important, since all new dowloads will be 0.9.1 and a lot
of 0.9 users will upgrade soon.  
(Reporter)

Comment 8

13 years ago
Tobias - yes, that's true. But it was intentionally left at 0.9. If you set it
to 0.9.1, you won't be able to install the extensions for 0.9.

Updated

13 years ago

Comment 9

13 years ago
(In reply to comment #8)
> Tobias - yes, that's true. But it was intentionally left at 0.9. If you set it
> to 0.9.1, you won't be able to install the extensions for 0.9.

So what should 0.9.1 users should do to disable this stupid update warning? It
there a way to do this, without disabling the possibility to get/install
extensions for 0.9?

Comment 10

13 years ago
Well, I say there's need for another version string then.
app.extensionCompatibleVersion or something like that.

app.version should clearly be 0.9.1. Nah?
(Reporter)

Comment 11

13 years ago
*** Bug 249029 has been marked as a duplicate of this bug. ***

Comment 12

13 years ago
Why do we need to disable extensions for 0.0.1 version increments? Such upgrades
should almost always be backward compatible. Additionally, there should be a
mechanism to mark a particular 0.0.1 update as incompatible with previous
releases on that branch so that extensions can be disabled and reenabled. As
suggested in comment 10 another version string like
app.extensionCompatibleVersion could implement both of these requirements with
minimal code changes.

Stupid hacks like using different version numbers on the update service and in
the release are just causng confusion and  will do so again when the same
situation arises in the future.

Comment 13

13 years ago
I'd have to agree here.  Though it's not a major problem, it should be fixed
sooner rather than later.

Comment 14

13 years ago
How about leaving app.version as 0.9 for the extensions compatability and
creating a new app.build string that the Update function also checks?

Ideally, (in the 1.0.* or 0.10.* ?), the extensions should only check the first
two version numbers (1.2.*) (the Major.Minor number) , while the update should
check the full version string (1.2.3) (Major.Minor.Build). 

I assume that any changes that would break the extensions would cause the Minor
version to be incremented (1.2.* to 1.3.*).
(Reporter)

Comment 15

13 years ago
*** Bug 249033 has been marked as a duplicate of this bug. ***

Comment 16

13 years ago
*** Bug 249040 has been marked as a duplicate of this bug. ***
Maybe Firefox could have another, separate pref, listing which theme/extension
versions to accept in addition to the current version.

i.e. the application version would be 0.9.1 (so 0.9.1 users wouldn't be informed
of the bogus upgrade), but 0.9.1 would be allowed to install extensions made for
0.9 and 0.9.0+.
(In reply to comment #1)
> It's a bit annoying to have that popup each time you start your browser IMHO :)

Does unticking Tools > Options > Advanced > Software Update > Periodically check
for updates to Firefox stop the false notification?

Comment 19

13 years ago
See bug 248653.

Comment 20

13 years ago
*** Bug 249062 has been marked as a duplicate of this bug. ***
*** Bug 249085 has been marked as a duplicate of this bug. ***
*** Bug 249096 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 23

13 years ago
OK, this bug is now fixed.. I've reverted the changes to update.rdf on the
server, so there should be no *new* notifications popping up.

SmartUpdate really needs a way to notify end-users of minor releases without
causing this kinda upheavil with extension versions. (but that'd be a different
bug. heh)

Another bug that some of the users may be bitten by, is the fact that Firefox
stores update data, so it'll continue to prompt you on startup.. For those of
you who have this problem:
1. Go to about:config
3. filter update.app
2. Right-click and reset each of these back to defaults 
update.app.AppDescription, update.app.updateURL, update.app.Version, and
update.app.UpdatesAvailable
3. Restart Firefox.
That should clear Firefox from thinking there's an update. and stop the prompt
from appearing on startup.
Status: NEW → ASSIGNED
(Assignee)

Comment 24

13 years ago
Marking Fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 25

13 years ago
*** Bug 249116 has been marked as a duplicate of this bug. ***

Comment 26

13 years ago
*** Bug 249135 has been marked as a duplicate of this bug. ***

Comment 27

13 years ago
*** Bug 249152 has been marked as a duplicate of this bug. ***

Comment 28

13 years ago
*** Bug 249197 has been marked as a duplicate of this bug. ***

Comment 29

13 years ago
*** Bug 249160 has been marked as a duplicate of this bug. ***

Comment 30

13 years ago
*** Bug 249208 has been marked as a duplicate of this bug. ***

Comment 31

13 years ago
*** Bug 249201 has been marked as a duplicate of this bug. ***

Comment 32

13 years ago
*** Bug 249247 has been marked as a duplicate of this bug. ***
see bug 249251

Comment 34

13 years ago
*** Bug 249273 has been marked as a duplicate of this bug. ***
*** Bug 249392 has been marked as a duplicate of this bug. ***

Comment 36

13 years ago
*** Bug 249389 has been marked as a duplicate of this bug. ***

Comment 37

13 years ago
*** Bug 249414 has been marked as a duplicate of this bug. ***

Comment 38

13 years ago
*** Bug 249448 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 39

13 years ago
*** Bug 249671 has been marked as a duplicate of this bug. ***

Comment 40

13 years ago
*** Bug 249790 has been marked as a duplicate of this bug. ***

Comment 41

13 years ago
*** Bug 249897 has been marked as a duplicate of this bug. ***

Comment 42

13 years ago
*** Bug 249924 has been marked as a duplicate of this bug. ***

Comment 43

13 years ago
Comment #23 solved my problem. CCM at a medium-large scale is what I do,
consider wisely the importance of image damage that this small problem brings so
easily.

Browser's version is in the format: A.B.C = VBrowser
                                    ^ ^ ^
                                    | | \------ revision number
                                    | \-------- minor version
                                    \---------- major version

You should have a "minimum version known to be compatible with" = VPackage
specified in the extension package and a configurable versioning policy in the
browser. The point of being able to configure the policy is that you should be
able, after some messing in about:config, to install anything. 

On the machine that wants to install a package:
- if VPackage is older than VBrowser: refuse to install.
- if only VPackage.B is older than VBrowser.B: ask an extra confirmation
- if only VPackage.C is older than VBrowser.C: display a warning

Comment 44

13 years ago
*** Bug 250206 has been marked as a duplicate of this bug. ***

Comment 45

13 years ago
It's not resolved or fixed and it's very annoying to get this popup and the
continual red exclamation point saying you need an update.  Unclicking the
notification under Tools, Software, Update does nothing to stop this annoyance.
Can't it be fixed?

Updated

13 years ago
Whiteboard: see comment 23 on how to stop being notified
(Assignee)

Comment 46

13 years ago
This bug is fixed as far as Mozilla Update is concerned..
http://update.mozilla.org/update.rdf uses 0.9.0, to prevent further
notifications from occuring.
The problem you're seeing is that Firefox stored the update info for a version
it can't figure out. Comment #23 contains instructions to fix that.
It's not a bug, normally, as the application should've canceled the notification
when you updated, but it doesn't think of itself as 0.9.1, therefore it thinks
that 0.9.1 is newer than itself (0.9.1 > 0.9.0). If I could remotely trigger
firefox to give up on that update, I would.. but I've done all I can.

Clearer Instructions on how to fix the persistant notification:
1. Type about:config into the Location bar and press <enter>
 A listing of firefox prefs appears with a filter/search box at the top.
2. In the filter box at the top enter, update.app
 The list changes to show only the update.app.* preferences.
3. Right-click on each of these items and choose reset on the menu that appears.
update.app.AppDescription, update.app.updateURL, update.app.Version, and
update.app.UpdatesAvailable
 This will reset the prefs back to their default status.
3. Restart Firefox.
That should clear Firefox from thinking there's an update. and stop the prompt
from appearing on startup.
Whiteboard: see comment 23 on how to stop being notified → see comment 46 on how to stop being notified

Comment 47

13 years ago
*** Bug 250701 has been marked as a duplicate of this bug. ***
*** Bug 250760 has been marked as a duplicate of this bug. ***

Comment 49

13 years ago
*** Bug 250650 has been marked as a duplicate of this bug. ***

Comment 50

13 years ago
*** Bug 251540 has been marked as a duplicate of this bug. ***

Comment 51

13 years ago
*** Bug 252108 has been marked as a duplicate of this bug. ***

Comment 52

13 years ago
*** Bug 252660 has been marked as a duplicate of this bug. ***

Comment 53

13 years ago
*** Bug 253824 has been marked as a duplicate of this bug. ***

Comment 54

13 years ago
*** Bug 258135 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

13 years ago
Component: Update → Web Site
Product: mozilla.org → Update
Version: other → unspecified
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.