Last Comment Bug 249883 - Do not open sidebar if panel content to fill it does not exist.
: Do not open sidebar if panel content to fill it does not exist.
Status: RESOLVED FIXED
[has patch, needs review (beng)] ETA:...
:
Product: Toolkit
Classification: Components
Component: Add-ons Manager (show other bugs)
: unspecified
: All All
-- minor with 12 votes (vote)
: ---
Assigned To: Ben Goodger (use ben at mozilla dot org for email)
: Ben Goodger (use ben at mozilla dot org for email)
: Andy McKay [:andym]
Mentors:
: 248152 278910 294809 303777 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-05 11:31 PDT by Asa Dotzler [:asa]
Modified: 2008-07-31 01:49 PDT (History)
25 users (show)
chofmann: blocking‑aviary1.0-
asa: blocking1.8b5+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Stops the sidebar from opening when the content does not exist (1.04 KB, patch)
2005-04-19 07:25 PDT, Teune van Steeg
no flags Details | Diff | Splinter Review
patch, based on twanno@lycos.nl's version. (2.06 KB, patch)
2005-08-02 11:09 PDT, Ben Goodger (use ben at mozilla dot org for email)
no flags Details | Diff | Splinter Review

Description User image Asa Dotzler [:asa] 2004-07-05 11:31:33 PDT
We have this issue (with this extension, at least) where if you have it active
(sidebar open) when you uninstall it, we don't clean up the localstore.rdf data
so a restart gives you an open and empty sidebar. This could potentially be a
more widespread problem. I think the uninstall routine needs to look at
localstore and remove any related items.

http://tkm.s31.xrea.com/xul/grepsidebar.shtml
Comment 1 User image Mike Shaver (:shaver -- probably not reading bugmail closely) 2004-07-05 11:32:52 PDT
Removing localstore contents will make upgrading from one version of an
extension to a later one a mite troublesome, if we aren't careful.  But who
isn't careful around here?
Comment 2 User image Asa Dotzler [:asa] 2004-08-31 13:31:33 PDT
*** Bug 248152 has been marked as a duplicate of this bug. ***
Comment 3 User image Benjamin Smedberg [:bsmedberg] 2004-08-31 14:04:43 PDT
There is no way to associate data in the localstore with any particular
extension. It might be possible to special-case a sidebar entry.
Comment 4 User image Kathleen Brade 2004-09-01 04:26:01 PDT
Maybe we shouldn't be cleaning up localstore.rdf directly (if it's too risky or
needs special casing).

Can the sidebar realize there isn't any content and close itself (or is that the
special casing bsmedberg plans)?

Could each extension have an "uninstall from app" function for this type of cleanup?
Comment 5 User image Nickolay_Ponomarev 2004-09-23 06:38:19 PDT
This also happens after installing a new Firefox release, which disables
non-compatible extensions automatically. (Reported recently as a QuickNote bug
<http://bugzilla.mozdev.org/show_bug.cgi?id=7371>).
Comment 6 User image Ben Goodger (use ben at mozilla dot org for email) 2004-09-25 06:44:49 PDT
It should be possible to strip entries from the localstore for a given package
as that package is uninstalled, no? (This would require direct tweaking of
localstore from EM uninstall logic... hardly ideal but ideally localstore/etc
would acquire some sort of useful API towards 2.0...)
Comment 7 User image chris hofmann 2004-09-30 16:48:44 PDT
ok, lets try and do this for 2.0 where there is more time for testing.
Comment 8 User image MW 2004-12-08 00:31:49 PST
sorry for bugspam

I hope this does not sound trite, but this bug can be worked around fairly
smoothly for extensions. Reinstall extension, Close Sidebar (or open a default
sidebar like bookmarks/history) and then Uninstall the extension. This method
won't solve the comment #5 issue though.

Deleting the localstore.rdf also works around the problem (obviously you will
loose button placement/window size and misc settings ect different from the
default FireFox setup).
Comment 9 User image Phil Ringnalda (:philor) 2005-01-18 17:49:04 PST
*** Bug 278910 has been marked as a duplicate of this bug. ***
Comment 10 User image baris 2005-04-18 14:46:45 PDT
Ping? 
Comment 11 User image Teune van Steeg 2005-04-19 07:25:39 PDT
Created attachment 181138 [details] [diff] [review]
Stops the sidebar from opening when the content does not exist

This patch prevents the sidebar from opening on browser startup when the
content is not present anymore (i.e. after uninstalling an extension). This as
an alternative to associate an extension with localstore data.

(I got the idea from the proposed patch for bug #285513)
Comment 12 User image Teune van Steeg 2005-04-19 07:47:25 PDT
Comment on attachment 181138 [details] [diff] [review]
Stops the sidebar from opening when the content does not exist

request review
Comment 13 User image Steve England [:stevee] 2005-05-19 15:11:48 PDT
*** Bug 294809 has been marked as a duplicate of this bug. ***
Comment 14 User image Mike Connor [:mconnor] 2005-07-12 22:21:16 PDT
I'm not sure about this fix given a cursory reading, but this isn't really a
blocker, unless you can't close the empty sidebar...
Comment 15 User image Asa Dotzler [:asa] 2005-07-12 22:27:19 PDT
(In reply to comment #14)
> I'm not sure about this fix given a cursory reading, but this isn't really a
> blocker, unless you can't close the empty sidebar...

you can't close the empty sidebar.

Comment 16 User image Kathleen Brade 2005-07-13 05:24:53 PDT
seeking blocking status since you can't close the sidebar
Comment 17 User image Benjamin Smedberg [:bsmedberg] 2005-07-13 05:28:05 PDT
Can we morph this bug, then, into making the sidebar sane, instead of "cleaning
up localstore" which is probably a cannon solution to a flyswatter problem.
Comment 18 User image Asa Dotzler [:asa] 2005-07-19 14:59:54 PDT
We need to see if this still impacts current and popular sidebar extensions. 
Comment 19 User image Tracy Walker [:tracy] 2005-07-20 06:22:23 PDT
Tested with EditCSS sidebar extension on Windows Deer Park build from 0719

-Open the EditCSS sidebar
-Unistall that extension
-Restart

The EditCSS extension still appears in the sidebar. As expected EditCSS does not
appear in the View | Sidebar menu. Clicking the [X] to close the sidebar doesn't
work. However, the workaround is to simply change the sidebar to Bookmarks or
History, then close and reopen the sidebar.
Comment 20 User image Tracy Walker [:tracy] 2005-07-20 08:25:21 PDT
Further testing shows that with every subsequent restart the sidebar opens with
blank content.  This happens no matter what state the sidebar was left in on app
exit.  This is bad and worth considering blocking 1.1
Comment 21 User image Asa Dotzler [:asa] 2005-07-20 19:14:07 PDT
Thanks, Tracy. This shows the same results I was seeing months ago. We do need
to fix this. Ben, can you review this patch?
Comment 22 User image Ben Goodger (use ben at mozilla dot org for email) 2005-08-02 11:09:33 PDT
Created attachment 191373 [details] [diff] [review]
patch, based on twanno@lycos.nl's version.
Comment 23 User image Ben Goodger (use ben at mozilla dot org for email) 2005-08-02 11:10:39 PDT
Landed. thanks for the patch!
Comment 24 User image Dave Townsend [:mossop] 2005-08-07 13:31:08 PDT
*** Bug 303777 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.