'View Background Image' in non-image context menu.

VERIFIED FIXED in Future

Status

SeaMonkey
General
P3
enhancement
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: Henrik Gemal, Assigned: gerv)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
Just like you have the "view image" it could be nice if there where also a 
"view background image" if a webpage/table has a background image.

Comment 1

19 years ago
IMHO, there are hundreds of contextual menu items that could each be convenient 
to a tiny fraction of users --- but if every one of them were added to an 
application, it would then be impossible to find the ones that most people do in 
fact need.

Can you think of any reasons why this particular one will be useful to a 
significant number of them?

---

Reassigning to German, who spec'd the context menu items.
Assignee: shuang → german

Updated

19 years ago
Severity: normal → enhancement
Summary: Ability to "view background image" → [enh]Ability to "view background image"
Target Milestone: M20

Comment 2

19 years ago
Have to agree with Eli here, I too am afraid of context menu overkill. How do you 
envision using this feature?

Updated

19 years ago
Summary: [enh]Ability to "view background image" → Ability to "view background image"

Comment 3

19 years ago
Moving all UE/UI bugs to new component: User Interface: Design Feedback
UE/UI component will be deleted.
Component: UE/UI → User Interface: Design Feedback

Comment 4

18 years ago
Mainly I use View Image to see the file name of the image (in NC 4.x it appears 
in the context menu). It would be nice to have this same functionality for 
background images. No need to add another item to the context menu, just make 
View Image load the background image if the mouse is over a background image.

Comment 5

18 years ago
QA Assigning non-confidential New/Assigned User Interface: Design Feedback bugs 
to Matthew Thomas (mpt@mailandnews.com).

Matthew Thomas is now the QA owner for the User Interface: Design Feedback 
component. (Bugs that involve UI issues in the Netscape-branded Mozilla browser 
should continue be QA assigned to elig@netscape.com.)
QA Contact: elig → mpt

Comment 6

18 years ago
This wouldn't really be context menu overkill, because (a) it would only appear 
in the context menu for the empty part of a page (and that menu isn't very large 
already), and (b) there would be no other way to get to this command (short of an 
intrepid excursion into the Page Info window).

You wouldn't need the whole suite of image context menu commands, just `View 
Image' -- the rest of the image-related items would then be in the context menu 
for the image when it was loaded in the window by itself.

Comment 7

18 years ago
Yse agreed: it is an overkill. Set resolution to WON'TFIX for this version.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX

Comment 8

18 years ago
Reopening and setting to Future. I don't think it's acceptable to require the 
user to hunt through Page Info just to be able to open the background image.

I've seen other browsers with this menu item; and if we're not going to have `Set 
as Wallpaper' like previous versions of Mozilla did, I think having `View 
Background Image' instead is quite reasonable.
Status: RESOLVED → REOPENED
OS: Windows 98 → All
Hardware: PC → All
Resolution: WONTFIX → ---
Target Milestone: M20 → Future

Comment 9

18 years ago
I do not have any major objections against adding it, its just one more thing 
that I would rate low in terms of usefulness for the average Netscape audience, 
compared to other things that need fixing...

Comment 10

18 years ago
I think 'View background image' is not something that the average Netscape
audience would worry about whether it was in the context menu. IMO, This feature
is only reasonably interesting for a web-design audience, or for those more than
causal web user.
I propose reassigning this bug to ben, the mozilla UI owner, so he can add this
to his 'ongoing discussions bin'
Assignee: german → ben
Status: REOPENED → NEW

Comment 11

18 years ago
Actually `Save Background' is in Netscape's own context menu spec
<http://bugzilla.mozilla.org/showattachment.cgi?attach_id=18576>. Replacing that 
with `View Background Image' would allow users to view the background unobscured, 
and then save it using `File'>`Save', and print it using `File'>`Print', etc etc. 
If there is only one background-image-related command in the context menu, this 
should be it, because it provides indirect access to all the others.

Comment 12

18 years ago
It would also be neat if "[Load/Show] Background Image" were shown for 
background images that haven't been loaded.  See also bug 35130 for that.
Summary: Ability to "view background image" → 'Save Background As...' in non-image context menu.
Maybe this and other more obscure links could be traversed through Page Info or
some similar metadata viewer?  Can you do that currently?

Comment 15

18 years ago
I disagree with the `updating' of the summary from having `View Background Image' 
to `Save Background As ...'.

If you have `Save Background As ...', you can not print the background, copy the 
image to the clipboard, copy the image URL, add a bookmark for the image, print 
the image, e-mail it to someone, etc.

If you have `View Background Image' instead, you can do all of those things once 
you have the image open by itself in the window, *and* you are still be able to 
save it by choosing `File' > `Save' (or `Save Image' in the context menu for the 
image itself).

Comment 16

18 years ago
See also bug 40230.

Comment 17

17 years ago
Chaning the qa contact on these bugs to me. MPT will be moving to the 
owner of this component shortly. I would like to thank him for all his hard 
work as he moves roles in mozilla.org...Yada, Yada, Yada...
QA Contact: mpt → zach
Assignee: ben → gervase.markham
OK, I have a working implementation of this. Taking bug from Ben :-)

I have replaced the (un-hooked-up) Save Background As... code with View 
Background Image, to appear instead of View Image in appropriate 
circumstances. This currently uses the View Image handling code, and so opens in 
a new window.

Questions:
- Should this menu item only appear if you click "directly" on the background 
(for some value of directly)? Currently it appears whenever there's a background 
image, and you haven't directly clicked on another image. Is this the right 
behaviour?

- Are there any instances where the value of "background" will not be an image?

Gerv

Comment 19

17 years ago
i had two good testcases for this stuff... one was nsa and one was my high 
school.  i still believe the only good solution is abandoning our flat menu. 
i'll find the testcases and probably post some browser comparisons eventually 
(or sooner if someone reminds me later)
timeless: Was that comment meant for this bug? I don't understand...

Gerv
I'm going to wait until my other context menu patch is checked in before 
sorting this one, so I don't have to keep disentangling the two :-)

Resummarising to reflect the actual implementation.

Gerv
Summary: 'Save Background As...' in non-image context menu. → 'View Background Image' in non-image context menu.
*** Bug 40230 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Depends on: 75338
I lost the old code, so I had to rewrite it, and am attaching the patch for
safekeeping. I'm looking for r=, but may not be actively chasing it for a while.
Still, if someone wants to, that would be great :-)

Gerv

Comment 26

17 years ago
r=timeless
Keywords: approval, patch
sr=blizzard by email; checked in by bbaetz. 

Gerv
Status: NEW → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 29

17 years ago
yeps.. verified in build 20010626
Status: RESOLVED → VERIFIED

Comment 30

16 years ago
*** Bug 125218 has been marked as a duplicate of this bug. ***

Comment 31

16 years ago
I have no problem with the 'View Background Image' solution. Only in my version
(Build ID 2002020406) it doesn't open in a new window.
This way I have to go back and it has to render the possibly complex page again.

Updated

16 years ago
Component: User Interface Design → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.