Installer chokes on Talkback : -214 DOES_NOT_EXIST

VERIFIED FIXED

Status

()

Firefox
Installer
P1
blocker
VERIFIED FIXED
14 years ago
12 years ago

People

(Reporter: Jean-Marc, Assigned: Chase Phillips)

Tracking

({smoketest})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Notification bug only. No code fixes will be made here.)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040710 Firefox/0.9.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040710 Firefox/0.9.0+

Talkback seems to be missing.
At installation, when the component is selected there's a message box that says :
+----------------------------------+
|Error                             |
+----------------------------------+
|Error occured during installation |
|- Quality Feedback Agent:         |
|-214 DOES_NOT_EXIST               |
|              [OK]                |
+----------------------------------+
(I like ASCII art :-) )
And then the installer hangs (gentle hang).

Reproducible: Always
Steps to Reproduce:
1. Install the nightly latest-0.9 of July 10th
2. Be sure to select Talkback in the components.
3. Proceed and wait.

Actual Results:  
An error message appears.

Expected Results:  
Finish the installation and ask me whether to start Firefox right away.

I had no profile at all before starting, but I doubt that this is relevant.
If you don't select Talkback, everything runs fine (at first glance at least).
(Reporter)

Comment 1

14 years ago
Created attachment 152805 [details]
The error message box in question

Comment 2

14 years ago
This bug is present in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040710 Firefox/0.9.0+

It was not rpesent in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040709 Firefox/0.9.0+

Installation process does not register Firefox with Windows (XP Home) and
consequently Firefox cannot be uninstalled from the Control Panel.

Comment 3

14 years ago
I can confirm this

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040710
Firefox/0.9.0+

The actual installation works properly, as in you can use the browser, but I
have to crash the installer using task manager to get rid of it.

Comment 4

14 years ago
I observed the same problem installing this build on Win2K.   Program not listed
for uninstallation either.  My installation followed an uninstall of the
20040709 build.  All installs used default settings.  

Firefox 1.0 cannot be released with this kind of error in the installer so I've
set the question mark in the blocking-avaiary 1.0 flag.

Flags: blocking-aviary1.0?

Comment 5

14 years ago
I see this problem with both the 7/10 and 7/11 builds using the installer
(obviously) Win32, under XP, even with a completely clean install. This isn't
proper as I had to remove the failed install, but everything except the version
should be accurate: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040707 Firefox/0.9.2 

Note sure what rights I have... but I say this should be Severity "BLOCKER" as
the install completely fails...  not even listed in Add/Remove and you have to
kill the install manually. I'd also mark it CONFIRMED, but not sure if I have
those rights or not.

Comment 6

14 years ago
Seeing this here as well. Browser still works, but I have to kill the installer.

Comment 7

14 years ago
Confirm this too...

20040711 branch build...

I reckon it's more a freeze than a hang
Flags: blocking-aviary1.0RC1?

Comment 8

14 years ago
leaf: Shouldn't have been a dummy XPI included here if the TB server is down
(which seemed to be the case here)?
If you just quit the installer, at this dialog, you can still use the install
provided.

So it doesn't render the builds useless... just make the installer oddly broken.
Re comment #9.  The last step of the install will not be performed (updating the
windows registry entries) if you exit at this point.

The correct work-around is to do a custom install and uncheck the Quality
Feedback agent check-box.
re comment #8.

Or the option to install talkback should be deselcted and not selectable if
talkback.xpi is not present in the install package.

Comment 12

14 years ago
*** Bug 251044 has been marked as a duplicate of this bug. ***

Comment 13

14 years ago
This is definitely a blocker, but i bet the problem is talkback not getting
produced, so i'm investigating that.
Flags: blocking-aviary1.0RC1?
Flags: blocking-aviary1.0RC1+
Flags: blocking-aviary1.0?
Flags: blocking-aviary1.0+

Comment 14

14 years ago
WFM with last night's build.

Comment 15

14 years ago
(In reply to comment #14)
> WFM with last night's build.

Confirmed: Appears to be fixed with last night's build (Mozilla/5.0 (Windows; U;
Windows NT 5.1; en-US; rv:1.7) Gecko/20040712 Firefox/0.9.1+).
Although it works with current builds, I am not sure this can be closed.  My
guess is that the issue with the talkbalk server has been corrected.

Still outstanding is the issue that builds created when the talkback server is
unavailable are not installable.

Comment 17

14 years ago
I don't understand why this would rely on the talkback server being up.  Is the
source code and/or binaries stored there and copied over?

Comment 18

14 years ago
AIUI, the talkback server has to know stuff about the build for talkback to
work. if it's not up at build time, then the necessary information can't go onto
the server and that results in talkback not getting packaged with the build.

However, the lack of a complete talkback shouldn't kill the build process or the
installer. In some product/platform/code branch combinations, that's been fixed,
but not all of them.

Comment 19

14 years ago
This bug seems to be fixed for 7/14 build.
i guess we can resolve this then...
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
yep, I couldn't repro this issue when running the installer for
2004-07-21-09-0.9 bits on WinXP (including talkback). marking vrfy'd.
Status: RESOLVED → VERIFIED
This is now maked as resolved and verified, but presumably that is only becuse
the talkback server has been behaving.  Presumably the underlying issue that
Firefox build created when the talkback server is down will not install still
exists.
Should a seperate bug be opened on this issue, or should this bug be reopened
until that is fixed as well?
I hate to say I told you so, but this is NOT fixed.  The 20040802 branch nightly
will not install and gets exactly the same error.  The problem is that builds
created when the talkback server is down will not install unless you do a custom
install and unselect installing the Quality Feedback agent.
We already know what the problem is...
leaf: Have you some time to look into the Firefox tinderbox which produces the 
build and make it generate a "fake" package when the Talkback server is down?

Comment 25

14 years ago
to whatever extent this is "fixed", it's fixed on the branch
Keywords: fixed-aviary1.0

Comment 26

14 years ago
FWIW, I see this error in 2004-09-01 builds for Firefox 0.9 and Thunderbird 0.8
on Windows.

Comment 27

14 years ago
reopening.

It would be nice to fix this so that the builds don't die completely each time
the talkback server has problems...
Status: VERIFIED → REOPENED
Keywords: fixed-aviary1.0
Resolution: FIXED → ---
Flags: blocking-aviary1.0PR+ → blocking-aviary1.0PR-
The error message has returned in the 20040906 builds of both Firefox and
Thunderbird.

There definitely needs to be some sort of workaround, like the already suggested
dummy XPI, for when Talkback can't be generated...
This is not a blocker since it doesn't occur with properly configured release
builds. 
Flags: blocking-aviary1.0+ → blocking-aviary1.0-

Comment 30

14 years ago
(In reply to comment #29)
> This is not a blocker since it doesn't occur with properly configured release
> builds. 

It 's back in this todays build:
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.3) Gecko/20040926 Firefox/0.10

Comment 31

14 years ago
*** Bug 258625 has been marked as a duplicate of this bug. ***

Comment 32

14 years ago
(In reply to comment #30)
> (In reply to comment #29)
> > This is not a blocker since it doesn't occur with properly configured release
> > builds. 
> 
> It 's back in this todays build:
> Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.3) Gecko/20040926 Firefox/0.10

In this light, it SHOULD be back to blocking.

Comment 33

14 years ago
"In this light, it SHOULD be back to blocking"

No it should, for the reasons already given. This is only ever going to affect
nightly builds which are generated automatically - for a release build they will
make sure that it works. Therefore, it's not a release blocker - it's just
annoying for people using nightly builds.

Comment 34

14 years ago
Add "hang" keyword?

Comment 35

14 years ago
(In reply to comment #34)
> Add "hang" keyword?

No, this isn't a hang.

Comment 36

14 years ago
Well, since there isn't a "choke" keyword, I figured "hang" would do, since that
is the closest way to describe the outcome.

;-(

Updated

14 years ago
Depends on: 258625
Let's clear this up.  Bug 258625 covers handling talkback server failures.
We get this bug because we don't handle talkback server failures gracefully.

When this bug occurs it should be Severity=Blocker for that build, because we
want talkback enabled builds for testing purposes. It's important to get
talkback into the next builds for maximum crash data collecting.

This bug will never be blocking-aviary1.0, because that, and any release build,
will be tested and ensured that talkback is available.

Normally this type of bug would be closed for each occurance.  But since this
has been happening frequently lately, perhaps leaving it open and simply raising
and lowering severity until bug 258625 is fixed will suffice.  

When 258625 is fixed, we'll still need to files a bug when talkback fails to
install.

note: Isn't this a hang?  The unistall module isn't added to Windows control
panel, because this happens after talkback and we don't get passed talkback to
get to it.

Comment 38

14 years ago
Technically, I don't think this is a hang. The installer fails to get to the
next step and do what it is supposed to do, but it isn't frozen - it doesn't use
any significant amount of CPU time and it still responds to clicking the close
button.

If I'm understanding correctly, bug 240234 dealt with the issue (now bug 258625)
previously on the build machines - if anyone knows exactly what that fix was,
then I guess it could be applied to the tinderbox machines that don't have it...

Updated

14 years ago
Blocks: 262161

Updated

14 years ago
No longer blocks: 262161
Okay, here we go.  Today's installer, build 2004-10-15-06-0.9, exhibits this
bug. I suppose it's not even worth upgrading the severity, since we know what's
happening and it will most likely be fixed for the next round of builds. Plus,
this probably won't hold the tree closed.

Comment 40

14 years ago
I, too, got bitten by this today.  I thought we had a solution.

Comment 41

14 years ago
Today's build (2004-10-21-07-0.9) has the bug.

Comment 42

14 years ago
regression keyword?
This is in todays release candidates.  Can't ship that way.  Upgrading it to a
smoketest blocker
Severity: major → blocker
Keywords: smoketest

Comment 44

14 years ago
taking.
Assignee: bugs → granrosebugs
Status: REOPENED → NEW
Priority: -- → P1

Comment 45

14 years ago
mac is ok, win32 is broken - rebuilding with --build-once, linux is still building.
Status: NEW → ASSIGNED

Comment 46

14 years ago
linux built successfully.  l10n builds still building.
windows build from 2004-10-26-11-0.11 looks good.
Severity: blocker → critical
Keywords: smoketest

Comment 48

14 years ago
Still getting the error in question.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041028
Firefox/1.0RC1

At the very least, a dummy package should be included if the Talkback server is
down. Even if this won't be an issue for release builds, it's still mighty
annoying to us testers in the trenches.
Please see bug 258625.  
We're only using this bug as a notification to the build and talkback teams. 
When the bug appears in a nightly we make it a smoketest blocker until it is
once again resolved. (the TB servers are back up)
Whiteboard: Notification bug only. No code fixes will be made here.

Comment 50

14 years ago
needs aviary landing keyword?
(In reply to comment #50)
> needs aviary landing keyword?

No, this has nothing to do with aviary-landing.

Updated

14 years ago
Flags: blocking-aviary1.1?

Comment 52

14 years ago
See Comment #37
Flags: blocking-aviary1.1?
worcester12345, please see comments #37, #49 and the Status Whiteboard. This bug
is for notification only. Bug 258625 was the proper bug to request
blocking-aviary1.1, which you did, thanks.

heh, collided with Robert Parenton.

Comment 54

14 years ago
blocking "-" missing?

Updated

14 years ago
Flags: blocking-aviary1.1-
*** Bug 275305 has been marked as a duplicate of this bug. ***
Installation of Talkback for Fx build 2005-03-17-06-aviary1.0.1 1.0.2 failed
with the -214 DOES_NOT_EXIST error.

This build can not be our 1.0.2 RC without talkback. We need a respin. When a
new build is available with TB, I'll lower the severity of this bug again.

note: Talkback was present in Mac and Linux Fx builds from this a.m.
Severity: critical → blocker
Keywords: smoketest
also happening on Thunderbird 1.0.2  windows build from this morning.

Updated

14 years ago
Flags: blocking-aviary1.1-
Flags: blocking-aviary1.0PR-
Flags: blocking-aviary1.0.2+
Flags: blocking-aviary1.0-

Updated

14 years ago
Assignee: granrosebugs → chase
Status: ASSIGNED → NEW
Fx and Tbird respins from 2005031711 have talkback
Severity: blocker → normal
Keywords: smoketest
Windows Fx trunk build 2005-04-21-07-trunk i smissing talkback due to this.

sidenotes for Jay: Talkback server seems slow this morning.  Fastfind is broken.
Severity: normal → blocker
Keywords: smoketest

Comment 61

13 years ago
Tracy: Talkback db issues have slowed down the query tools, but they are working
fine now.  Also, the server went down yesterday, so that might explain why this
mornings builds did not have Talkback.  Hopefully newer builds are ok.

Comment 62

13 years ago
I'm seeing this bug as well with the Firefox 1.0+ build dated 4-21-05

Talkback is present in Fx trunk build 2005-04-22-07-trunk
Severity: blocker → normal
Keywords: smoketest
talkback failed to install with this bug on Windows Fx trunk build
2005-04-28-07-trunk

note: Windows Thunderbird trunk build today is missing master.ini
Severity: normal → blocker
Keywords: smoketest
talkback has returned in builds for 0429
Severity: blocker → normal
Keywords: smoketest
*** Bug 292349 has been marked as a duplicate of this bug. ***
*** Bug 291489 has been marked as a duplicate of this bug. ***
(In reply to comment #65)
> talkback has returned in builds for 0429

the error is present on build "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.7.8) Gecko/20050430 Firefox/1.0.4" which I installed a few minutes ago.
(In reply to comment #23)
> I hate to say I told you so, but this is NOT fixed.  The 20040802 branch nightly
> will not install and gets exactly the same error.  The problem is that builds
> created when the talkback server is down will not install unless you do a custom
> install and unselect installing the Quality Feedback agent.

AFAICT, when installing over a previous nightly which has the QFA installed, it
is not possible to deselect the QFA install (it is checked and greyed out). In
that case, the installer still chokes, and (again, AFAICT) the QFA (the older
one, presumably) remains functional.


Best regards,
Tony.
the error is present in "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.7.8) Gecko/20050501 Firefox/1.0.4" but not in the parallel build "Mozilla
Thunderbird version 1.0.4 (20050501)"
Both Firefox and Thunderbird aviaries for May 2 are exempt from the error. As
has been said previously, this does not necessarily mean that the bug is fixed.
They may just have been built at a favourable time.
The bug is indeed not fixed. Current (post-release) nightlies of Fx 1.0.4 seem
exempt from it (touch wood), but Thunderbird version 1.0.4 (20050515) has it.
(Note: According to Tinderbox
http://tinderbox.mozilla.org/sb.cgi?tree=Aviary-1.0.1 that's an isolated
"successful" build after a long series of "busted" ones.)
talkback failed to install with this bug on Windows Fx trunk build
2005-05-16-07-trunk

tony: please see comment #37 and comment #49
Severity: normal → blocker
Keywords: smoketest
check that, I saw this error for the website reporter, not talkback.  Talkback
installed fine.
Severity: blocker → normal
Keywords: smoketest
(In reply to comment #73)
> talkback failed to install with this bug on Windows Fx trunk build
> 2005-05-16-07-trunk
> 
> tony: please see comment #37 and comment #49

OK; Except I have no privileges on this bug. In particular, Bugzilla won't let
me change its severity.

Today's Fx-aviary build did not suffer from the bug; TB-aviary building machine
"patrocles" was "up in fire" ("busting" one build after another) for most of the
weekend, and the build finally succeeded at an unusual time of day (19:20 Sunday
according to Tinderbox), which may explain that its build was "bugged".

There was a new TB-aviary build (20050516) two and a half hours ago (06:53
according to Tinderbox) and it did not suffer from the bug.

Note: "+blocking-aviary1.0.2" is somewhat ridiculous now that Fx/TB aviaries
1.0.4 are out and there is no permanent fix in sight.


Best regards,
Tony.
"Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050518
Firefox/1.0.4" has the bug; Thunderbird version 1.0.4 (20050518), built about
two hours earlier, hadn't got it.

Could someone please raise this bug's severity? I don't have that privilege.


Best regards,
Tony.
yes, and the Mac trunk Fx build 2005-05-18-07-trunk is missing Talkback (no error, but no installer).
Severity: normal → blocker
Keywords: smoketest
sorry, tony, Talkback is present in my windows install of build
2005-05-18-07-trunk.  
Severity: blocker → normal
Flags: blocking-aviary1.0.2+
Keywords: smoketest
(In reply to comment #78)
> sorry, tony, Talkback is present in my windows install of build
> 2005-05-18-07-trunk.  

Well, it is absent from my Windows install of 2005-05-18-07-aviary1.0.1, built
approx. 20 minutes earlier on a different machine.

Couldn't we leave the smoketest-blocker indicator on as long as one of the day's
builds has the bug?


Best regards,
Tony.

Comment 80

13 years ago
Tony:  There is no point in marking this a smoketest blocker, since it is an
ongoing problem that we have been dealing with for years.  We were able to
prevent this error in the past, see
https://bugzilla.mozilla.org/show_bug.cgi?id=240234#c10

There is a similar fix for Firefox/Thunderbird (bug 258625), but we are working
on a better solution.  Until that is done, we will continue to get builds that
are missing Talkback because of the flaky Talkback servers.  The build
automation currently needs to contact the Talkback server in order to
successfully package Talkback, and it often runs into network issues or DB
connection problems due to bugs in the Talkback software (which we do not have
source code for, and therefore can't do much about).  So, this bug is simply a
notification bug (see the whiteboard) to keep track of when things break. 
Unless we see a problem with Talkback missing for more than 2-3 consecutive
days, we are not going to worry about it.

I know it is an inconvenience, but we are trying our best to resolve this issue
with a workaround/fix that will free the build systems from their dependency on
the Talkback servers.  Feel free to email me if you have any questions.
Severity: normal → blocker
Status: NEW → ASSIGNED
20050519: Neither of the Fx and TB W32 aviary builds has the bug today.
Info on trunk builds, anyone?

Comment 82

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050519
Firefox/1.0+ ID:2005051917

I am still having this on the hourly tinderbox builds.

I'm not even sure why the talkback is not included in the installer while it is
in the zip builds ?!

Comment 83

13 years ago
TB version 1.0.4 (20050521) for Win32 has this problem
Latest and crucial blocker for 1.1a as seen on Windows and Mac builds from
2005-05-24 A.M. nightlies.  With Jay out of connection for the week, we need
Chase to investigate or not why talkback servers were down during those builds.

anyway, upgrading until a talkback enabled 1.1a build is created.
Keywords: smoketest
this is back on Windows build 2005-06-02-06-trunk. It was also on Thunderbird in
yesterdays build.
(Assignee)

Comment 86

13 years ago
Yesterday I added Shiva's cmanifest.pl script to the Talkback module and
modified it and our build system to work in harmony.  This cmanifest.pl script
replaces the older fcsutil.pl script and, where fcsutil.pl required
communicating with the Talkback servers to get a copy of master.ini,
cmanifest.pl creates the master.ini without any interaction with those servers.
 Jay verified that today's builds on the trunk have the Talkback client and that
stack traces make sense -- which means things have not regressed with the new
change.

Today I migrated the necessary changes from the trunk to the 1.0, 1.0.1, and 1.7
branches.  We'll be able to verify given time but I'm willing to bet dollars to
donuts we won't see the Talkback missing installer error for a while.

-> Fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago13 years ago
Resolution: --- → FIXED
excellent
Status: RESOLVED → VERIFIED

Updated

12 years ago
QA Contact: bugzilla → installer
You need to log in before you can comment on or make changes to this bug.