Closed Bug 250922 Opened 16 years ago Closed 15 years ago

found links aren't focused

Categories

(Toolkit :: Find Toolbar, defect, P2)

defect

Tracking

()

RESOLVED INVALID

People

(Reporter: bugs, Assigned: bugzilla)

References

Details

Steps to reproduce
1) visit a page with links 
2) Ctrl+F or / to invoke Find Toolbar
3) type text in a link, text in the link is selected
4) press "Enter"

Expected Results:
- Navigate to link

Actual Results:
- Nothing happens. Need to press tab to shift focus to next link, then shift tab
to shift it back.
Flags: blocking-aviary1.0RC1+
Priority: -- → P2
Target Milestone: --- → Firefox1.0beta
see also bug 250272, bug 250274.
QA Contact: bugzilla
The other thing is that people are used to hitting Enter at the end of a Ctrl+F
search.

Muscle memory wise this is a problem and people might not notice the behavior is
now different.

So you type Ctrl+F bug Enter like you used to, and you've missed the first match.
Fixed on branch.

Don't need to leave open for trunk since I have bug 250231 and all these fixes
will land as part of that.
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
This appears to fix Bug 250483 too.
A text find using the Find Toolbar (invoked through Ctrl+F) doesn't focus links
for me. A text find using Find As You Type or '/' does focus links. Is this
behavior intentional? Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040804 Firefox/0.9.1+
right, ctrl-f (ctrl-g also) puts focus with a text cursor into the find bar
textfield, and keeps it there, which sort of makes sense since it'll behave more
like a find dialog with the old find dialog shortcut..
hmh. reopening for a look since it doesn't do what comment 0 specifies, and
comment 2 still applies.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
the original test case worksforme 08/06... please file new bugs on other problems. 
Status: REOPENED → RESOLVED
Closed: 16 years ago16 years ago
Flags: blocking-aviary1.0PR+ → blocking-aviary1.0PR-
Resolution: --- → FIXED
Reopening.  The original test case does not work using 08/23 branch build. 
Enter triggers Find Again but does not navigate the link.  To reproduce, search
for "Show" on this page.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
*** Bug 256304 has been marked as a duplicate of this bug. ***
Is this bug not considered a blocker for 1.0?
I have this problem mostly with pages using frames and using autostart type ahead.

The last update of this bug where a long time ago, do someone have a fix for this?
Flags: blocking-aviary1.1?
-> WFM

Currently, the found link doesn't have a focus. But it has pseudo-focus always.
While FAYT, find toolbar's enter key event fires found link's enter key event.
See bug 259454.
Status: REOPENED → RESOLVED
Closed: 16 years ago15 years ago
Flags: blocking-aviary1.1?
Resolution: --- → WORKSFORME
Target Milestone: Firefox1.0beta → ---
I still see this bug using the steps in comment 0.

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050707
Firefox/1.0+
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
I run into this bug on a daily basis.
1. go to http://www.eclipse.org
2. after loaded find downloads (/downloads)
3. downloads link is highlighted by pressing enter does not navigate
If you are testing with Ctrl + F, it is invalid.
Ctrl + F is not found the link that is designed so.

If you think that Ctrl + F should be, it is not bug. It is not bug.
So it is not this bug (this bug is not 'enhancement', it is 'normal').

Currently design, FastFind find the link and you can naviate the link that is
only in FAYT mode, not in Normal Find mode.
O.K. I misread comment 0.

Comment 0 said:
> 2) Ctrl+F or / to invoke Find Toolbar

Currently design, the link is found when starting with "'" only.
It is design. Not a bug.

-> INVA
Status: REOPENED → RESOLVED
Closed: 15 years ago15 years ago
Resolution: --- → INVALID
I disagree.

1. Navigate to http://www.eclipse.org
2. type "'" to start finding links
3. enter "downloads"
4. the downloads link is highlighted
5. press enter to follow the link
6. nothing happens.

While the link is highlighted, it isn't focused and can't be navigated to with
the keyboard.
Travis:

It is a FAYT's bug in frame. It is not this bug.
Please file a new bug.
*** Bug 250272 has been marked as a duplicate of this bug. ***
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.