Compose Window: Disable unused menu items for B1

VERIFIED FIXED in M14

Status

MailNews Core
Composition
P3
normal
VERIFIED FIXED
18 years ago
9 years ago

People

(Reporter: Phil Peterson, Assigned: Charles Manske)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+]date depends on 27947)

(Reporter)

Description

18 years ago
Our decision is to disable unused menu items (rather than remove them) and
precede each un-enable-able item with a '.'
(Reporter)

Updated

18 years ago
Keywords: beta1
Target Milestone: M14

Updated

18 years ago
QA Contact: lchiang → nbaca

Comment 1

18 years ago
Putting on PDT+ radar for beta1.
Whiteboard: [PDT+]
accepting
Status: NEW → ASSIGNED
done
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 4

18 years ago
Build 2000-02-07-08M14: NT4, Linux 6.0, Mac 8.5.1

1. The following items appear enabled yet they do nothing. Please gray them out:
- Insert|.Line Break
- Insert|.Break Below Image(s)

2. The following items are not working. They should have a dot and be grayed 
out:
- Format|Paragraph|Paragraph (bug# 26999)
- Format|Apply Style Sheet and all its submenus (bug# 11359)
- Format|Properties (bug# 14344)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
cc cmanske who owns those two menus.
Status: REOPENED → ASSIGNED
Whiteboard: [PDT+] → [PDT+] 2/15/00
(Assignee)

Comment 6

18 years ago
I'll take care of these since all are in the overlay files that I manage.
All are fixed and waiting for an open tree to checkin.
Format Properties will work correctly, others will be disabled.
Assignee: ducarroz → cmanske
Status: ASSIGNED → NEW
(Assignee)

Comment 7

18 years ago
Checked in 2/9
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 8

18 years ago
Mozilla Build 2000-02-16-09M14: NT4
Commercial Build 2000-02-16-08M14: Linux 6.0
Commercial Build 2000-02-16-09M14: Mac 8.5.1

Items that are now OK:
1. Insert menu
- Line Break, disabled.
- Break Below Images, disabled.

2. Format
- Paragraph|Paragraph, disabled.
- Apply Style Sheet and all submenu items are gone. This is ok for beta1 even 
though it doesn't match Editor.

This is the last item that needs to be fixed:
- Format|Properties, still displays and does nothing. I logged a bug since this 
menu item is suppose to change and work (bug# 28115). Making this bug dependant 
on 28115.
Status: RESOLVED → REOPENED
Depends on: 28115
Resolution: FIXED → ---
(Assignee)

Comment 9

18 years ago
If we have a specific bug for the "Properties..." item, and this already has
PDT+ approval, why don't we just dup 28115 to this bug to avoid PDT cycle 
again? Just copy my last comment in 28115 to this bug for detailed 
explanation.
(Assignee)

Comment 10

18 years ago
*** Bug 28115 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

18 years ago
Status: REOPENED → ASSIGNED
(Assignee)

Comment 11

18 years ago

*** This bug has been marked as a duplicate of 28149 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE

Comment 12

18 years ago
reopening bug; this is not a duplicate of bug #28149 (#28149 is a Composer 
specific issue and unrelated to mail compose).
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 13

18 years ago
Fix is ready.
(Assignee)

Comment 14

18 years ago
fix is ready
(Assignee)

Comment 15

18 years ago
Checked in 2/17. Sorry for extra comments -- bugzilla was real slow updating
the database recently.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 16

18 years ago
Build 2000-02-22-16M14: NT4
Build 2000-02-22-12M14: Linux 6.0
Build 2000-02-22-11M14: Mac 8.5.1
Reopening

On Windows and Linux the "Properties" item works as expected. It is available, 
depending on the type of item highlighted, which is good.

On the Mac Format|Properties is always available when, depending on the item 
highlighted, it should not appear or be disabled. For instance:

a. Insert|Anchor, highlight the anchor, Format|Properties and nothing happens.
b. Insert|Table, highlight the table, Format|Properties and nothing happens.
c. Insert|HTML Source, highlight the text displayed, Format|Properties, and 
nothing happens.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

18 years ago
Depends on: 29078
(Assignee)

Comment 17

18 years ago
This is fixed, but is now blocked by 29078 because the "oncreate" method is
not being called on Mac only.
Status: REOPENED → ASSIGNED
Whiteboard: [PDT+] 2/15/00 → [PDT+]

Comment 18

18 years ago
remove 2/15/2000 date from status whiteboard nbaca--is the format menu item the only problematic item on Mac or are other items also having problems? Perhaps a new mac-specific bug would be a better place for this new bug rather than the current bug? I see the current bug in Composer which isn't Mail/News specific so I really think this bug should be resolved fixed and a new bug should be filed.
No longer depends on: 29078

Comment 19

18 years ago
I just collided with Charley's comments...

based on what Charley just said, I recommend we resolve this bug as fixed again
and nbaca verify after 29078 is marked fixed.
(Assignee)

Comment 20

18 years ago
Let's keep it open at least until 28115 is PDT+ approved.
If we mark this fixed, it will appear crossed out as the "... blocks" item
for 28115.

Comment 21

18 years ago
Marking this bug depended on bug# 29078. When 29078 is fixed then I will be 
prompted to check this bug.
Depends on: 29078
(Assignee)

Updated

18 years ago
Depends on: 27947
(Assignee)

Updated

18 years ago
Whiteboard: [PDT+] → [PDT+]date depends on 27947
(Assignee)

Comment 22

18 years ago
Bug 27947 is now fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 23

18 years ago
Build 2000-02-29-08M15: Mac 8.5.1
Verified Fixed since most of the menu items that should be disabled are 
disabled.

The problem remains on the Mac with the Format|Properties menu.
I will log a seperate bug with the Composer/Editor on this issue.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.