HTML charts don't validate

RESOLVED FIXED in Bugzilla 3.0

Status

()

defect
--
trivial
RESOLVED FIXED
15 years ago
12 years ago

People

(Reporter: bugreport, Assigned: spam)

Tracking

2.18
Bugzilla 3.0
Bug Flags:
approval +

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

15 years ago
# Line 128, character 46:

... ref="buglist.cgi?action=wrap&bug_file_loc_type=allwordssubst ...
                                 ^

Error: unknown entity bug_file_loc_type

The urls in the table cells should be passed through a filter to conver & to &


Also, there are several <strong> tags that never close.

Updated

15 years ago
Summary: html charts dont validate → HTML charts don't validate

Updated

15 years ago
Blocks: 47251

Comment 1

14 years ago
Could you point out, either by example or directly in the code where there is a
problem? I am not able to reproduce the described problem.
(Reporter)

Comment 2

14 years ago
Try just about any 2-dimensional HTML report.  Note that you have to log in
first, so you must Validate LOCAL html (upload a file).  If you attempt to just
paste a URL into the validator, you will find out that the login challenge page
validates.

Updated

13 years ago
QA Contact: mattyt-bugzilla → default-qa
Posted patch patch for tip (obsolete) — Splinter Review
Attachment #233568 - Flags: review?
sorry for bugspam :-(
needs to remove buglistbase from filterexceptions.
Attachment #233568 - Attachment is obsolete: true
Attachment #233579 - Flags: review?
Attachment #233568 - Flags: review?
Comment on attachment 233579 [details] [diff] [review]
patch for tip v2

r=gerv.

Gerv
Attachment #233579 - Flags: review? → review+

Updated

13 years ago
Assignee: gerv → bmo
Flags: approval?
Target Milestone: --- → Bugzilla 3.0
Flags: approval? → approval+

Comment 6

13 years ago
Checking in template/en/default/filterexceptions.pl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/filterexceptions.pl,v  <--  filterexceptions.pl
new revision: 1.76; previous revision: 1.75
done
Checking in template/en/default/reports/report-table.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/reports/report-table.html.tmpl,v  <--  report-table.html.tmpl
new revision: 1.13; previous revision: 1.12
done
Checking in template/en/default/reports/report.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/reports/report.html.tmpl,v  <--  report.html.tmpl
new revision: 1.11; previous revision: 1.10
done
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 7

13 years ago
*** Bug 310752 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.