If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Non-working "Use Global Inbox" option is shown during Movemail account creation

RESOLVED FIXED

Status

SeaMonkey
MailNews: Account Configuration
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: Stefan Borggraefe, Assigned: Bienvenu)

Tracking

({fixed-aviary1.0})

Trunk
x86
Linux
fixed-aviary1.0
Bug Flags:
blocking-aviary1.0 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

13 years ago
Tested with a Seamonkey Linux trunk build from yesterday.

The option to use the Global Inbox is shown in the Account Wizard when you
create a Movemail account, though Global Inbox support for Movemail account is
currently not available.

Comment 1

13 years ago
The option in Account Wizzard is non-functional. But once you succeeded in
setting it up manually, "Global Inbox" itself works fine, even with Movemail and
multiple identities.
BTW: Identity manager is completely missing for movemail accounts. See also Bug
256971

Following settings WFM:

user_pref("mail.account.account1.identities", "id1");
user_pref("mail.account.account1.server", "server1");
user_pref("mail.account.account2.identities", "id2");
user_pref("mail.account.account2.server", "server1");
user_pref("mail.account.account3.identities", "id3");
user_pref("mail.account.account3.server", "server1");

user_pref("mail.accountmanager.accounts", "account1,account2,account3");
user_pref("mail.accountmanager.defaultaccount", "account1");
user_pref("mail.accountmanager.localfoldersserver", "server1");

user_pref("mail.server.server1.hostname", "localhost");
user_pref("mail.server.server1.login_at_startup", true);
user_pref("mail.server.server1.name", "Local Folders");
user_pref("mail.server.server1.type", "movemail");

Tested with "thunderbird-i686-linux-gtk2+xft.tar.gz version 0.7+ (20040825) "

Comment 2

13 years ago
The option in Account Wizzard is non-functional. But once you succeeded in
setting it up manually, "Global Inbox" itself works fine, even with Movemail and
multiple identities.
BTW: Identity manager is completely missing for movemail accounts. See also Bug
256971

Following settings WFM:

user_pref("mail.account.account1.identities", "id1");
user_pref("mail.account.account1.server", "server1");
user_pref("mail.account.account2.identities", "id2");
user_pref("mail.account.account2.server", "server1");
user_pref("mail.account.account3.identities", "id3");
user_pref("mail.account.account3.server", "server1");

user_pref("mail.accountmanager.accounts", "account1,account2,account3");
user_pref("mail.accountmanager.defaultaccount", "account1");
user_pref("mail.accountmanager.localfoldersserver", "server1");

user_pref("mail.server.server1.hostname", "localhost");
user_pref("mail.server.server1.login_at_startup", true);
user_pref("mail.server.server1.name", "Local Folders");
user_pref("mail.server.server1.type", "movemail");

Tested with "thunderbird-i686-linux-gtk2+xft.tar.gz version 0.7+ (20040825) "
Flags: blocking-aviary1.0?
(Assignee)

Updated

13 years ago
Flags: blocking-aviary1.0? → blocking-aviary1.0+

Updated

13 years ago
Depends on: 256971
(Assignee)

Comment 3

13 years ago
Created attachment 160423 [details] [diff] [review]
hide that choice from movemail accounts

Can you try this, Stefan? Ideally, we would get movemail working with the
global inbox, but I don't have a linux machine to try that on, and it's not
really supported.
(Reporter)

Comment 4

13 years ago
Comment on attachment 160423 [details] [diff] [review]
hide that choice from movemail accounts

This doesn't work, because movemail isn't treated as a mail account. So
isMailAccount.value is false and setServerType() is never called during
Movemail account creation.

The good news is, when I played with your patch I figured a way how to fix this
bug. :-) I'm going to attach a patch in a minute.
Attachment #160423 - Attachment is obsolete: true
(Reporter)

Comment 5

13 years ago
Created attachment 160469 [details] [diff] [review]
Patch

The problem was, that there was no way to detect that you are currently
creating a movemail account. I added a new kind of accounttype to pageData, so
now you can.

The patch also deals with hiding the separator between the deferStorage-box and
the incomingServer-box, because in the case of movemail, the incomingServer-box
is also hidden and thus there is nothing above the separator.
(Reporter)

Updated

13 years ago
Attachment #160469 - Flags: superreview?(bienvenu)
Attachment #160469 - Flags: review?(mscott)
(Reporter)

Updated

13 years ago
No longer depends on: 256971

Updated

13 years ago
Attachment #160469 - Flags: review?(mscott) → review+
(Assignee)

Comment 6

13 years ago
Comment on attachment 160469 [details] [diff] [review]
Patch

great, thx, Stefan. I never saw the bugmail notifications - sorry for the delay
Attachment #160469 - Flags: superreview?(bienvenu) → superreview+
(Reporter)

Comment 7

13 years ago
Fix checked in.(In reply to comment #6)
> (From update of attachment 160469 [details] [diff] [review])
> great, thx, Stefan. I never saw the bugmail notifications - sorry for the delay

Have you seen my other requests, e.g. for Bug 256971?

Fix checked in.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Reporter)

Updated

13 years ago
Attachment #160469 - Flags: approval-aviary?
(Assignee)

Comment 8

13 years ago
fixed on aviary branch
Keywords: fixed-aviary1.0
(Reporter)

Updated

13 years ago
Attachment #160469 - Flags: approval-aviary?

Comment 9

13 years ago
(In reply to comment #8)
> fixed on aviary branch

Using 2004-10-05 Linux build[1], it seems as if you completely removed the "Use
Global Inbox" option instead of giving it the desired functionality.

I'm not sure about this because in this build most of the chrome is broken.
Maybe it'll be available in one of the next non broken builds?

If no, would we have to file a new feature request for getting "Movemail along
with Global Inbox"? As I pointed out in comment #1 , that combination works
perfectly, but only setting up is a struggle without an interface. 

[1]http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2004-10-04-06-0.8/thunderbird-i686-linux-gtk2+xft.tar.gz
(Reporter)

Comment 10

13 years ago
(In reply to comment #9)
> (In reply to comment #8)
> > fixed on aviary branch
> 
> Using 2004-10-05 Linux build[1], it seems as if you completely removed the "Use
> Global Inbox" option instead of giving it the desired functionality.
> 
> I'm not sure about this because in this build most of the chrome is broken.
> Maybe it'll be available in one of the next non broken builds?

I hope my patch doesn't cause this... I can only check this in 6 hours or so,
because I'm at work currently.

> If no, would we have to file a new feature request for getting "Movemail along
> with Global Inbox"?

Yes, this would make sense.

> As I pointed out in comment #1 , that combination works
> perfectly, but only setting up is a struggle without an interface. 

Making the hiding of Global Inbox stuff complete was easier for the time being,
but ultimately having this functionality for Movemail would be nice of course. 

Perhaps David can provide a few hints about what needs to be done to achieve
this and why he decided to hide the UI.
(Reporter)

Comment 11

13 years ago
(In reply to comment #9)
> (In reply to comment #8)
> > fixed on aviary branch
> 
> Using 2004-10-05 Linux build[1], it seems as if you completely removed the "Use
> Global Inbox" option instead of giving it the desired functionality.
> 
> I'm not sure about this because in this build most of the chrome is broken.
> Maybe it'll be available in one of the next non broken builds?

I guess what you see is bug 262701. At least this is what I see. I wonder how
you managed to get to the Account Wizard with this build at all. ;-)

Comment 12

13 years ago
Created attachment 161155 [details]
Option "Global Inbox" has gone

(In reply to comment #10)
> > If no, would we have to file a new feature request for getting "Movemail 
> > along with Global Inbox"?
> 
> Yes, this would make sense.

Using today's build[1] unfortunately I can confirm that the option "Golbal
Inbox" on setting up Movemail account has definitely disappeared.

Comment 13

13 years ago
(In reply to comment #11)
> I guess what you see is bug 262701. 

Exactly. (It's almost fixed in today's build.)

> At least this is what I see. I wonder how you managed to get to the Account 
> Wizard with this build at all. ;-)

Starting Thunderbird with the option "-profilemanager", I could still access the
Account Wizard.

Comment 14

13 years ago
Filed a new Bug 263013
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.