RSS items should have different HTML mail preferences than regular messages

RESOLVED FIXED

Status

--
enhancement
RESOLVED FIXED
14 years ago
7 years ago

People

(Reporter: bugzilla.mozilla.org, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040730 Firefox/0.9.1+
Build Identifier: version 0.7+ (20040731)

When Thunderbird preferences are set to display messages are "plain text" or
"simple html", images and advanced html content do not display. While it is
possible to change the preferences when reading RSS feeds, they stay that way
while reading normal messages, resulting in the necessity of changing them back.

Adding a new preference solely for RSS accounts would make RSS browsing easier
for people who like plain-text email, but HTML RSS browsing.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago
At least Thunderbird should IMHO use the parser that strips the plain text out
of html mail/news.

Comment 2

14 years ago
This needs to get fixed, I don't think trying to map showing RSS into the global
e-mail settings is a good idea, but if it is going to stay that way, "simple
html" should at least be the real content of RSS feed (show images, etc.), since
there is currently no way to have those at all, the linked page shown by
"original html" (which is kind of stupid too, IMHO, as is not showing anything
at all when plain text is selected) does not necessarily even have same content.

Sage output for example is pretty much what I have in mind for "simple html".

Comment 3

14 years ago
*** Bug 259950 has been marked as a duplicate of this bug. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All

Comment 4

14 years ago
I agree with Sven's comment about the parser.  I see a need for 3 levels of feed:
Sage
Simple HTML
Full HTML

(and just to continue my own personal rant: I still think I should be able to
turn off remote image loading in RSS feeds but get all the HTML although if the
fact that it is displayed in an iFrame makes the coding too difficult I understand)

Comment 5

14 years ago
Absolutely..

I always use "plain text", which shows nothing when viewing RSS from eg.
theregister.com. Simple html shows the "headline + excerpt" and full loads the
page..

All i want i to keep plaintext for my email, and see all text contained IN the
rss tags, not loading the entire page. 

Comment 6

13 years ago
*** Bug 325445 has been marked as a duplicate of this bug. ***

Comment 7

12 years ago
I'd go one step further and say that this setting should be done per-folder - but I just spent a long time trying to figure out why some of my feeds were showing no content, and it's because I've configured thunderbird for plaintext emails, assuming that I'd also want this for RSS feeds is a little unintuitive. 
*** Bug 354096 has been marked as a duplicate of this bug. ***
QA Contact: rss

Comment 9

11 years ago
html tags in title are displayed literally. A bug was filed years ago, and considered duplicate of this, although for me are different bugs altogether (bug 284102 which was considered duplicate of bug 253853 finally resolved as invalid).

Comment 10

11 years ago
Sorry I meant bug 284102 which was considered duplicate of bug 252147 finally resolved as invalid

Updated

11 years ago
Depends on: 438429

Updated

11 years ago
Blocks: 438429
No longer depends on: 438429

Comment 11

11 years ago
If you have different prefs, they should be:
pref("mailnews.display.html_as", 0);
pref("rss.display.rss.html_as", 0);
pref("mailnews.display.html_sanitizer.allowed_tags", "html head ... noscript ... img(alt,title,longdesc,src) ... b");
pref("rss.display.html_sanitizer.allowed_tags", html head ... noscript ... img(alt,title,longdesc,src) ... b");

This would also allow you to permit a different set of HTML tags in RSS than in email.

The sanitizer has special code (not preffed) to remove URLs, and a special case to allow images embedded in the email (mid: URLs).
FYI, the sanitizer was written in part as defense against web bugs in spam mails.

To make a different set of prefs, you need to push your HTML through the sanitizer yourself. The currently used code is function HTMLSanitize() in mimemoz2.cpp
http://mxr.mozilla.org/seamonkey/source/mailnews/mime/src/mimemoz2.cpp#2201
called from mimethsa.cpp (mimeInlineTextHTMLSanitizedClass), which processes HTML (text/html) and triggered in mimei.cpp as alternative to mimethtm.cpp (mimeInlineTextHTMLClass).

Comment 12

11 years ago
I personally think the suggestion above is a ugly fix...

What if I want HTML for one feed and not another? Or... for one mail folder and not another?

These kinda of settings should be on a per account, and overrideable on a *per folder* level to be of real use - IMHO.

Comment 13

11 years ago
I don't think you want such complex prefs like the HTML tag list on a per account or pre folder level. Otherwise, you could argue that straight out all prefs should be per account/folder.

Comment 14

11 years ago
Personally I would argue that actaully - much like you can in mutt (i think)

Such as setting a sig per folder, or a default identify - or any other config setting.

Maybe I'm asking for the moon on a stick though... but this kind of feature is something I would definatly use - even if it meant writing complicated config files - obviously the scope of this solution is far greater.

Comment 15

11 years ago
That's fine. That just doesn't belong here. It should be a general facility of Mailnews (can you file an enhancement bug, please?) - to allow (almost) all prefs to be per-Account, but have a global (per-user) pref in case there's no pre-Account setting. Because in most cases, you want all accounts to have the same setting and all change with one click.
Assignee: mscott → nobody

Updated

10 years ago
No longer blocks: 438429
Depends on: 438429

Updated

10 years ago
Blocks: 438429
No longer depends on: 438429

Updated

10 years ago
No longer blocks: 438429
Depends on: 438429
Seconded, this is quite painful. In particular, I would love enhancements proposed on comments #14&15.

Comment 17

10 years ago
the UI pref selection has been implemented in Bug 438429, what remains is for libmime backend code to honor the pref for feeds.  marking this fixed, as it's obsoleted now by Bug 458606, and comments should follow up there.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

10 years ago
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core
You need to log in before you can comment on or make changes to this bug.