Never lose focus if element/ancestor is hidden, destroyed or disabled

RESOLVED DUPLICATE of bug 570835

Status

()

Core
Keyboard: Navigation
P2
minor
RESOLVED DUPLICATE of bug 570835
14 years ago
2 years ago

People

(Reporter: Aaron Leventhal, Unassigned)

Tracking

(Blocks: 2 bugs, {access, sec508})

Trunk
mozilla1.9alpha8
access, sec508
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
This is spun off from bug 255187

If any element becomes unfocusable for any reason (destroyed, hidden or disabled
are the reasons I can think of right away), then the focus should automatically
advance to the next focusable item.
(Reporter)

Updated

14 years ago
Priority: -- → P2

Updated

13 years ago
Target Milestone: --- → mozilla1.9beta
(Reporter)

Comment 1

13 years ago
We've taken care of any cases where focus/keynav is totally locked up -> minor
Severity: normal → minor

Updated

10 years ago
Blocks: 75324
Mass un-assigning bugs assigned to Aaron.
Assignee: aaronleventhal → nobody
QA Contact: keyboard.navigation

Updated

8 years ago
Depends on: 374786
When focused element becomes hidden by CSS visibility, this bug can still be reproduced on current Nightly build.

> data:text/html,<input autofocus id="i"><input><script>window.addEventListener("load", function () { var i = document.getElementById("i"); i.style.visibility = "hidden"; setTimeout(function () { i.style.visibility = "visible"; }, 10000); }, false);</script>

This testcase sets focus to the first <input> and hide it at load event. 10 sec later, it's shown again. Even during it's hidden, I can edit the content of <input>.

Comment 4

6 years ago
This is covered by 570835 pretty much.

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 570835
You need to log in before you can comment on or make changes to this bug.