Closed Bug 255342 Opened 15 years ago Closed 11 years ago

Infinite loop when `Bookmarks Toolbar Items` are added next to menus on top while `Bookmarks Toolbar Folder` has no bookmarks inside

Categories

(Firefox :: Toolbars and Customization, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 247116

People

(Reporter: mdonatas, Unassigned)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040809 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040809 Firefox/0.9.1+

Firefox enters an infinite loop (well nothing is infinite but still...) trying
to refresh it's toolbars layout once you add an empty (means no bookmarks are
added to it) `Bookmarks Toolbar Items` on the top of the browser next to
Firefox's menus.

Reproducible: Always
Steps to Reproduce:
1. Have no bookmarks in `Bookmarks Toolbar Folder`
2. Add `Bookmarks Toolbar Items` on top of the browser next to the menus
I saw a slightly different version of this, where if I have one item in my
'bookmarks toolbar folder', and the 'bookmarks toolbar' is a band just below
the forward/back/reload controls, and then I resize my browser to be narrow
enough that you see only the >> (and do not see the bookmark button) in the
toolbar area, then the browser flashes re-laying out the browser
again and again.
BTW, the problem that I was seeing was on Linux Fedora Core 3 with
FireFox 1.0
I too see this behaviour (like Danny, not William). Firefox 1.0.2 on Windows XP.
It causes the bar at the top of the window with the menus in it to get slightly
bigger and then slightly smaller continually.
Dupe of Bug 247116 ?
Blocks: 304183
Assignee: bugs → nobody
QA Contact: bugzilla → toolbars
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 247116
You need to log in before you can comment on or make changes to this bug.