application/rss+xml should pretty-print instead of downloading

RESOLVED WORKSFORME

Status

()

Firefox
File Handling
--
minor
RESOLVED WORKSFORME
13 years ago
a year ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

29.13 KB, application/atom+xml
Details
29.13 KB, application/rss+xml
Details
29.13 KB, application/rdf+xml
Details
(Reporter)

Description

13 years ago
1. Load http://www.squarefree.com/index.rdf

Result: Firefox asks me if I want to open or save.

Expected: Display the XML tree.  (For bonus points, add a "Subscribe" button at
the top in Firefox.)

Comment 1

13 years ago
We could either mark this as a duplicate of bug 155730 or make it depend on it.
After that bug is fixed we could make this a bug for the special "bonus points"
handling for this MIME type and probably for 'application/atom+xml' as well.

RDF files should have a 'application/rdf+xml' MIME type by the way, which is
supported, see bug 61839.
OS: Windows XP → All
Hardware: PC → All
Version: 1.7 Branch → Trunk

Updated

13 years ago
Depends on: 155730
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050603
Firefox/1.0+ ID:2005060317

WFM

Clicking the link displays the XML Tree. (Tested with a clean profile)

Comment 3

13 years ago
That IRI is no longer sending the right MIME type to trigger the "bug" described
in comment 0. Please test that first before adding a comment. (Removing it for now.)

Comment 4

13 years ago
anyone could upload testcases to bugzilla and set mime types, in the interim
i've setup:
http://viper.haque.net/~timeless/index.256379-rss
http://viper.haque.net/~timeless/index.256379-rdf
http://viper.haque.net/~timeless/index.256379-atom

Comment 5

13 years ago
Created attachment 187329 [details]
application/atom+xml

Comment 6

13 years ago
Created attachment 187330 [details]
testcase (rss)

Comment 7

13 years ago
Created attachment 187331 [details]
testcase (rdf+xml)
*** Bug 303802 has been marked as a duplicate of this bug. ***

Comment 9

12 years ago
*** Bug 320222 has been marked as a duplicate of this bug. ***

Comment 10

12 years ago
i'd greatly appreciate those feeds being displayed as trees...
(Reporter)

Comment 11

11 years ago
Feeds are now displayed in a nice way: not as an XML tree like I suggested when I filed this bug, but as excerpts and links and a subscribe button.  I think that's more useful for most users, so I'm marking this as FIXED.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Comment 12

11 years ago
What changed to "fix" this and when? Was it a core change, or just something in the Firefox feed handling code?  Do you happen to know Jesse, because I don't see this behavior in Camino trunk builds
it was the ff feed handling code
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
It works in some cases and not for others.  Example that doesn't work:
http://trac.wordpress.org/ticket/5149?format=rss

Looking at the headers, I don't see what the difference is between this and the examples from timeless.

Ciao!
Assignee: file-handling → nobody
QA Contact: ian → file-handling
The feed in Comment 14 has the HTML tags visible since they are escaped HTML chars, but are you seeing something else that is broken on the page?

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a2pre) Gecko/20090902 Namoroka/3.6a2pre (.NET CLR 3.5.30729) ID:20090902052327

Updated

a year ago
Component: File Handling → File Handling
Product: Core → Firefox
Version: Trunk → unspecified
Oy. We killed Camino, and SeaMonkey uses Firefox's feed preview. Die, bug.
Status: REOPENED → RESOLVED
Last Resolved: 11 years agoa year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.