If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Undo should be allowed after deleting an address book card

RESOLVED DUPLICATE of bug 240520

Status

Thunderbird
Address Book
--
enhancement
RESOLVED DUPLICATE of bug 240520
13 years ago
12 years ago

People

(Reporter: Jean-Marc, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040827 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040827 Firefox/0.9.1+

It's very easy to delete an address book card : just hit [DEL] or click on the
big red cross. Unfortunately "undo" for this is not implemented (it's grayed out
in the menu).

Reproducible: Always
Steps to Reproduce:
1. Select an address card.
2. Delete it : [DEL] or the red cross.

Actual Results:  
The "undo" item under the "Edit" menu is disabled.

Expected Results:  
"undo" should be available and the address card recoverable.

Comment 1

13 years ago
Duplicate of Bug 94407?
(Reporter)

Comment 2

13 years ago
If the address book component is common to Mozilla's MailNews and Mozilla
Thunderbird, my apologies for this duplicate.

Updated

13 years ago
Blocks: 94407

Updated

13 years ago
No longer blocks: 94407
Depends on: 94407

Comment 3

13 years ago
*** Bug 273347 has been marked as a duplicate of this bug. ***

Comment 4

13 years ago
*** Bug 266100 has been marked as a duplicate of this bug. ***

Comment 5

13 years ago
in a second step:
a Trashcan could be helpful (like it is for the normal Mail) -> so long they are
there you can recover -> confirm to delete forever! 

Comment 6

13 years ago

*** This bug has been marked as a duplicate of 240520 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
No longer depends on: 94407
You need to log in before you can comment on or make changes to this bug.