Reenable Offline in Profile Manager

VERIFIED FIXED

Status

()

Toolkit
Startup and Profile System
--
minor
VERIFIED FIXED
14 years ago
10 years ago

People

(Reporter: nthomas, Assigned: Benjamin Smedberg)

Tracking

Trunk
Points:
---
Dependency tree / graph
Bug Flags:
blocking-aviary1.0PR +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040902 Firefox/1.0 PR (NOT FINAL)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040902 Firefox/1.0 PR (NOT FINAL)

In bug 255654 the File menu item for Offline support was disabled, since this
feature will not be bug-free for version 1. Offline mode should not be available
from the Profile Manager either.

Reproducible: Always
Steps to Reproduce:
1. Launch Firefox using firefox -P or firefox -ProfileManager

Actual Results:  
Checkboxes for Offline Mode and Don't ask at startup are available

Expected Results:  
Offline mode checkbox should be hidden
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-aviary1.0PR?
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → 1.0 Branch
(Assignee)

Comment 1

14 years ago
Does not block PR, the profile manager is considered advanced UI.
Flags: blocking-aviary1.0PR? → blocking-aviary1.0PR-
This bug is about removing it, because of PR. See bug 255654.
Created attachment 157731 [details] [diff] [review]
Comment out offline mode option

Just comment it out for now.
Attachment #157731 - Flags: review?(mconnor)
Flags: blocking-aviary1.0PR- → blocking-aviary1.0PR?
(Assignee)

Comment 4

14 years ago
Comment on attachment 157731 [details] [diff] [review]
Comment out offline mode option

You cannot unconditially remove it, because it is required for Thunderbird.
Attachment #157731 - Flags: review?(mconnor) → review-
(Assignee)

Comment 5

14 years ago
And this bug does *not* block PR. Do not change the PR flag.
Flags: blocking-aviary1.0PR? → blocking-aviary1.0PR-
Created attachment 157734 [details] [diff] [review]
Only for firefox

Does this work?
Attachment #157731 - Attachment is obsolete: true
Attachment #157734 - Flags: review?(mconnor)
(In reply to comment #5)
> And this bug does *not* block PR. Do not change the PR flag.

Sorry, but I figured that releasing the PR with UI for a removed feature
somewhat silly, especially if it's such a trivial change.
(Assignee)

Comment 8

14 years ago
Comment on attachment 157734 [details] [diff] [review]
Only for firefox

You're getting closer, but I don't think you tested it: you need to also #ifdef
the code at
http://lxr.mozilla.org/aviarybranch/source/toolkit/profile/content/profileSelec
tion.js#120 or else it will throw an exception
Attachment #157734 - Flags: review?(mconnor) → review-
Created attachment 157737 [details] [diff] [review]
Patch v3 - needs to be backed out on trunk
Attachment #157734 - Attachment is obsolete: true
Attachment #157737 - Flags: review?(bsmedberg)
(Assignee)

Updated

14 years ago
Attachment #157737 - Flags: review?(bsmedberg)
Attachment #157737 - Flags: review+
Attachment #157737 - Flags: approval-aviary?

Comment 10

14 years ago
Comment on attachment 157737 [details] [diff] [review]
Patch v3 - needs to be backed out on trunk

a=asa for branch checkin.
Attachment #157737 - Flags: approval-aviary? → approval-aviary+
(Assignee)

Comment 11

14 years ago
Fixed, branch and trunk (should I have fixed this on the trunk? do we want
offline on the trunk?)
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Keywords: fixed-aviary1.0
Resolution: --- → FIXED
(Reporter)

Comment 12

14 years ago
Bug 255654 did not land on the trunk, and Asa specifically tells people to get a
trunk build if they can't live without offline support:

http://bugzilla.mozilla.org/show_bug.cgi?id=255654#c15

So this bug's patch should probably be backed out on the trunk.

Comment 13

14 years ago
Nick, that we had it in the past and I suggested people find it on the trunk
doesn't mean I was suggesting that it was a trunk requirement. 
dbaron, can you revert this one too?

/be
Status: RESOLVED → REOPENED
Flags: blocking-aviary1.0PR- → blocking-aviary1.0PR+
Resolution: FIXED → ---
Backed out of the aviary branch.
(Although as far as I can tell, the profile manager UI for offline mode doesn't
do anything even with offline UI enabled again.  But maybe I'm doing something
wrong...)
(Reporter)

Comment 17

14 years ago
Now that Firefox is back on the trunk, I noticed that the change was not
reverted there. It would be nice to do this for consistency with 1.0.
(Assignee)

Comment 18

14 years ago
Please do *not* land this on the trunk, it is an app-specific #ifdef.
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 19

14 years ago
I am proposing that the application specific ifdef be removed from the trunk.

http://lxr.mozilla.org/seamonkey/source/toolkit/profile/content/profileSelection.js#120
http://lxr.mozilla.org/seamonkey/source/toolkit/profile/content/profileSelection.xul#81

I was checked into branch and trunk, but only reverted on the branch.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 20

14 years ago
The Firefox 1.0 Profile Manager offers Work Offline. The trunk build does not
currently. See comment 19.
Keywords: fixed-aviary1.0
Summary: Profile Manager still offers Offline mode → Reenable Offline in Profile Manager
Version: 1.0 Branch → Trunk

Updated

14 years ago
Attachment #157737 - Attachment description: Patch v3 → Patch v3 - needs to be backed out on trunk
Requesting 1.1 blocking, since this is a regression from 1.0, what with the
app-specific code.

Is profile management planned to be part of XULRunner, or be layered on top of
it by apps as needed?
Flags: blocking-aviary1.1?

Comment 22

14 years ago
> Is profile management planned to be part of XULRunner, or be layered on top of
> it by apps as needed?

Profile management is a core function of XULRunner.  (See
http://wiki.mozilla.org/wiki/XUL:Xul_Runner#User_Profiles)

Updated

14 years ago
Blocks: 285789
(Assignee)

Comment 24

14 years ago
I have removed the #ifdefs.
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED
Any reason the comments weren't removed? There's no reason to leave a reference
to this bug there.
Flags: blocking-aviary1.1?
(Assignee)

Comment 26

14 years ago
Sure there is... bugzilla references can be very important for understanding why
the code has bizarre things like an offline switch in the profile manager.
(In reply to comment #26)
> Sure there is... bugzilla references can be very important for understanding why
> the code has bizarre things like an offline switch in the profile manager.

Right, but this bug won't help explain that line all, it was just about removing
(then restoring) it. It doesn't really matter.

Verified per latest beast build. As mentioned in comment 16, it doesn't seem to
have any affect, but that's something for another bug.
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.