remove offline from firefox for 1.0

VERIFIED WONTFIX

Status

()

Firefox
General
VERIFIED WONTFIX
13 years ago
11 years ago

People

(Reporter: asa, Assigned: Blake Ross)

Tracking

unspecified
x86
All
Points:
---
Bug Flags:
blocking-aviary1.0PR +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
Our offline support is mostly broken and we don't have time to do proper testing
before one dot oh. We should remove this for the PR.
(Reporter)

Comment 1

13 years ago
Removing features after the PR could have negative PR impact around 1.0. We
should plan on doing this ASAP.
Flags: blocking-aviary1.0PR+
(Reporter)

Updated

13 years ago
Flags: blocking-aviary1.0PR+ → blocking-aviary1.0PR?
(Reporter)

Comment 2

13 years ago
Or at a minimum, make it an off by default extension like offline for Tbird

Comment 3

13 years ago
> Our offline support is mostly broken

How is it broken?  I searched for "ALL offline votes:2 -mail -thunderbird" and
didn't see anything that screamed "broken".  In fact, the bug with the most
votes was the bug for adding offline support in Firefox, which is marked as FIXED.
(Reporter)

Comment 4

13 years ago
bug 106044 & bug 130774
also bug 43406 and bug 131500 are a few of the documented problems. That we
don't tell the user which pages in bookmarks and history are available and which
aren't available until after you click the link is horribly broken. This is an
almost unusable feature and we should remove it unless we can fix most of those
usability and dataloss problems. 
(Reporter)

Comment 5

13 years ago
It was decided at the last aviary meeting that we should pull this menu-item.
Blake, can you help here?
Flags: blocking-aviary1.0PR? → blocking-aviary1.0PR+
(Assignee)

Comment 6

13 years ago
Fixed.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
hmm, if I read blakes checkin right we just hid the menu item.

how big is this code? We still build it, right? Would we get a gain by not
building it?

Comment 8

13 years ago
There's probably no point in pulling the code for a couple of months, then
putting it back in for fixing later. People are free to work on the code and fix
it for post-1.0 builds as long as it's in the source. We could comment it out
maybe, but it's probably not worth it... I doubt there'd be significant
performance gains.
Yeah, you are right especially if it goes back in :)

V FIXED on debug branch build pulled today.
Status: RESOLVED → VERIFIED

Comment 10

13 years ago
I totaly agree on removing a non-working, broken, and a "we-didnt-care" feature
for 1.0, it'll look more professional ... 

But you can't really talk of permanently remove off-line feature (unless of
course your desire to be a mainstream browser changed). Just commment out and
make a plan for 1.1 to make off-line browsing a charm with firefox (alot of
people use the excellent internet explorer offline mode)

Comment 11

13 years ago
so what's happening with it? it it just the pref being hidden or is it being
totall pulled on the branch?
http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&subdir=mozilla/browser/base/content&command=DIFF_FRAMESET&file=browser-menubar.inc&rev1=1.19.2.2.2.18&rev2=1.19.2.2.2.19&root=/cvsroot

Comment 13

13 years ago
This hurts bad! Can we have an extension to re-show the item, at least?

Comment 14

13 years ago
The nightly builds should still include this function and for the major releases
it should be hidden until the feature has been polished up. It's not really a
big deal to take it out before each release is built. Personally I feel this
feature works as I would expect it to and furthermore I need this function for
my web browsing so I would like to see it in at least the nightly builds. 
(Reporter)

Comment 15

13 years ago
If you can't do without features that have been pulled for 1.0, get a trunk
nightly build. Please stop spamming bugs with advocacy comments. If you want to
have a discussion, take it to mozillazine. Thanks.

Comment 16

13 years ago
(In reply to comment #8)
> There's probably no point in pulling the code for a couple of months, then
> putting it back in for fixing later. People are free to work on the code and fix
> it for post-1.0 builds as long as it's in the source. We could comment it out
> maybe, but it's probably not worth it... I doubt there'd be significant
> performance gains.

Is there a point in keeping it? What if the "fix" causes a regression?

If nothing else, taking it out will make the file smaller for quicker download
and less load on servers when 1.0 does come out.

Comment 17

13 years ago
Just for the record, I have Thunderbird start up asking me if I want to go
online, and no way to access it. I'd hate to have a ton of people looking for a
fix for this the day after 1.0 hits the street when it could be there now.
(Reporter)

Updated

13 years ago
Keywords: fixed-aviary1.0
See also bug 257777.
Re-enabling offline for PR1.

Darin, we could use your help for 1.0 figuring out why going offline cancels
downloads in progress.  Any ideas?

/be
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Re-enabled for PR1.
Please revert bug 257777 also.

Comment 22

13 years ago
> Darin, we could use your help for 1.0 figuring out why going offline cancels
> downloads in progress.  Any ideas?

The reason for cancelation is simple: we kill the socket transport service when
switching to offline mode.

I'm assuming that you want a solution for 1.0, right? ;-)
Darin: sorry, we talked about this and I promptly forgot about the socket
transport service being zapped.  You mentioned either fixing things so the
downloads complete, then you go offline; or you get a "can't go offline" error;
or something better.  Ideas that fit in the 1.0 timeframe?

/be

Comment 24

13 years ago
> You mentioned either fixing things so the
> downloads complete, then you go offline; or you get a "can't go offline" error;
> or something better.  Ideas that fit in the 1.0 timeframe?

Yeah, those solutions might be tricky to implement, but maybe we could do
something.  It'd probably be easiest to make the STS stick around until all
sockets complete (i.e., just make it refuse to open any new sockets).

Comment 25

13 years ago
What about icon for go online/offline? Can it be shown in status bar?
Firefox 1.0

Comment 26

13 years ago
Offline wasn't removed from Firefox 1.0, and it won't be in the future.
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Keywords: fixed-aviary1.0
Resolution: --- → WONTFIX
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.