Remote image blocking Info between the thread-pane and message-preview is not updated when switching to another message

RESOLVED INVALID

Status

Thunderbird
Mail Window Front End
RESOLVED INVALID
14 years ago
13 years ago

People

(Reporter: AlexIhrig, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Thunderbird Installer 0.8 branch 20040902

When switching from a message (preview) with blocked remote images to another
message (preview) with no blocked images, the Remote-Image-Info between the
threadpane and the preview is NOT deleted.

Reproducible: Always
Steps to Reproduce:
1. Open the preview for a message with blocked remote images 

> the Remote-Image-Info is shown between the threadpane and the message-preview

2. Switch to another message (without remote images) in the same folder

> the Remote-Image-Info is NOT blended out / deleted

Actual Results:  
> the Remote-Image-Info is NOT blended out / deleted


Expected Results:  
> the Remote-Image-Info is should be blended out / deleted
(Assignee)

Comment 1

14 years ago
I haven't been able to reproduce this yet.

any JS errors in the console? Does this only happen on a particular message or
all the time for you? 
(Reporter)

Comment 2

14 years ago
The problem appeart in a clean install (2004-09-02) in every account, every
folder and every combination of messages.

After upgrading to 2004-09-03 (and for test cases downgrading to 2004-09-02) the
problem is gone (for both builds).

Comment 3

14 years ago
I can confirm this. Thunderbird 0.8 release on Mac OS X; copied it over my old
Thunderbird 0.7.3 release. I have Enigmail (from 0.7; not updated) and
SmoothWheel installed.

The "Thunderbird has blocked remote images" toolbar does not appear for text
message. For HTML messages with unloaded images, it appears. But it does not
disappear after clicking "Show Images", nor does it disappear when shifting to a
text message. It does disappear when switching mailboxes.

Any other details you need to know about my setup, let me know.
(Reporter)

Comment 4

14 years ago
I've been installing Thunderbird 0.8 in a clean directory. The problem appears
again.

I can confirm the description from Terence.

Comment 5

14 years ago
Running ThunderBird 0.8 (upgraded) with Enigmail version 0.85.0.0 on Windows XP.
Description from Alexander confirmed -- I was able to reproduce the problem with
the following observation - the 'Remote Images Blocked' Indicator is gone from a
plain message if the user switches to another folder and back.

Steps:

1. Open the preview for a message with blocked remote images 
Response: The 'Remote Images Blocked' indicator is shown between the threadpane
and the message-preview.

2. Switch to another message (without remote images) in the same folder
Response: The 'Remote Images Blocked' indicator is retained.
Expected Response: The 'Remote Images Blocked' indicator should not be shown.

3. Switch to another folder using the Folder Pane.

4. Switch back the original folder.
Response: The message (without remote images) is previewed without the 'Remote
Images Blocked' indicator.

Comment 6

14 years ago
I also see this on the 0.8 distribution and nightly (of Sep 20th)
Linux/gkt/xft with enigmail plug-in.

If you remove enigmail, the problem goes away. So there is some interferrence
between enigmail and the "remote image blocking" notice.

Comment 7

14 years ago
The problem appears to be in Enigmail and is documented as
http://bugzilla.mozdev.org/show_bug.cgi?id=7297

I recommend closing this bug in favour of the mozdev.org bug.

Comment 8

14 years ago
*** Bug 261459 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 9

14 years ago
ok closing this out. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Comment 10

14 years ago
*** Bug 261866 has been marked as a duplicate of this bug. ***

Comment 11

14 years ago
*** Bug 264478 has been marked as a duplicate of this bug. ***

Comment 12

14 years ago
xref bug 265196 -- The Mnenhy extension also causes this symptom.

Comment 13

14 years ago
*** Bug 259700 has been marked as a duplicate of this bug. ***

Comment 14

13 years ago
*** Bug 272532 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.