"show article summary instead of loading the web page" only affects new items

RESOLVED FIXED

Status

MailNews Core
Feed Reader
--
enhancement
RESOLVED FIXED
14 years ago
9 years ago

People

(Reporter: Joel Adami, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040911 Firefox/0.10
Build Identifier: Thunderbird version 0.6+ (20040901)

Both the default option "show article summary instead of loading the web page"
(acount settings -> news & blogs) and manage suscriptions -> edit don't work for
me. 


Reproducible: Always
Steps to Reproduce:
1.suscripe a rss feed
2.tick the option


Actual Results:  
thunderbird shows the webside instead of the summary

Expected Results:  
thunderbird should show the summary
(Reporter)

Comment 1

13 years ago
*** Bug 259020 has been marked as a duplicate of this bug. ***
Same here.  I originally was able to see the web page in the message view pane,
but after adding another feed and changing its option to "show summary", ALL my
feeds now refuse to show the web page even after changing their own settings and
the global setting.

Comment 3

13 years ago
In the RSS Account Settings panel, toggling "By default, show the article
summary instead of loading the web page" will only affect new RSS feeds added
after the checkbox has been selected or unselected. RSS feeds added previously
will continue to use their old setting for this feature.

Comment 4

13 years ago
This functionality is hard to fix because the setting controls the RSS mail item
the moment it's received - either just raw text, or an <iframe> directly
displaying the web page.

Suggested fix - the UI makes it more clear that what is happening e.g.

'Show article summary instead of loading the web page for future news messages'.

Note : OS should be 'All'.
(Reporter)

Updated

13 years ago
OS: Windows XP → All

Comment 5

13 years ago
See also bug 260074, which was marked as Invalid because this is basically an RFE
Changing the summary from "doesn't work" to "only affects new items", and
changing to enhancement
Severity: major → enhancement
Summary: "show article summary instead of loading the web page" doesn't work → "show article summary instead of loading the web page" only affects new items

Comment 6

13 years ago
See also bug 260858 (probably should be marked as duplicate of this)

Comment 7

13 years ago
*** Bug 260858 has been marked as a duplicate of this bug. ***

Comment 8

13 years ago
As I read but Bug 260858 this is not a duplicate.  Bug 260858 says that once an
article is downloaded it maintains the setting as of the time of download.  This
but is that articles are store without due respect to the setting of the
preference.  It is not the same thing.
*** Bug 287425 has been marked as a duplicate of this bug. ***
The summary and original comments aren't describing the same behavior.

This should be marked INVALID if following the summary, per comment 1 in bug 260074
or
It should be marked WFM if following the reporters original comments;  Newly dowloaded feed articles 
(post pref toggle) do respect the pref. 
QA Contact: rss

Updated

10 years ago
Depends on: 438429

Updated

9 years ago
Assignee: mscott → nobody

Comment 11

9 years ago
Additional confirmation: 
Only When RSS subscription is created it is possible to set if feed reads as raw text or web page. All subsequent changes are ignored, if you want to change settings you have to delete the subscription and create a identical new one with initial setting changed. Very annoying.
Fixed by bug 438429 ?
Whiteboard: closeme 2009-05-07

Comment 13

9 years ago
(In reply to comment #12)
> Fixed by bug 438429 ?

yes.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Whiteboard: closeme 2009-05-07

Updated

9 years ago
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core
You need to log in before you can comment on or make changes to this bug.