Add engines fails quietly unless user has rights to searchplugins dir

VERIFIED DUPLICATE of bug 232638

Status

()

defect
VERIFIED DUPLICATE of bug 232638
15 years ago
13 years ago

People

(Reporter: ajarmoniuk, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040911 Firefox/0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040911 Firefox/0.10

Add engines... option does nothing if the user does not have write permission to
the searchplugins directory. The engine is not added. No warning is shown.

Reproducible: Always
Steps to Reproduce:
0. Prerequisite: the user has no write permission to searchplugins dir.

1. Click on Add engines...; should load MyCroft.
2. Pick any search engine, a javascript confirmation dialog should pop up.
3. Pick "OK"

Actual Results:  
Nothing happens.

Expected Results:  
A warning message should pop up. 

Or, better, search plugins should be installed in user profile dir.
setting 
-> depends on bug 232638 move searchplugins directory to profile
Depends on: 232638

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 232638 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
No longer depends on: 232638
Resolution: --- → DUPLICATE
(Reporter)

Updated

15 years ago
Depends on: 248719

Updated

15 years ago
No longer depends on: 248719
Status: RESOLVED → VERIFIED

Comment 3

14 years ago
*** Bug 297306 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.