every second email deleted disappear instead of being sent to trash

RESOLVED DUPLICATE of bug 260226

Status

--
major
RESOLVED DUPLICATE of bug 260226
14 years ago
8 years ago

People

(Reporter: tux, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)
Build Identifier: Thunderbuird nightly build (20040907)

When deleting to trash (pressing delete key) multiple times (deleting it one-by-
one while reading) to delete multiple messages, each second messge gets deleted 
forever instead of sending to trash.

Reproducible: Always
Steps to Reproduce:
1. press Get Mail and download at least two new messages from server
2. read one. Delete it (Del key).
3. Read next. Delete it.

Actual Results:  
Look into trash folder: only one of the mesages is there.

Expected Results:  
both messages should be there
I have set "empty trash on exit", so this doesn't really matter to me, but some 
people might find losing their messages ....
It happens to me too. I have not set "empty trash on exit". Emails get not to
Trash after deleting from Inbox and from Sent Folder. Not all mails, but some. I
didn't have this problem before when I didn't use the Global Inbox.
I forgot to tell: I have windows XP SP1 and Thunderbird version 0.8 (20040914)
branch with one POP account
(In reply to comment #1)

> It happens to me too. I have not set "empty trash on exit". Emails get not to
> Trash after deleting from Inbox and from Sent Folder. Not all mails, but some. 
> I didn't have this problem before when I didn't use the Global Inbox.

"Deleted message" was probably moved to Trash folder file of the account instead
of Global Inbox account's or Local Folders's Trash folder file.
Terminate Thunderbird and see contents of "Trash" files (not Trash.msf file) in
Mail directry.

If you can find vanished mails, check "X-Account-Key" header of the mail,
then see prefs.js definition ; 

 (relation among account key/account id number/server number) 

 user_pref("mail.accountmanager.accounts", "accountAA,accountBB,...,accountXX");
 
 user_pref("mail.account.<accountXX>.identities", "<idYY>");
 user_pref("mail.account.<accountXX>.server", "<serverZZ>");

 user_pref("mail.identity.<idYY>......", ... ) entries
 user_pref("mail.server.<serverZZ>......", ... ) entries
I found a missing mail in Trash. Here it is:

"From - Fri Sep 17 10:11:45 2004
X-Mozilla-Status: 0001
X-Mozilla-Status2: 00800000
Message-ID: <414A8E2F.6020103@otenet.gr>
Date: Fri, 17 Sep 2004 10:11:43 +0300
From: Haris Karachristianidis <hariskar@otenet.gr>
User-Agent: Mozilla Thunderbird 0.8 (Windows/20040914)
X-Accept-Language: en-us, en
MIME-Version: 1.0
To: Michalis Vassiliadis <m.vassiliadis@prismaglass.gr>
Subject: (no subject)
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit

Ti eipan oi giatroi? Rotises ton Lampro?"

What can I do now?

I don't use the Global Inbox anymore and the problem still exists.

Comment 5

14 years ago
Seeing the bug here, although it's not every second mail - it's more random than
that. I confirmed the bug on my test PC with a fresh install of XP SP2 and TB
0.8. I used a single POP3 account, *without* the global inbox. Sent 12 emails,
received and deleted them, and one was missing from the trash - BUT it was still
present in the trash file (checked by viewing the file in text editor)
(Assignee)

Comment 6

14 years ago
Haris, did the From line look like this:

From - Fri Sep 17 10:11:45 2004

or did it really start with a quote, "From -..."? It has to start with
From<space>, no leading quote or anything.

If someone who's seeing this behaviour could zip up their trash folder and the
trash.msf file (preferably a small trash folder :-) ) and e-mail it to me, I
could try to figure out why the message is not showing up. 
Assignee: mscott → bienvenu
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to comment #4)
> I found a missing mail in Trash.

Where did you find the missing mail?
 (a) Trash file for the account
 (b) Trash file for Global Inbox account
 (c) Trash file for "Local Folders"

Where will deleted mails be moved after stopping Global Inbox use? 
a) Trash file for the account is the answer. I don't use Global Inbox anymore,
because I hoped it would fix the problem, but it didn't.
I agree with  Paul Roberts, it is not every second mail, but random. The title
should change, I guess.


(In reply to comment #7)
> (In reply to comment #4)
> > I found a missing mail in Trash.
> 
> Where did you find the missing mail?
>  (a) Trash file for the account
>  (b) Trash file for Global Inbox account
>  (c) Trash file for "Local Folders"
> 
> Where will deleted mails be moved after stopping Global Inbox use? 
> 

Comment 9

14 years ago
Something very weird is going on here... I can find already deleted mail not
only in the "trash" file, but also in my "inbox" and "sent" files in my profile!
(using Tb 0.8, Windows 2000)
(In reply to comment #9)
> Something very weird is going on here... I can find already deleted mail not
> only in the "trash" file, but also in my "inbox" and "sent" files in my profile!
> (using Tb 0.8, Windows 2000)

This is normal, if you Right click on a folder eg Inbox and choose Compact
Folder, then the mail is deleted from Inbox.

Comment 11

14 years ago
Sorry, you're right, I forgot to compress the folders. ;/ but the bug is still
present... sorry for the bugspam.

Comment 12

14 years ago
Is this related to 260370, it sounds like there is a general problem with some
mail going into the ether.

Comment 13

14 years ago
This is nasty - lost e-mail on move as well as delete.
Hope it's high priority - like 0.8.1 tomorrow...!!!

Jem

Comment 14

14 years ago
This is nasty - lost e-mail on move as well as delete.
Hope it's high priority - like 0.8.1 tomorrow...!!!

Jem
(Assignee)

Comment 16

14 years ago
duping - discussion is going on there...

*** This bug has been marked as a duplicate of 260226 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.