message count and file size is wrong for folders on pop3 account

RESOLVED DUPLICATE of bug 260981

Status

--
major
RESOLVED DUPLICATE of bug 260981
14 years ago
14 years ago

People

(Reporter: worcester12345, Assigned: mscott)

Tracking

unspecified
x86
Windows XP
Bug Flags:
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040912 Firefox/0.10 (bangbang023)
Build Identifier: Thunderbird version 0.8 (20040910)

see this thread: http://forums.mozillazine.org/viewtopic.php?p=745732#745732

details:
After emptying the trash, the number of messages in the trash folder remains. I
am emptying it with the right mouse button. The only thing which clears that
number is quitting and then restarting the program.

Further info: All folders' numbers are doing this. I have one set up for
notifications from this forum, and it said 6 until I clicked on it (after the
new mail sound came) and saw the two new ones. The number then updated to 8
after selecting the folder. Just more of an FYI to you, MScott.

More info on folder problems: I deleted a few messages, then went to the "Trash"
folder to look at or recover or whatever, and it showed 2 messages and the size,
but it would not show the messages.

Reproducible: Sometimes
Steps to Reproduce:
1.
2.
3.

Actual Results:  
Message counts were off, messages not showing up.
Restarting Thunderbird fixed counts, but messages still not showing after
restarting.

Expected Results:  
The counts should have been correct and messages should be visible.
(Reporter)

Updated

14 years ago
Flags: blocking-aviary1.0?

Comment 2

14 years ago
Also seeing this problem on Win98se.

Comment 4

14 years ago
possibly related, yes.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 5

14 years ago
This one also sounds familiar. I think they are all related:

"Blank emails appear in my inbox listing"
https://bugzilla.mozilla.org/show_bug.cgi?id=216730
(Reporter)

Comment 6

14 years ago
another:

"Messages visually disappearing when closing thread"
https://bugzilla.mozilla.org/show_bug.cgi?id=259259
(Reporter)

Comment 7

14 years ago
Quitting and restarting the program doesn't change the count, as I previously
said. The only thing that does is if I get lucky and delete one which "takes"
and then I can empty trash and have it go back to 0. Ditto for junk mail.

Comment 8

14 years ago
please try a nightly trunk or .8 build from yesterday or today...I believe this
is fixed now.
(Assignee)

Comment 9

14 years ago
not a 1.0 stopper unless we get more reports of problems. 
Flags: blocking-aviary1.0? → blocking-aviary1.0-
(Reporter)

Comment 10

14 years ago
(In reply to comment #8)
> please try a nightly trunk or .8 build from yesterday or today...I believe this
> is fixed now.

Finally was able to get a nightly build. It seems to be somewhat fixed, but the
program seems so slow now that it feels like it has crashed or is about to just
about all the time. It takes over a minute to find out I have one little email.
I am not sure if this is still related to this folder and counting issue or not,
but it sure feels like it just got a lot slower with this night's "fix".

Comment 11

14 years ago
the fix would not slow the app down - the code would only be called if you
compacted a folder or emptied the trash, and the change wouldn't make any
appreciable difference in performance even then. There might have been other
changes, of course, in that build, or perhaps something's going on with your
system. On top of that, no one else has reported any slow down...

*** This bug has been marked as a duplicate of 260981 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 12

14 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3)
Gecko/20040912 Firefox/0.10 (bangbang023)
> Build Identifier: Thunderbird version 0.8 (20040910)
> 
I have been having this bug, and the other bug that referred me here.
1) I get a message that should be automatically junked, but it stays in the inbox.
2) I get multiple messages, delete one by one as reading, trash folder only has
message 2+.  Message 1 is rarely ever found.
3) I get mixed messages (junk and non-junk).  As I hit the junk button, not all
follow the rule of moving to Local Folders->Trash.
4) Automatic Junk detection is supposed to move them to Local Folders->Trash. 
Sometimes they are in account trash, sometimes in Local Folders trash, sometimes
they are not ANYWHERE.
5) Many times I have to try to fool the system by only deleting junk, then going
to the account trash and setting them as Junk so they move to Local Folders
trash, then I can compact the folder and both trash and inbox compact (doesn't
work if only 1 email due to #2 above).   
6) many times my trash folders NEVER compact (unless later I do #5 above).  Even
after restarting, the won't compact and I have to physically edit the disk file
and delete the contents.  Then when I click on the trash folder it clears the
byte count.

That's a lot to try to track down.....
rfb
You need to log in before you can comment on or make changes to this bug.