If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Indicate sort direction in column headers in thread view

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED WORKSFORME
18 years ago
13 years ago

People

(Reporter: Richard Zach, Assigned: David Hyatt)

Tracking

({helpwanted, polish})

Trunk
Future
helpwanted, polish

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rtm-] REQUEST PICTURE)

(Reporter)

Description

18 years ago
NS 4.7 has little up and down arrows to indicate the column sorted on and the
sort direction in the thread pane column headers.  Mozilla MailNews should have
that too.

Updated

18 years ago
QA Contact: lchiang → fenella

Comment 1

18 years ago
Seems like some combination of the tree and RDF need to work this out.
Reassigning to rjc, cc hyatt and alecf.
Assignee: phil → rjc

Comment 2

18 years ago
RDF sets various "hints" in the content model to indicate when a sort is being 
imposed, its "direction", etc.  Its up to Mail/News to use CSS to get the 
appropriate effects (up/down icons, gray the selected column, etc.)

Phil, can you assign this to someone on the Mail/News team?
Assignee: rjc → phil

Comment 3

18 years ago
Thanks Robert. Reassign to putterman.
Assignee: phil → putterman

Comment 4

18 years ago
*** Bug 26118 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M17

Comment 5

18 years ago
*** Bug 30254 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 6

18 years ago
becki@talkware.net posted a patch to n.p.m.mail-news for sort direction
indication in the address book.  Should that be a different bug?

Comment 7

18 years ago
hangas actually filed a new bug for the address book sort indicator: 
http://bugzilla.mozilla.org/show_bug.cgi?id=32015

Comment 8

18 years ago
Mail Review hopes this is post-beta2, easy, polish work.  Marking M18.
Target Milestone: M17 → M18

Updated

18 years ago
Keywords: nsbeta3

Comment 9

18 years ago
nominate as nsbeta3. This was a problem for users observed during usability 
testing.

Updated

18 years ago
Keywords: mail2, polish

Comment 10

18 years ago
reassigning to dimator
Assignee: putterman → dimator
Status: ASSIGNED → NEW

Comment 11

18 years ago
FYI, already fixed for the Address Book.

Comment 12

17 years ago
So this should be really easy?
OS: Linux → All
Hardware: PC → All

Updated

17 years ago
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 13

17 years ago
Fixed.  I disabled sort indicators for the unread button column and the flagged
column, as per my discussion with scottip, because the indicator was causing
display problems (it was being placed in the column headers to the right of
unreadbutton and flagged).  All the others work fine though.

Updated

17 years ago
Whiteboard: [nsbeta3+]

Comment 14

17 years ago
Linux (2000-08-07-14 M18)
Win32 (2000-08-06-21 M18)
Mac (2000-08-06-20 M18)
Verify that this problem has been fixed.
Status: RESOLVED → VERIFIED

Comment 15

17 years ago
Linux (2000-08-23-06 M18)
Win32 (2000-08-23-08 M18)
Mac (2000-08-23-08 M18)
This bug comes back again.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 16

17 years ago
fenella, can you try this again with some 8-24 builds?  I'm not seeing the 
problem with them...

Comment 17

17 years ago
Linux (2000-08-24-08 M18)
Win32 (2000-08-24-06 M18)
Mac (2000-08-24-08 M18)
I still see this problem.
(Reporter)

Comment 18

17 years ago
I have nice little triangles in 00-8-26-08 Linux.

Comment 19

17 years ago
second pass: - per mail triage
Whiteboard: [nsbeta3+] → [nsbeta3-][cut 8/29]

Comment 20

17 years ago
*** Bug 50933 has been marked as a duplicate of this bug. ***

Comment 21

17 years ago
Retested this to see if it's still happening.  Yes this is still a bug on builds 
2000-09-26 on win98, mac and linux.  Both Modern and classics themes. 

Comment 22

17 years ago
Retested on branch, still a problem.  Note: On some profiles that were created
weeks ago, the arrow indicator for sort order shows up on the coloumn.  We saw
this on Scott's system, but if you create a new profile this doesn't work.  Also
note, the Address book and Bookmarks don't display this arrrow for the sort
order either. Scott says it a general bug.

Comment 23

17 years ago
nominating for rtm, this is very visible in our main window.
Keywords: rtm

Comment 24

17 years ago
Robert, can you see if RDF is setting the active sort attribute for the tree?  
If so, please forward to Hangas to see if this is a skins problem.

(We also think the column highlighting is broken due to the same cause as this 
bug.)
Assignee: dimator → rjc
Status: REOPENED → NEW
Keywords: mailtrack
Whiteboard: [nsbeta3-][cut 8/29] → [nsbeta3-]
RDF is setting the attributes.  In my branch build from today, sorting in 

Bookmarks as well as Mail DOES display the sorting direction icon (Classic Skin).



Over to Paul...

Assignee: rjc → hangas

Comment 26

17 years ago
So do we have a failure in Modern for Mail?  I thought this was working too.  Is 
there still a problem with sort indication?

Comment 27

17 years ago
I think it might be a problem everywhere. Unfortunately this has never happened
to me in my debug build and it's working fine in my commercial build. But, I
have seen this not work on various members of QA's machines including as
recently as last week.

Comment 28

17 years ago
does resizing the window make it appear by chance? Maybe this is one of those
stale-box-reflow bugs that makes the header area fail to appear...

Comment 29

17 years ago
In the branch builds, on all platforms, this problem does not exists.
Linux (2000-09-29-09 MN6)
Win32 (2000-09-29-09 MN6)
Mac (2000-09-29-11 MN6)
Need to check trunk builds again

Comment 30

17 years ago
nbaca or esther, since you were able to reproduce, does resizing help?

Comment 31

17 years ago
Branch builds from 9/29: NT4, Linux 6.0, Mac 9.04
I can see the sort indicators in the thread pane and address book. Same results 
as Fenella. We'll check the trunk builds next.

Comment 32

17 years ago
Strange bug, seems to come and go from build to build.  I see this in the N6 10-
11-10 build for Classic and Modern.  Sending to Joe
Assignee: hangas → hewitt
Whiteboard: [nsbeta3-] → [rtm need info]

Comment 33

17 years ago
This works in my tree, but is broken in verification builds.  I hate when that 
happens.
Status: NEW → ASSIGNED

Comment 34

17 years ago
I don't think this is a theme bug, because:

A. it happens in both themes
B. I can get the box to render itself
C. It fails to recognize rules with the "sortDirection" attribute specified.

So, my conclusion is that for some reason, sortDirection is not being set on the
treecell header.

Comment 35

17 years ago
This morning I was seeing this bug. Then I created a new profile... and now the
bug has gone away.  I can't explain it.  Is anyone else seeing / not seeing this
in today's branch builds?

Comment 36

17 years ago
I'm seeing it in my branch debug build from this morning. It's not appearing in
any of the windows that use it.

Comment 37

17 years ago
This is intermittent.  The headers are there sometimes, not there other times.  
All I can say is that the CSS is correct, and the problem is that the 
sortDirection attribute is not always getting set on the headers.  I think the 
code for setting this is in C++, not JS.  Re-assigning to Hyatt for 
investigation.
Assignee: hewitt → hyatt
Status: ASSIGNED → NEW
(Assignee)

Comment 38

17 years ago
Sorting code that sets attributes is owned by waterson and rjc.  Reassigning to
them. FWIW, this works for me just fine.
Assignee: hyatt → rjc
WORKSFORME too
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 40

17 years ago
Mac (2000-10-16-08 MN6)
Linux (2000-10-16-09 MN6)
Win32 (2000-10-16-09 MN6)
Mac is OK.
But Linux and Win32, I try both the old migrated profile and a new profile, the 
bug is still there.
Re-open the bug
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
This appears to be a mail-only bug... Scott?  Something special about the thread 
pane?  (Oddly enough, this sounds similar to a transient problem that warren was 
working on regarding getting CSS etc out of JAR files, which would sometimes 
fail.)
Assignee: rjc → putterman
Status: REOPENED → NEW

Comment 42

17 years ago
this is not a mail only bug! I see it in bookmarks when it happens. The WFM
isn't valid because I've seen it both work and not work continually. My guess is
that developers aren't seeing this bug. When it happens it happens everywhere so
it's not mail code (though in theory since we just copied how bookmarks did it,
it could be).

I really believe that this is either a sorting problem when are an attribute on
the column isn't being set or a style rule problem.

Comment 43

17 years ago
I'm now seeing this problem on my Win98 10/16 08 mn6 build.  I also see that
manage bookmarks is broken and history appears to be broken as well (but it
doesn't show any of my URLs so that may be bogus.)

It used to work fine for me on my WinNT, but it recently stopped working.  Not
sure which build, but I thought it was also the 10/16.

Comment 44

17 years ago
Sounds like either rjc or warren is the correct owner for this bug.  Robert has
previously stated that he's setting the attribute properly.  Given that it's a
transient problem, it sounds more like we're failing to get the proper CSS from
the jar file.

Warren, can you examine why we might still fail to load CSS from the jar sometimes?
Assignee: putterman → warren

Comment 45

17 years ago
rjc: I don't know of any transient problem getting things out of jar files.
Assignee: warren → rjc
Talking with Warren directly, he says the problems were with the memory cache.

Comment 47

17 years ago
sorry for the extra email. Removing mail2 keyword.
Keywords: mail2
I finally managed to reproduce this *once* today (and only once; I can't get it 
to happen again) so immediately broke into the debugger and did a bit of 
checking. As far as I can see, the XUL Sort Service *IS* setting the correct 
attributes on the correct nodes, but something farther down in the style system 
(or XUL, or ...?) isn't working correctly.

Over to trudelle's XUL/CSS experts...
Assignee: rjc → trudelle

Comment 49

17 years ago
Are you guys serious?  I don't think this feature is worth any risk at this
point. Given the other serious bugs we've got on our plate, or have already
futured, I can't see spending any time on it either. This is a no-brainer. rtm-
Whiteboard: [rtm need info] → [rtm-]

Comment 50

17 years ago
->future/helpwanted
Keywords: helpwanted
Target Milestone: M18 → Future

Updated

17 years ago
Status: NEW → ASSIGNED
*** Bug 50933 has been marked as a duplicate of this bug. ***

Comment 52

17 years ago
this works now, resolving as fixed to get test/verfiy - a big Thank You to
whoever did the work!
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 53

17 years ago
Sorry folks, I still see this problem on the 2000121904 build on Windows 98 and
screen resolution 800x600 small fonts. Other people reported on chatzilla they
don't see this bug in Modern (while I do) but agree on one point: this bug
happens always in Classic. REOPENING.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 54

17 years ago
It doesn't always happen - WFM using classic on Win98 with small fonts, on a
recent personal build of Mozilla.  Possible packaging problem?  The only other
difference is I'm using 1280X1024 and 1024X768.

Comment 55

17 years ago
Please don't reopen such a bug without a picture.  I can't tell if you're 
talking about sorting chatzilla userlists or the mail thread view.
Whiteboard: [rtm-] → [rtm-] REQUEST PICTURE

Comment 56

17 years ago
The sort indicator disappears If I switch the theme.

Comment 57

17 years ago
I started investigating this after I had a bug #49079 reopened after I thought
it was "worksforme".   I then went to 5 other folks here - on macs, pc's, modern
and classic, and 50% of the people could see the sort indicators, and 50% could
not. And it wasnt like 1 person 50% of the time, it was like if you didnt see it
you never saw it, and if you did see it you always saw it.

Now using the console, there were two possible things, there was some error in
abOverlay.js line 9 I think, but even when this error shows up in the console,
someone was able to see the sort indicators.

The other thing we saw was a dump statement saying "failure to do sort".

So this is really puzzling!

I think my bug though (49079) depends on this .

What would cause roughly 50% of the folks who do this (regardless of fresh
profile) to see the sort indicators, and 50% or so do not.  Could some component
not be getting registered. or some race condition in layout?

Comment 58

17 years ago
adding self to cc.

Comment 59

17 years ago
clearing future target, ->hyatt
Assignee: trudelle → hyatt
Status: REOPENED → NEW
Target Milestone: Future → ---

Updated

17 years ago
Blocks: 49079

Updated

17 years ago
Keywords: mailtrack

Comment 60

17 years ago
-> future, and re-evaluate with outliner
Target Milestone: --- → Future

Comment 61

17 years ago
ok - outliner's in - should this be revisited?  I dont see any sort indicators
at all in mac...

Comment 62

17 years ago
wfm
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 63

17 years ago
ops, probably was too quick, sorry. Not sure that it works everywhere.

I use a nightly after the "modern 3" landing. Modern skin. Linux. Non-debug,
optimized.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 64

17 years ago
FYI:
Build 2001-05-15-04: WinMe
Build 2001-05-15-08: Mac 9.04
Build 2001-05-15-08: Linux (scalkin's system)

- Existing profiles (win, mac, linux)
I'm seeing the column indicators in the thread pane and Address Book using
Modern and Classic.

- New profiles (win, mac)
I'm seeing the column indicators in the thread pane and Address Book using
Modern and Classic. Can't try on linux due to a crash when creating new profiles.

Comment 65

17 years ago
Propose 4xp keyword since feature is present on NS 4.x and not on Mozilla.

Updated

16 years ago
QA Contact: fenella → laurel

Comment 66

16 years ago
Marking worksforme,  I'm pretty sure this is fixed now everywhere with outliner.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → WORKSFORME

Comment 67

16 years ago
OK with apr5-8 commercial trunk: win98, mac OS 9.2, linux rh6.2
OK in both new and existing profiles.
OK in both classic and modern themes.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.