No new mail notification icon when using global inbox and filters

RESOLVED FIXED in Thunderbird1.0

Status

defect
RESOLVED FIXED
15 years ago
15 years ago

People

(Reporter: farmerchris, Assigned: Bienvenu)

Tracking

({fixed-aviary1.0})

unspecified
Thunderbird1.0
x86
All

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Reporter

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

When email arrives to an account that is set to use the global inbox (ie, the
inbox from Local Folders) the new mail notification does not appear.  The popup
alert box is intermittent but infrequently works.  I never see the system tray
icon.  I don't have speakers on this machine so I can't tell you whether the new
mail sound is played.

Reproducible: Always
Steps to Reproduce:
1. Add a POP3 account to use the global inbox feature in Thunderbird 0.8.
2. Turn on the "Show an alert" setting for new mail.
3. Send mail this this account, and wait for it to arrive.

Actual Results:  
Usually I will see no popup alert; there is never any system tray icon.

Expected Results:  
Popup alert and white icon in the system tray.

Setting the POP account back to use its own inbox restores the notification
functionality.

Comment 1

15 years ago
I have the same problem.  I am using version 0.8 (20040913), with only 1
extenstion installed: Contacts Sidebar 0.3.

I have never once seen a new mail notification (I have been using this build
since its release date, and get email several times daily).  I have "show an
alert" checked, play an alert is not.

This particular installation has 1 account, specified as global and the mail
goes to my Local Folders-->Inbox.

Comment 2

15 years ago
I experience this problem as well.   The audio notification does work if that is
important.  It's just the system tray and popup alert that isn't working.  

Comment 3

15 years ago
Using TB version 0.8 (20040913) (WinXP Pro SP1), I'm experiencing the same
problem.  No pop-up or system tray notification when using Local Folders. 
System sound does fire however.

I see the same problem forcing one account to go into another (inbox for
different account).

If you restore accounts to their normal set-ups, notifications fire as expected.

I've tested this on a fresh install of TB (brand new profile as well) with no
extensions.
Assignee

Updated

15 years ago
Assignee: mscott → bienvenu
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

15 years ago
I can confirm this bug also occurs when the POP account is deferred to another 
POP account, not just to the Local Folders.
Reproduced with TB 0.8 milestone, Win2K.

Could not reproduce with Mozilla 1.8a4-0924 -- I got the notification for the 
deferred account, with that program.

Comment 5

15 years ago
*** Bug 250369 has been marked as a duplicate of this bug. ***

Comment 6

15 years ago
*** Bug 259377 has been marked as a duplicate of this bug. ***

Comment 7

15 years ago
Experiencing same: no popup alerts or systray reminders for new POP emails in
local folders on global acct.

Win2k/
Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10

Thunderbird version 0.8 (20040913).
Reporter

Comment 8

15 years ago
More on this.  I now have two machines with Thunderbird.  On on, the
notifications work using global inbox.  On the other, they don't work when
global inbox is enabled.  If it can help reproduce this bug, I can post the
configuration files from each program to this bug.  Please let me know what
files you'd like to see.

Comment 9

15 years ago
I am experiencing the same problem, but on Linux (Thunderbird 0.8 + New Mail
Icon extension, moztraybiff.mozdev.org). The new mail notification icon in
system tray works intermittently with Global Inbox enabled. New mail sound works
always. I tried to do some testing to see why it works only sometimes, but there
is no apparent connection to anything.
I suggest changing the OS field to 'All'.
I am using version 0.8 (20040913) on Windows XP (w/ SP 2), and this is a problem
for me as well. I use the Global Inbox, and the system tray icon shows up only
once in a while (as does the notification).

Comment 11

15 years ago
This is happening on versions of Windows other than XP as well as Linux.
Shouldn't this be OS "All"?
Reporter

Comment 12

15 years ago
Moving to OS: All.
OS: Windows XP → All
I'm running TB 0.8 and was having the same problem: audio notification worked,
but no systray notifications.  Then, I upgraded Mozilla from 1.7 to 1.7.3 and
again to 1.8a4 (trying to find a bug).  Mozilla is now uninstalled, with Firefox
0.9.3 installed.  I also uninstalled JRE 1.4.2 and installed 1.5.  One of these
seems to have fixed the problem, because I now have systray alerts with global
inbox.
Sorry I wasn't paying more attention, but maybe that'll help point someone in
the right direction.
Assignee

Comment 14

15 years ago
Chris, the first files to see are your prefs.js for the two profiles.

Comment 15

15 years ago
Hi David, et. al.;

The mail notification envelope quit appearing in my system tray upon installing
TB0.8 with global inbox as well.  I have two email accounts and I just ran the
following test.  I first removed one account from the global inbox. The result
was the continued absense of the mail notification envelope upon receipt of
messages.  I then removed the other account from the global inbox such that none
of my accounts use global inbox.  Then, the mail notification envelope began
appearing (as it should) upon receipt of messages.  Then, once I made either
account use global inbox again then the problem reappeared with no mail
notification envelope in the system tray.  

This bug's dependence on the global inbox is very easy to duplicate at least in
my installation.

FYI,

Gordon Dickens
Assignee

Comment 16

15 years ago
I'm able to reproduce the problem and I believe I have a fix for it...the
problem is that when we get to the code that decides whether or not to put up an
alert about new mail, we check if we're really running biff or not (we don't put
up new notifications if the user presses get new mail). The problem is that
we're setting the performingBiff flag on the pop3 server, but checking it on the
local folders server...I've got a patch that makes us set the performingbiff
flag on the local folders server...
(In reply to comment #16)
> (we don't put up new notifications if the user presses get new mail).

I thought I'd seen as much, but not consistently.  Is there a difference there 
between Get New Mail for <account> and Get New Mail for ALL accounts?

Anyway, given that, how to explain bug 260245?
Assignee

Comment 18

15 years ago
if we're not setting and clearing the performing biff flag correctly in the
global inbox case, that could help explain bug 260245...but I don't know for
sure. There's still some things I'm not sure about in the multiple account case.
Assignee

Comment 19

15 years ago
Posted patch proposed fixSplinter Review
Assignee

Updated

15 years ago
Attachment #161965 - Flags: superreview?(mscott)

Updated

15 years ago
Attachment #161965 - Flags: superreview?(mscott) → superreview+
Assignee

Updated

15 years ago
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Keywords: fixed-aviary1.0
Resolution: --- → FIXED

Comment 20

15 years ago
I don't believe this is fully fixed yet, I'm afraid.

If you follow the steps to reproduce from the original reporter, but first
enable "Do not mark messages as junk mail if the sender is in my address book"
in the junk mail controls for local folders, the problem still exists, as described.

See http://forums.mozillazine.org/viewtopic.php?t=139727.

I'm using version 0.8 (2004-10-25 branch) on Windows XP SP2.

Comment 21

15 years ago
David, I have to agree with Comment 20.  I'm using the 10/26 nightly, and the
problem is still there.  Messages that get downloaded to the Global Inbox when I
first start TB (not by clicking Get Mail), do not trigger the tray icon.

Comment 22

15 years ago
reopen?

Comment 23

15 years ago
The problem is still appearing in version 0.9 (20041103), using the Global
Inbox.  Granted, it is intermittent this time, but notifications (both pop-up
and system tray) do not fire on a consistent basis.

At least the message filters appear to be working correctly for the Global Inbox.

Comment 24

15 years ago
I am still seeing this problem.

It also seems to occur with mail that gets filtered into folders - if the mail
stays in my inbox (i.e. isn't filtered), i'll get the icon.

Comment 25

15 years ago
I have also the same problem . 
It seems to happen randomly. 
My  installation has 4 accounts ,  and all the mail
goes to my Local Folders-Inbox or are filtered to other subfolders.
does the propose patch work??? 

Comment 26

15 years ago
(In reply to comment #25)
> I have also the same problem . 
> It seems to happen randomly. 
> My  installation has 4 accounts ,  and all the mail
> goes to my Local Folders-Inbox or are filtered to other subfolders.
> does the propose patch work??? 

Please let us know what you find out, franck.

Comment 27

15 years ago
Can someone please reopen this bug?  It's obviously not fixed, but it's not
gonna get any attention since it's labeled RESOLVED.
Assignee

Updated

15 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Assignee

Comment 28

15 years ago
adjusting summary to reflect filter case. I do see this problem and should have
a fix today.
Status: REOPENED → ASSIGNED
Summary: New mail notification icon does not appear when using global inbox → No new mail notification icon when using global inbox and filters
Target Milestone: --- → Thunderbird1.0
Assignee

Comment 29

15 years ago
Posted patch proposed fixSplinter Review
need to set the dest server (in this case, local folders), as performing biff,
so the notification will fire.
Assignee

Updated

15 years ago
Attachment #166019 - Flags: superreview?(mscott)

Updated

15 years ago
Attachment #166019 - Flags: superreview?(mscott) → superreview+
Assignee

Comment 30

15 years ago
2nd patch checked into branch and trunk - please try tomorrow's build.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → FIXED

Comment 31

15 years ago
David,

I've just tried build 20041116 (branch) and I think you've nailed it this time.

Well done, and thank you!

Comment 32

15 years ago
Hi David,

I will second what Dave Murray said.  I have downloaded and tested the 20041117
branch build and the new mail notification icon is working properly.  It appears
that the latest patch corrected the problem.

Thanks,

Gordon

Comment 33

15 years ago
*** Bug 270489 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.