favicon shows in location bar but not in bookmarks toolbar folder

RESOLVED DUPLICATE of bug 258867

Status

()

RESOLVED DUPLICATE of bug 258867
14 years ago
12 years ago

People

(Reporter: skaes, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10

After adding www.dilbert.com to the bookmarks toolbar folder, the favicon never
shows in the toolbar, not matter how many times you load the page by clickking
on the toolbar icon.

Reproducible: Always
Steps to Reproduce:
1. go to www.dibert.com: favicon shows in location bar
2. drag link to bookmarks toolbar
3. click on the bookmark icon

Actual Results:  
favicon not shown

Expected Results:  
favicon should be used

Comment 1

14 years ago
Probably a settings problem.
In 
  about:config 
add a new entry for chrome.browser.load_toolbar_icons with value set to 2 or 3.

Please report back if that fixes your problem.
(Reporter)

Comment 2

14 years ago
Sorry to disagree, but I don't think this is a settings problem, because the bug
does not affect all favicons. Dilbert is one of the sites where the bug occurs. 
Anyway, I tried your suggestion, but to no avail. Emptying the cache didn't help
either.

*** This bug has been marked as a duplicate of 252401 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

14 years ago
This is not a duplicate of bug 252401.

Obviously, the display engine uses different code to display icons in the
location bar vs. icons in bookmarks. This should be changed so that the same
codes is used in both cases.

In my opinion, restricting the size, as suggested by bug 252401, is also not a
very good idea. An .ico-file can contain any number of icon sizes and display
depth. The engine should check whether the .ico file contains a valid format for
display and use it.

A good example ist http://www.heise.de/favicon.ico. It contains 6 images at
resolutions 16x16x8bbp, 32x32x8bpp, 48x48x8bpp, 16x16x32bpp, 32x32x32bpp and
48x48x32bpp. Its size is about 22KB.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 5

14 years ago
Related to bug 246946?
(Reporter)

Comment 6

14 years ago
(In reply to comment #5)
> Related to bug 246946?

Possibly. But I checked some of the favicons, they only contain one image.
So its either same or 2 differnet bugs.

BTW: What is so difficult about displaying an .ico????

Comment 7

14 years ago
this bug is a duplicate of bug 258867
however you mark it as such.
bug 252401 is blocking bug 258867 as well as this one since they're the same
thing basicly.

*** This bug has been marked as a duplicate of 258867 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.